Announcement Announcement Module
Collapse
No announcement yet.
import org.springframework does not work Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • import org.springframework does not work

    Hi,
    I would really appreciate some help. After having installed Spring in Eclipse, I am able to create Spring projects and everything seems to be fine. Nevertheless, if I try to use the framework by adding a statement like

    import org.springframework.(..)

    Eclipse tells me, that there is no package which starts with org.springframework. I assume some simple configuration error- but which one? Can anyone help?

    Many thanks!

    Cheers
    Martin

  • #2
    What do you mean by "installed Spring in Eclipse"?

    What you need is adding the spring jar (and dependency jars as necessary) to your compile time classpath of your project (Project | Properties | Java Build Path | Libraries).

    Regards,
    Andreas

    Comment


    • #3
      Hi Martin,

      by
      After having installed Spring in Eclipse
      do you actually mean that you installed Spring IDE?

      If so please note that Spring IDE does not add any libraries - like spring.jar - to your Eclipse java project. You need to do this yourself. This is by design and has been discussed in this forum thread.

      Let me know if this answers your question.

      Christian

      Comment


      • #4
        Hi,
        ok- I see that my statement "installed Spring in Eclipse" was not helpful. What I meant is the following: I used the Update functionality in Eclipse and added the corresponding entry as additional resource (I am not sitting in front of my PC, therefore it is difficult to mention details- if necessary I can add it in some hours.) and via Update Manager Spring installation has been done automatically. This is how I understood so far the installation process: Ecplise gets additional plugins and Spring.jar files are added to some local respository. As I saw in the referenced forum thread, Spring.jar is NOT automatically added. I will check it out in the evening. Many thanks so far!
        Cheers
        Martin

        Comment


        • #5
          Hi,
          in the meantime I could verify, that the reason was in fact the missing spring jar-files. Thanks a lot :-) Now, it works..
          Cheers
          Martin

          Comment

          Working...
          X