Announcement Announcement Module
Collapse
No announcement yet.
MyUsers (raible) Eclipse/Spring/Sysdeo/Tomcat start error Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • MyUsers (raible) Eclipse/Spring/Sysdeo/Tomcat start error

    Hi,

    I've been trying Matt Raible's myusers spring application. I have been setting up a number of non-spring applications using this configuraion. So far I've been able to run the myusers application fine outside of eclipse. However, once I try to configure and start eclipse/spring/sysdeo/tomcat the server never starts and tried to load the StandardContext class from the catalina.jar file. Here's the error stack:

    org.apache.catalina.startup.Bootstrap at localhost:2487
    Thread [main] (Suspended (exception NullPointerException))
    StandardContext.start() line: 4151
    StandardHost(ContainerBase).start() line: 1083
    StandardHost.start() line: 789
    StandardEngine(ContainerBase).start() line: 1083
    StandardEngine.start() line: 478
    StandardService.start() line: 480
    StandardServer.start() line: 2313
    Catalina.start() line: 556
    NativeMethodAccessorImpl.invoke0(Method, Object, Object[]) line: not available [native method]
    NativeMethodAccessorImpl.invoke(Object, Object[]) line: not available
    DelegatingMethodAccessorImpl.invoke(Object, Object[]) line: not available
    Method.invoke(Object, Object[]) line: not available
    Bootstrap.start() line: 284
    Bootstrap.main(String[]) line: 422
    Any ideas?
    Thanks,
    Kerry

  • #2
    Re: MyUsers (raible) Eclipse/Spring/Sysdeo/Tomcat start erro

    This tutorial should help you setup MyUsers in Eclipse.

    http://jroller.com/page/raible/20040...ers_in_eclipse

    Comment


    • #3
      Thanks Matt, so far I've been using that description. The project builds/deploys outside of eclipse okay (w ant/tomcat5.0 and eclipse-plugins-1.2.zip you suggested). The other thing I'm able to do is run/debug in eclipse the jpetstore app as well (w tomcat 4.1 not 5.0)? Strange, when I try to setup the myusers (w tomcat 5.0 and eclipse-plugins-1.2.zip you suggested) I keep getting this "StandardContext.start() NullPointerException condition. My eclipse setup is pretty much as you suggest. There are no good error messages (no logs) or at the console.

      Kerry

      Comment


      • #4
        Hmmm, what OS are you using? What version of Eclipse? Can you reproduce it on another machine?

        Matt

        Comment


        • #5
          here is what I have:

          spring-framework-1.0-rc2
          tomcat 5.0
          com.sysdeo.eclipse.tomcat_3.0.0.beta
          eclipse 3.0.0 Build id: 200312182000
          windows 2000
          j2sdk1.4.2_05

          as I said it works fine as a ant emacs build/deploy environment, once I move (and remove any traces in tomcat before hand) to eclipse build and try to run I get this internal bootstrap error condition?

          org.apache.catalina.startup.Bootstrap at localhost:2487
          Thread [main] (Suspended (exception NullPointerException))
          StandardContext.start() line: 4151

          thanks,
          Kerry

          Comment


          • #6
            Honesty, I don't know. I've been able to setup the Tomcat plugin with Eclipse on Suse 9.1, Win XP and OS X w/o issues. I'm guessing it's something with your Tomcat Plugin settings - you have it pointing to the proper Tomcat home directory?

            Comment

            Working...
            X