Announcement Announcement Module
Collapse
No announcement yet.
getting error for org.mortbay.jetty (5.1.11) and javax.servlet (2.4.0) Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • getting error for org.mortbay.jetty (5.1.11) and javax.servlet (2.4.0)

    Hello,

    I am trying to include spring ide 2.0-rc2 in my eclipse environment. I have installed the dependencies - such as GEF, WTP etc. When I try to install the spring ide archieved file springide_updatesite_dev_2.0-rc2_v200706171744 from eclipse Help->Software Updates->Find and Install, it gives me the following error. I am not sure what I need to do. Please help.

    The current configuration contains errors and this operation can have unpredictable results.
    WST Web Services Core (2.0.0.v200706041905-7G7PE_QEDx2WYLY3o9oX7C) requires plug-in "javax.servlet (2.4.0)", or compatible.
    WST Server Adapters (2.0.0.v200706041905-4--_kE77Y7QI7EEEQ) requires plug-in "org.mortbay.jetty (5.1.11)", or compatible.

  • #2
    Ditto:

    I'm running Eclipse on Ubuntu and also have had difficulty with getting the Spring IDE working. The org.mortbay.jetty missing shows up and seemingly cannot be resolved using the "Select Required" button.

    Any ideas?

    Comment


    • #3
      Quick follow-up

      On Ubuntu this version installs fine at first glance;
      http://springide.org/updatesite_1.x/

      Comment


      • #4
        Hi,

        I don't have any problems installing Spring IDE 2.0 in Eclipse 3.3 on Ubuntu.

        WST Web Services Core (2.0.0.v200706041905-7G7PE_QEDx2WYLY3o9oX7C) requires plug-in "javax.servlet (2.4.0)", or compatible.
        WST Server Adapters (2.0.0.v200706041905-4--_kE77Y7QI7EEEQ) requires plug-in "org.mortbay.jetty (5.1.11)", or compatible.
        The missing plugins can be installed from the Eclipse Europa Update Site and aren't related to Spring IDE.

        Christian

        Comment


        • #5
          Sounds Good

          I'll retry on Monday and see if it works. I had tried many combinations of resolving the Spring IDE 2.0 problem and some would finish but not really install the IDE.

          Comment


          • #6
            cdupuis: question

            When you say you have no problem installing the Spring IDE, what method are you referring to?

            One can install the IDE using Synaptic which installs Eclipse as well or, in my case, I already had Eclipse installed and attempted to use Eclipse's update management system to add the Spring IDE to an already customized Eclipse environment.

            The latter, is the route I have been trying with no luck.

            Comment


            • #7
              Hi,

              I normally use the pre-packaged Eclipse distros from http://www.eclipse.org/downloads/ (e.g. Java or Java EE developer version) and use Spring IDEs update site.

              I haven't tried it with Ubuntu's Package Manager.

              Christian

              Comment


              • #8
                Got Spring 2.0 on Eclipse 3.2 on Ubuntu

                Using Eclipse's Update management system, I added this source;

                http://springframework.sourceforge.n...pse/updatesite

                and it finally worked seamlessly.

                I had searched for an update site prior to this and tried it which had resulted in the errors and inability to add the missing components. no one seemed to mention Ubuntu by name and I may have inadvertently tried a vanilla Linux link of some kind.

                Nor was I aware that Spring and Eclipse are available through Synaptic when initially setting up Ubuntu. I downloaded Eclipse independently and had a bit of work in my pocket before realizing the oversight.

                Christian,

                Thanks for the helping hand. a number of similar threads ended in silent deadends so maybe this will help others.

                - Frank Krasicki

                Comment


                • #9
                  Hmmm,

                  That update site is damn old; only version 1.0.3. This does not give you support for Spring 2.0, AOP and Web Flow.

                  You should really try to use http://springide.org/updatesite as Eclipse Update Site. This is documented here.

                  Christian

                  Comment

                  Working...
                  X