Announcement Announcement Module
No announcement yet.
java.lang.ClassNotFoundException: org.springframework.ide.eclipse.core.internal.proj Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • java.lang.ClassNotFoundException: org.springframework.ide.eclipse.core.internal.proj


    My system :
    OS : Windows XP SP2
    Eclipse : 3.2.2
    Spring ide for spring 2.0.2

    My problem :
    After installation of spring-ide for spring 2 everything worked well, I had auto completion in bean ids and classes in my config files.
    But since 2 days I have the following error at eclipse start up :
    org.springframework.ide.eclipse.core was unable to load class org.springframework.ide.eclipse.core.internal.proj ect.SpringProjectBuilder.

    with the following stacktrace in the log :
    java.lang.ClassNotFoundException: org.springframework.ide.eclipse.core.internal.proj ect.SpringProjectBuilder
    at org.eclipse.osgi.framework.internal.core.BundleLoa der.findClass(
    at org.eclipse.osgi.framework.internal.core.BundleLoa der.findClass(
    at org.eclipse.osgi.internal.baseadaptor.DefaultClass Loader.loadClass(
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at org.eclipse.osgi.framework.internal.core.BundleLoa der.loadClass(
    at org.eclipse.osgi.framework.internal.core.BundleHos t.loadClass(
    at org.eclipse.osgi.framework.internal.core.AbstractB undle.loadClass(
    at org.eclipse.core.internal.registry.osgi.RegistrySt rategyOSGI.createExecutableExtension(RegistryStrat
    at org.eclipse.core.internal.registry.ExtensionRegist ry.createExecutableExtension(ExtensionRegistry.jav a:759)
    at org.eclipse.core.internal.registry.ConfigurationEl ement.createExecutableExtension(ConfigurationEleme
    at org.eclipse.core.internal.registry.ConfigurationEl ementHandle.createExecutableExtension(Configuratio
    at antiateBuilder(
    at ializeBuilder(
    at uilder(
    at cBuild(
    at$ n(
    at .java:37)
    at cBuild(
    at cBuildLoop(
    at d(
    at ild(
    at ava:58)

    I checked and the core.jar file is still in the plugins\org.springframework.ide.eclipse.core_1.9.0 directory.

    anyone can help ?

  • #2
    Originally posted by paskos View Post
    I checked and the core.jar file is still in the plugins\org.springframework.ide.eclipse.core_1.9.0 directory.
    It seems that you're running a mixup of Spring IDE 2.0 milestone releases.

    So please delete all Spring IDE-related features and plugins (starting with "org.springframework.*") from your local Eclipse installation and reinstall milestone 3 via the update manager.