Announcement Announcement Module
Collapse
No announcement yet.
Graph not showing connections anymore Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Graph not showing connections anymore

    I just did my usual Callisto update, and installed the latest nightly build, and the connections between beans are no longer drawn in the graph view. Reverting to a previous nightly build did not fix this, so I guess the Callisto update broke the graph rendering.

  • #2
    Hi Paul,

    I'm sorry to say but I think that you just discovered a bug in latest versions of Spring IDE. I think the refactoring and changes due to ticket #486 (http://springide.org/project/ticket/486) broke the graph view.

    We'll have a look into this. In the meanwhile I've created a ticket report at #492.

    Thanks for spotting and sharing this.

    Christian

    Comment


    • #3
      Originally posted by cdupuis View Post
      I'm sorry to say but I think that you just discovered a bug in latest versions of Spring IDE. I think the refactoring and changes due to ticket #486 broke the graph view.
      Christian is right. I wasn't able to finish all the stuff which was affected by implementing #486. Ticket #491 is left.

      I would like to suggest for getting back a working BeansGraph and BeansSearch you should install a nighly build older than 3rd of Feb 2007 and wait for #491 to be closed (it's the next on my list ).

      Comment


      • #4
        Originally posted by Torsten Juergeleit View Post
        Christian is right. I wasn't able to finish all the stuff which was affected by implementing #486. Ticket #491 is left.

        I would like to suggest for getting back a working BeansGraph and BeansSearch you should install a nighly build older than 3rd of Feb 2007 and wait for #491 to be closed (it's the next on my list ).
        Thanks for looking at this - I just backed out my update and will keep a look out for the fixes.

        Your work is HIGHLY appreciated !

        Comment


        • #5
          Originally posted by Torsten Juergeleit View Post
          I would like to suggest for getting back a working BeansGraph and BeansSearch you should install a nighly build older than 3rd of Feb 2007 and wait for #491 to be closed (it's the next on my list ).
          The connections in the BeansGraph are back now.

          Comment


          • #6
            The fix, and hopefully only the fix , made it into today's nighty build. You can test it in build version 2.0.0.v200703060600.

            Christian

            Comment


            • #7
              Originally posted by cdupuis View Post
              The fix, and hopefully only the fix , made it into today's nighty build. You can test it in build version 2.0.0.v200703060600.

              Christian
              Yes, all working now - thanks !

              Any idea when the flow visualization will be available, and how will you be able to view a flow using this ?

              Comment


              • #8
                Originally posted by Paul Newport View Post
                Any idea when the flow visualization will be available, and how will you be able to view a flow using this ?
                I'm currently shaping the graphical editor and prepare it for its public release. It will basically work as described at http://springide.org/project/wiki/WebFlowEditor.

                Knowing that the corresponding ticket is close to two years old, you can actually start counting the hours until M3 with Web Flow Editor comes out.

                Hope that helps

                Christian

                Comment

                Working...
                X