Announcement Announcement Module
Collapse
No announcement yet.
help : webflow editor doesn't work !! (spring-webflow-1.0-rc3.zip) Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • help : webflow editor doesn't work !! (spring-webflow-1.0-rc3.zip)

    Dear all,

    I am a novice in spring and I want to create a project with the webflow editor.

    I am using Eclipse 3.2 (callisto) with Spring IDE 1.3.2 (work ok) and I downloaded Spring WebFlow Editor (spring-webflow-1.0-rc3.zip) but I can't find a doc for its instalation to include it into eclipse. I would like to have in my eclipse the editor like in this page http://springide.org/project/wiki/WebFlowEditor .

    thank you for any help or advice

  • #2
    help : webflow editor doesn't work !! (spring-webflow-1.0-rc3.zip)

    Unfortunately that rc3.zip will not do any good to your IDE. You will have manually configure the Webflow in your IDE. I am assuming that you have all the Eclipse UI and spring IDE configured.

    Here is how you do it.

    goto this URL http://springide.org/updatesite_dev/plugins/

    get the following files
    org.springframework.ide.eclipse.web.flow.core_0.0. 3.jar
    org.springframework.ide.eclipse.web.flow.ui.editor _0.0.3.jar
    org.springframework.ide.eclipse.web.flow.ui_0.0.3

    then goto this URL http://springide.org/updatesite_dev/features/
    get this file

    org.springframework.ide.eclipse.web.flow_0.0.3.jar

    explode these files in respective directories of eclipse plugins and features.

    Make sure that your create separate directories for each of these jar and then explode into it. It will be easier to maintain.

    Once all of the above step are done then just restart your eclipse and you should be able to show view for Webflow.

    Comment


    • #3
      Hi,

      thank's for your configuration setup.

      Unfortunately, when I open a flow definition I get the following exception:
      ava.lang.ClassCastException: org.eclipse.ui.part.FileEditorInput
      at org.springframework.ide.eclipse.web.flow.ui.editor .WebFlowEditor.superSetInput(WebFlowEditor.java:75 6)
      at org.springframework.ide.eclipse.web.flow.ui.editor .WebFlowEditor.setInput(WebFlowEditor.java:723)
      at org.eclipse.gef.ui.parts.GraphicalEditor.init(Grap hicalEditor.java:318)
      at org.eclipse.ui.internal.EditorManager.createSite(E ditorManager.java:839)
      at org.eclipse.ui.internal.EditorReference.createPart Helper(EditorReference.java:583)
      at org.eclipse.ui.internal.EditorReference.createPart (EditorReference.java:372)
      ....


      The Webflow Property Dialog (Projekt->Properties->Webflow) is empty and an error message "invalid values on page" appears.

      With SpringIde 1.3.4 I had no luck at all (don't even open the editor).

      Any Idea's how to solve the problems for Eclipse 3.2, SpringIde 1.3.2 ???

      Thank you very much in advance,

      Timmo (from Berlin)

      Comment

      Working...
      X