Announcement Announcement Module
Collapse
No announcement yet.
Is Spring Framework plugin available for WSAD Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    No, No memory issues. I used these:
    -vmargs -Xms90m -Xmx256m and I have 2 GB machine. Not sure if you need to adjust depending on your memory amount.

    Comment


    • #17
      Hi

      I'm getting an error whenever trying to run Junit test WSAD 5.1.2

      Console[<terminated> C:\j2sdk1.4.2_05\bin\javaw.exe
      Error occurred during initialization of VM
      java/lang/NoClassDefFoundError: java/lang/Object

      Comment


      • #18
        Hi,

        I am using Spring IDE for WSAD 5.1.2 with JRE 1.3.1 and it works well.

        The plugin Graphicial Editing Framework 2.1.3 should already be installed in WSAD 5.1.2. Do not install the GEF 3.0.1, because it needs Eclipse 3.0!

        I have installed the updatesite_1.0.3 for the eclipse-ide.

        Regards,

        Etienne.

        Comment


        • #19
          Forget the last reply, I was using jre 1.4.

          Comment


          • #20
            Hi everyone,

            I've followed the above steps to get Spring to work with WSAD 5.1.2 and now 'm trying to figure out to install the jPetStore sample that comes with the framework....any takers?? Thanks!

            Comment


            • #21
              Please refer to Dan Dobrin's description here in this forum.

              Torsten

              Comment


              • #22
                Thanks Torsten.

                Before I proceed any further down this path, I wanted to make sure that running the latest version of Spring (Framework and IDE) is even possible with WSAD 5.1.2 Lots of posts I have seen around the web seem to suggest that you cannot.

                If it's not possible, which IBM IDE do I need to get to make it work? Thanks

                Comment


                • #23
                  Spring IDE 1.2.5 requires Eclipse 3.0 (or newer) with JDK 1.4.1 (or newer). So you need a version of WSAD which fulfills these requirements.

                  For versions of WSAD which are based on Eclipse 2 or running on JDK 1.3 you have to stick with Spring IDE 1.1.1 (the last version of Spring IDE which supports Eclipse 2 and JDK 1.3).

                  Torsten

                  Comment


                  • #24
                    Running RationalSDP with Sun Java

                    I have rationalSDP and I tried following these steps and it did not work.

                    DIfferences:
                    1. The exe file is "rationalsdp.exe" instead of "wsappdev.exe"
                    2. The config file is called rationalsdp.ini

                    When I run the shortcut I get the eclipse error dialog

                    JVM terminated. Exit code=1
                    etc...
                    see attached file error.jpg

                    Can you tell me what I need to do to get rationalsdp running with the Sun Java VM instead of the IBM VM?

                    Thanks.

                    sdeo

                    Originally posted by 2devnull
                    To get WSAD to run on a different JRE do the following (assuming Windows platform):

                    1. Create a shortcut

                    2. Put this in the target field (adjust path for your system):
                    "C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\wsappdev.exe" -vm "C:\j2sdk1.4.2_04\jre\bin\java.exe" -vmargs -Xms90m -Xmx256m

                    3. Put your workspace in the Start in field (adjust path for your system):
                    "C:\Documents and Settings\2devnull\My Documents\IBM\wsappdev51\spring"

                    4. Remove the line VMArgs=-Xj9 from wsappdev.ini (usually found in C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2) (THIS IS THE KEY, OR IT WOULDN'T WORK)

                    5. Restart WSAD using the Shortcut

                    BTW: Torsten Juergeleit had helped me with this. I have the Spring plugin working just fine.




                    *** System properties:
                    awt.toolkit=sun.awt.windows.WToolkit
                    catalina.base=C:/Program Files/IBM/WebSphere Studio/Application Developer/v5.1.2/eclipse/plugins/org.eclipse.tomcat_4.0.6.2/
                    catalina.home=C:/Program Files/IBM/WebSphere Studio/Application Developer/v5.1.2/eclipse/plugins/org.eclipse.tomcat_4.0.6.2/
                    catalina.useNaming=true
                    file.encoding=Cp1252
                    file.encoding.pkg=sun.io
                    file.separator=\
                    java.awt.graphicsenv=sun.awt.Win32GraphicsEnvironm ent
                    java.awt.printerjob=sun.awt.windows.WPrinterJob
                    java.class.path=C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\.\eclipse\startup.jar
                    java.class.version=48.0
                    java.endorsed.dirs=C:\j2sdk1.4.2_04\jre\lib\endors ed
                    java.ext.dirs=C:\j2sdk1.4.2_04\jre\lib\ext
                    java.home=C:\j2sdk1.4.2_04\jre
                    java.io.tmpdir=C:\DOCUME~1\2devnull\LOCALS~1\Temp\
                    java.library.path=C:\j2sdk1.4.2_04\jre\bin;
                    java.naming.factory.initial=org.apache.naming.java .javaURLContextFactory
                    java.naming.factory.url.pkgs=org.apache.naming
                    java.runtime.name=Java(TM) 2 Runtime Environment, Standard Edition
                    java.runtime.version=1.4.2_04-b05
                    java.specification.name=Java Platform API Specification
                    java.specification.vendor=Sun Microsystems Inc.
                    java.specification.version=1.4
                    java.util.prefs.PreferencesFactory=java.util.prefs .WindowsPreferencesFactory
                    java.vendor=Sun Microsystems Inc.
                    java.vendor.url=http://java.sun.com/
                    java.vendor.url.bug=http://java.sun.com/cgi-bin/bugreport.cgi
                    java.version=1.4.2_04
                    java.vm.info=mixed mode
                    java.vm.name=Java HotSpot(TM) Client VM
                    java.vm.specification.name=Java Virtual Machine Specification
                    java.vm.specification.vendor=Sun Microsystems Inc.
                    java.vm.specification.version=1.0
                    java.vm.vendor=Sun Microsystems Inc.
                    java.vm.version=1.4.2_04-b05
                    line.separator=

                    Comment


                    • #25
                      Originally posted by Torsten Juergeleit
                      A little typo: "Spring IDE - Beans Configuration Support 1.0.3"

                      Regards,
                      Torsten
                      Hi,

                      I installed Spring Plug-in in my WSAD. I can also view the SpringIDE in my Show view window. But I can't change my project in Spring Nature by right clicking the project.

                      Please help me out.

                      Rgds/Ramesh.

                      Comment

                      Working...
                      X