Announcement Announcement Module
Collapse
No announcement yet.
Is Spring Framework plugin available for WSAD Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Is Spring Framework plugin available for WSAD

    Hi,

    I'm looking for a Spring plugin I can use in my Websphere Studio Application Developer 5.1.2

    Is there a working example in WSAD that I can download?

    Thank you

  • #2
    Spring IDE should work with WSAD too. You only have to use a recent JRE (preferably v1.4.2) instead of IBM's JRE J9 (v1.3) which ships with WSAD.

    Regards,
    Torsten

    Comment


    • #3
      How do you get WSAD to actually run under a different JRE? It's simple to select a different JDK for building projects etc, but I thought the IDE itself was hard linked to the IBM JDK..?

      Comment


      • #4
        To change to different JRE, go to window->preferences->Java->Installed JRE's

        Comment


        • #5
          Originally posted by theone
          To change to different JRE, go to window->preferences->Java->Installed JRE's
          In WSAD that doesn't affect the JRE used to actually run the IDE unless I'm missing something. Dumping config settings (after switching to Sun JDK 1.4 for example and restarting the IDE) shows that J9 is still being used.

          Comment


          • #6
            Originally posted by davison
            How do you get WSAD to actually run under a different JRE? It's simple to select a different JDK for building projects etc, but I thought the IDE itself was hard linked to the IBM JDK..?
            I don't know WSAD. But if it's similar to Eclipse then the launcher may support an option to specify a JRE. Eclipse's eclipse.exe provides the option "-vm" for this. For details please refer to Eclipse / WSAD online help "Workbench User Guide / Tasks / Running Eclipse").

            Regards,
            Torsten

            Comment


            • #7
              To get WSAD to run on a different JRE do the following:

              To get WSAD to run on a different JRE do the following (assuming Windows platform):

              1. Create a shortcut

              2. Put this in the target field (adjust path for your system):
              "C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\wsappdev.exe" -vm "C:\j2sdk1.4.2_04\jre\bin\java.exe" -vmargs -Xms90m -Xmx256m

              3. Put your workspace in the Start in field (adjust path for your system):
              "C:\Documents and Settings\2devnull\My Documents\IBM\wsappdev51\spring"

              4. Remove the line VMArgs=-Xj9 from wsappdev.ini (usually found in C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2) (THIS IS THE KEY, OR IT WOULDN'T WORK)

              5. Restart WSAD using the Shortcut

              BTW: Torsten Juergeleit had helped me with this. I have the Spring plugin working just fine.




              *** System properties:
              awt.toolkit=sun.awt.windows.WToolkit
              catalina.base=C:/Program Files/IBM/WebSphere Studio/Application Developer/v5.1.2/eclipse/plugins/org.eclipse.tomcat_4.0.6.2/
              catalina.home=C:/Program Files/IBM/WebSphere Studio/Application Developer/v5.1.2/eclipse/plugins/org.eclipse.tomcat_4.0.6.2/
              catalina.useNaming=true
              file.encoding=Cp1252
              file.encoding.pkg=sun.io
              file.separator=\
              java.awt.graphicsenv=sun.awt.Win32GraphicsEnvironm ent
              java.awt.printerjob=sun.awt.windows.WPrinterJob
              java.class.path=C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\.\eclipse\startup.jar
              java.class.version=48.0
              java.endorsed.dirs=C:\j2sdk1.4.2_04\jre\lib\endors ed
              java.ext.dirs=C:\j2sdk1.4.2_04\jre\lib\ext
              java.home=C:\j2sdk1.4.2_04\jre
              java.io.tmpdir=C:\DOCUME~1\2devnull\LOCALS~1\Temp\
              java.library.path=C:\j2sdk1.4.2_04\jre\bin;
              java.naming.factory.initial=org.apache.naming.java .javaURLContextFactory
              java.naming.factory.url.pkgs=org.apache.naming
              java.runtime.name=Java(TM) 2 Runtime Environment, Standard Edition
              java.runtime.version=1.4.2_04-b05
              java.specification.name=Java Platform API Specification
              java.specification.vendor=Sun Microsystems Inc.
              java.specification.version=1.4
              java.util.prefs.PreferencesFactory=java.util.prefs .WindowsPreferencesFactory
              java.vendor=Sun Microsystems Inc.
              java.vendor.url=http://java.sun.com/
              java.vendor.url.bug=http://java.sun.com/cgi-bin/bugreport.cgi
              java.version=1.4.2_04
              java.vm.info=mixed mode
              java.vm.name=Java HotSpot(TM) Client VM
              java.vm.specification.name=Java Virtual Machine Specification
              java.vm.specification.vendor=Sun Microsystems Inc.
              java.vm.specification.version=1.0
              java.vm.vendor=Sun Microsystems Inc.
              java.vm.version=1.4.2_04-b05
              line.separator=

              Comment


              • #8
                2devnull,

                Can you help me get Spring working in my WSAD? Examples will be great too.

                Thanks in advance

                Comment


                • #9
                  1. Open your Install/Update perspective.

                  2. Right click on the 'Features Update' pane and select NEW-> Site Bookmark...

                  3. In the Name: put 'Spring IDE'

                  4. In the URL put 'http://springframework.sourceforge.net/spring-ide/eclipse/updatesite/'

                  5. Leave the rest as defaults

                  6. Click Finish

                  7. Expand the bookmark (Spring Framework and Spring IDE) and install Spring Framework 1.0.2 and Spring IDE - Beans Configuration Support 1.0.3

                  8. Close WSAD and restart using shortcut (the one created to use JRE 1.4 - see post above)

                  9. In Web perspective, right click on your project folder and select Add Spring Beans Project Nature

                  10. Now you can use it Windows->Show View->Other->Spring IDE->Spring Beans

                  Comment


                  • #10
                    Originally posted by 2devnull
                    7. Expand the bookmark (Spring Framework and Spring IDE) and install Spring Framework 1.0.2 and Spring IDE - Beans Configuration Support 1.0.2
                    A little typo: "Spring IDE - Beans Configuration Support 1.0.3"

                    Regards,
                    Torsten

                    Comment


                    • #11
                      Originally posted by Torsten Juergeleit

                      A little typo: "Spring IDE - Beans Configuration Support 1.0.3"
                      Thanks. fixed it.

                      Comment


                      • #12
                        Thanks for the help in setting up Spring in WSAD, 2devnull and Torsten.

                        Now I got the evirnoment set up. Can you tell me why I'm getting this error when I start up the test server? Why is the parent context null?

                        5:00] 3ceab98c DispatcherSer I org.springframework.web.servlet.DispatcherServlet Initializing servlet 'springapp'
                        [8/17/04 16:46:55:774 GMT-05:00] 3ceab98c DispatcherSer I org.springframework.web.servlet.DispatcherServlet Framework servlet 'springapp' init
                        [8/17/04 16:46:55:774 GMT-05:00] 3ceab98c WebGroup I SRVE0180I: [SpringWeb] [/SpringWeb] [Servlet.LOG]: Initializing WebApplicationContext for servlet 'springapp'
                        [8/17/04 16:46:55:794 GMT-05:00] 3ceab98c DispatcherSer I org.springframework.web.servlet.DispatcherServlet Servlet with name 'springapp' will try to create custom WebApplicationContext context of class 'org.springframework.web.context.support.XmlWebApp licationContext' using parent context [null]
                        [8/17/04 16:46:56:074 GMT-05:00] 3ceab98c XmlBeanDefini I org.springframework.beans.factory.xml.XmlBeanDefin itionReader Loading XML bean definitions from resource [/WEB-INF/springapp-servlet.xml] of ServletContext
                        [8/17/04 16:46:56:194 GMT-05:00] 3ceab98c DispatcherSer E org.springframework.web.servlet.DispatcherServlet Context initialization failed
                        [8/17/04 16:46:56:275 GMT-05:00] 3ceab98c DispatcherSer E org.springframework.web.servlet.DispatcherServlet TRAS0014I: The following exception was logged org.springframework.beans.factory.BeanDefinitionSt oreException: Error registering bean with name 'springappController' defined in resource [/WEB-INF/springapp-servlet.xml] of ServletContext: Bean class [SpringappController] not found; nested exception is java.lang.ClassNotFoundException: SpringappController
                        java.lang.ClassNotFoundException: SpringappController
                        at com.ibm.ws.classloader.CompoundClassLoader.findCla ss(CompoundClassLoader.java(Compiled Code))
                        at com.ibm.ws.classloader.CompoundClassLoader.loadCla ss(CompoundClassLoader.java:300)
                        .....

                        Comment


                        • #13
                          NP...it appears SpringappController is defined in springapp-servlet.xml but not in your build path.

                          Comment


                          • #14
                            SpringWeb/Java Resources is in my build path though

                            Comment


                            • #15
                              2devnull,

                              Do you have a memory issue running WSAD through the created shortcut?

                              After running for a short while, the memory usages are registered as:

                              Java.exe +200,000K
                              javaw.exe +100,000K

                              Eventually Websphere gives me "Out of memory error"

                              And I still have the Bean class not found error

                              Thanks

                              Comment

                              Working...
                              X