Announcement Announcement Module
Collapse
No announcement yet.
Problem Adding Spring Project Nature Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem Adding Spring Project Nature

    Hi, all.

    I just added WTP 1.0.2 and SpringIDE 1.3 to Eclipse 3.1.2. I am running in a Linux environment.

    When I try to add the Spring project nature to an existing project, I get the following error:

    NLS missing message: ProjectNature_addError in: org.springframework.ide.eclipse.beans.ui.SpringUIM essages.

    Has anyone encountered this error before or have an idea what I have done wrong?

    Thanks,

    Matt Stine

  • #2
    Matt,

    this error indicates that you are using the developer preview version of Spring IDE 1.3 which was available on the developer updatesite.

    Please delete this version of Spring IDE from your Eclipse installation and install the final version of Spring IDE 1.3 from the official updatesite http://springide.org/updatesite/ as described here.

    Torsten

    Comment


    • #3
      Torsten,

      I originally followed the instructions at the link you provided to install Spring IDE. I tried to update from there but Eclipse said there were no new updates available.

      Matt

      Comment


      • #4
        Originally posted by mstine
        I tried to update from there but Eclipse said there were no new updates available.
        That's because you already installed a version 1.3 of Spring IDE (the developer preview and the final version have the same plugin version number). So you have to manually delete all Spring IDE related stuff from your Eclipse installation (<Eclipse Home>/[features|plugins]/org.springframework.ide.eclipse*) and install the final version of Spring IDE 1.3 from the official updatesite again.

        Torsten

        Comment

        Working...
        X