Announcement Announcement Module
Collapse
No announcement yet.
Spring IDE 1.3 cannot find beans defined in a different xml file? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring IDE 1.3 cannot find beans defined in a different xml file?

    When I was using 1.2.5, only in one of my web project that Spring IDE was able to find beans defined in different xml file. But in this 1.3 version, that project was dead as well.

    Here's what I was doing
    Code:
    <bean id="action.suncorpForm" class="au.com.auscript.web.firmuser.flow.SuncorpFormFlowAction">
    	<property name="interviewService">
    		<ref bean="interviewService"></ref>
    	</property>
    </bean>
    The bean 'interviewService' is defined in another xml file, I added both file into Spring Beans config, but it still issued warning of 'Referenced bean interviewService not found'.

    That's really annoying cos it added more than 100 warnings into my Eclipse project.

    I didn't use 'import' to include the other xml file into the current one as I think the new version of Spring doesn't required that.

    I'm using the latest version of Lomboz (it's basically an eclipse 3.1, hopefully u've heard about it)

    Any thoughts?

  • #2
    Spring IDE needs a little help here

    You have to provide a hint which BeansConfig files are combined in a single Spring ApplicationContext. Therefore Spring IDE supports the notion of BeansConfigSets.

    Torsten

    Comment


    • #3
      Thanks

      I did have a config set and my eclipse was able to find beans in other xml files. But after I upgrade one of the plugin it then stop working.

      I removed the config set and added again, it's working now, thanks!

      Comment


      • #4
        Originally posted by Torsten Juergeleit
        Spring IDE needs a little help here

        You have to provide a hint which BeansConfig files are combined in a single Spring ApplicationContext. Therefore Spring IDE supports the notion of BeansConfigSets.

        Torsten
        ahhh. i was having exactly the same problem and this post fixed the problem for me. thanks.

        Comment

        Working...
        X