Announcement Announcement Module
Collapse
No announcement yet.
Does Spring IDE 1.2.5 work with Eclipse 3.1.2? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Does Spring IDE 1.2.5 work with Eclipse 3.1.2?

    My Problems (well, the ones concerning SpringIDE)

    I have SpringIDE 1.2.5 installed in Eclipse 3.1.2.

    It seems like the plugin does nothing - when I "Add Spring Project Nature" to a project, no decorator appears on the project. When I open the Spring Beans view, it's empty (no beans are shown) and there's no buttons to add my config files. I've successfully used earlier versions of the plugin in earlier versions of Eclipse, so I don't think it's pilot error.

    What's more, in Eclipse's Help->About dialog, there's two square "Spring" icons shown (with slightly different images). Clicking one of these shows the Spring IDE version number "1.2.5", while clicking the other shows "1.1.1".

    I've tried using Eclipse Update Manager to search for newer versions, but none are found.

    My Questions

    1. Is the Spring IDE meant to work in Eclipse 3.1.2?
    2. Even if it's not officially supported, does anyone know how to completely uninstall all versions of the plugin, so I can reinstall 1.2.5 from scratch to see if it does in fact work?
    3. Are there meant to be two SpringIDE icons in the About dialog?
    4. I think I read that there were two versions of the 1.2.5 plugin. How can I make sure I have the later one?

    TIA,

    Andrew

  • #2
    Some answers to my own questions...

    In case anyone is interested:

    2. This can be done via Help -> Software Updates* -> Manage Configuration; disable then uninstall any plugins you don't want. After I did this, there were still some SpringIDE jars showing in Help -> About -> Plug-in Details, so I shut down Eclipse and dragged all folders named like "org.springframework.ide.*" out of my Eclipse plugins folder.
    3. After doing the above and reinstalling 1.2.5, there's only one, so I'd say not.
    4. Since I installed from scratch, I'm trusting that the update site gave me the latest one.

    Anyway, the plugin seems to work now, although I've not tested it exhaustively.

    HTH,

    Andrew

    P.S. But I'd still like an answer to (1) if possible...

    * how are software updates "help" ???

    Comment


    • #3
      Originally posted by andrews
      1. Is the Spring IDE meant to work in Eclipse 3.1.2?
      Yes.

      The answers to your other questions are correct :-)

      Torsten

      Comment


      • #4
        Is the Wiki out of date?

        Hi Torsten,

        Thanks for answering so quickly. I got the impression from this page:

        http://springide.org/project/wiki/SpringideInstall

        ... that Eclipse 3.1.1 was required. Does that page need updating?

        Andrew

        Comment


        • #5
          Originally posted by andrews
          ... that Eclipse 3.1.1 was required. Does that page need updating?
          Fixed. Thanx for spotting this.

          Torsten

          Comment

          Working...
          X