Announcement Announcement Module
Collapse
No announcement yet.
STS 3.3.0 not runnig on W7 ? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS 3.3.0 not runnig on W7 ?

    For some reason I am not able to run STS on Windows 7. My JAVA points to Java7. Java6 required by STS is installed. The attached screenhot shows the log window and system specs.


    Attachment
    Attached Files

  • #2
    Hey!

    Unfortunately the screenshots are a bit low res, so I cannot read anything on them. Did you use the installer to install STS 3.3.0 on your machine? And is everything 64bit (Windows, JDK, and STS, or everything 32bit, depending on your setup)?

    In case you would like to check the JVM that is being configured for running STS, this is defined in the STS.ini file. Can you check that as well?

    HTH,
    Martin

    Comment


    • #3
      I am using 32bit JDK on 64bit Windows machine. STS 64bit has been installed from the installer.

      This is my STS.ini file:
      -vm
      C:\Program Files (x86)\Java\jdk1.7.0_13\bin\javaw.exe
      -startup
      plugins/org.eclipse.equinox.launcher_1.3.0.v20130327-1440.jar
      --launcher.library
      plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1. 1.200.v20130521-0416
      -product
      org.springsource.sts.ide
      --launcher.defaultAction
      openFile
      --launcher.XXMaxPermSize
      256M
      -vmargs
      -Dosgi.requiredJavaVersion=1.6
      -Xms40m
      -Xmx768m
      -XX:MaxPermSize=256m

      Java configuration:
      Your Java configuration is as follows: Vendor: Oracle Corporation Version: Java SE 7 Update 13 Operating System: Windows 7 6.1 Java Architecture: 32-bit

      Perhaps I am not allowed to use JDK 32-bit with STS 64bit on 64bit machine?

      PS: For some reasons the forum engine uploads the thumbnail of the original high-res image. This is a link to the original file : http://www.fileswap.com/dl/7CPFlP5i59/
      Last edited by lmiroslaw; Aug 13th, 2013, 03:35 AM. Reason: small image uploaded

      Comment


      • #4
        To start you would need the 64bit version of java... Further on (for your projects) you should be able to use the other version.

        Comment


        • #5
          Hey!

          Marten is correct. You need to run STS 64bit with the JDK for 64bit (or 32bit each), but you cannot mix that. You can run 32bit stuff on your 64bit Windows machine, but you cannot mix a 64bit STS and a 32bit JDK. In your case I would recommend to run the 64bit JDK.

          Cheers,
          -Martin

          Comment


          • #6
            Thanks! I downloaded STS 32bit and it helped.

            Comment


            • #7
              Glad to hear you got it working.
              And thanks for letting us know!

              Cheers,
              -Martin

              Comment

              Working...
              X