Announcement Announcement Module
Collapse
No announcement yet.
STS 3.3.0.RELEASE don't recognize '[environment]* war' Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS 3.3.0.RELEASE don't recognize '[environment]* war'

    Hi

    Im using STS 3.3.0.RELEASE and when I need to specify the enviroment for my grails war, it breaks.

    dev war

    produces

    | Loading Grails 2.2.0
    | Configuring classpath
    | Running pre-compiled script
    | Script 'Dev war' not found, did you mean:
    1) War
    2) RunWar
    3) InstallDependency
    4) DependencyReport
    5) Upgrade
    > Please make a selection or enter Q to quit:

    With 3.2 it works fine.

  • #2
    First, what's your full environment? I ask because I'm seeing the same problem with externally added Grails. Have you tried upgrading to the internal 2.2.3?

    Comment


    • #3
      This is the bug that you are probably running into:
      https://issuetracker.springsource.com/browse/STS-3468

      Note that you will also hit this bug even when 'keep running' option is enabled if using a version of Grails older than 2.2.0.
      That's because the keep running option is not supported prior to 2.2.0 and silently ignored.

      Keep an eye on the bug report for developments. A fix should be available from nightly update site shortly.

      Kris

      Comment


      • #4
        Thanks, that seems to be the problem.

        My environment is:

        Windows 7
        Java 1.6.0_32
        Grails 2.2.0
        Groovy Compiler 2.0.7
        STS 3.3.0.RELEASE

        I have checked "Keep external Grails Running" and the command have success.

        Comment


        • #5
          > I have checked "Keep external Grails Running" and the command have success.

          Great! If that works for you, an added benefit is that commands will probably execute a little faster as well.

          Kris

          Comment

          Working...
          X