Announcement Announcement Module
Collapse
No announcement yet.
STS reports an incompatible workspace version after upgrading to 3.3.0.RELEASE Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS reports an incompatible workspace version after upgrading to 3.3.0.RELEASE

    Hi all,

    Version: 3.3.0.RELEASE
    Build Id: 201307092139

    I upgraded to STS 3.3.0 last night (from 3.2.<something> I think... I forget exactly what). Everything looked fine, the initial post-upgrade restart went fine, until I later closed and tried to re-open STS at which point it refused to start.

    Found this in <workspace>/.metadata/.log

    Code:
    !ENTRY org.eclipse.osgi 4 0 2013-07-11 09:05:40.432
    !MESSAGE Application error
    !STACK 1
    java.lang.NoClassDefFoundError: org/eclipse/core/resources/IContainer
            at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:125)
            at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
            at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
            at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:597)
            at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
            at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
            at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
            at org.eclipse.equinox.launcher.Main.main(Main.java:1414)
    Caused by: org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter$TerminatingClassNotFoundException: An error occurred while automatically activating bundle org.eclipse.core.resources (142).
            at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:122)
            at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:469)
            at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:216)
            at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:395)
            at org.eclipse.osgi.internal.loader.SingleSourcePackage.loadClass(SingleSourcePackage.java:35)
            at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:461)
            at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:421)
            at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:412)
            at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
            ... 14 more
    Caused by: org.eclipse.core.internal.resources.ResourceException: Incompatible file format. Workspace was saved with an incompatible version: 1145119490.
            at org.eclipse.core.internal.resources.WorkspaceTreeReader.getReader(WorkspaceTreeReader.java:58)
            at org.eclipse.core.internal.resources.WorkspaceTreeReader.getReader(WorkspaceTreeReader.java:66)
            at org.eclipse.core.internal.resources.SaveManager.restoreTree(SaveManager.java:1000)
            at org.eclipse.core.internal.resources.SaveManager.restore(SaveManager.java:687)
            at org.eclipse.core.internal.resources.SaveManager.startup(SaveManager.java:1528)
            at org.eclipse.core.internal.resources.Workspace.startup(Workspace.java:2502)
            at org.eclipse.core.internal.resources.Workspace.open(Workspace.java:2251)
            at org.eclipse.core.resources.ResourcesPlugin.start(ResourcesPlugin.java:439)
            at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
            at java.security.AccessController.doPrivileged(Native Method)
            at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
    I know I can simply delete my workspace and start again but it's somewhat of a monster and is the result of a long duration of careful curation... So I could really do without trying to remember what settings and plugins I've used over the last few years while I try to do this morning's work :-)

    Anyone have any ideas for specific things (plugins etc) I could remove from the workspace to try and get it to load?

    Many thanks,

    Edd

  • #2
    Try restarting with the -clean option. From the command line: STS.exe -clean (if on windows) or STS -clean (otherwise).

    Comment


    • #3
      Sorry, forgot to mention that I'd tried that already, sadly to no avail. Actually I managed to sort the problem though by arming myself with BeyondCompare and gradually pulling over plugins, config etc until I'd got enough to get things working. Rather messy approach and unfurtunately it didn't illuminate the root cause of the issue but at least it unblocked my dev work this morning! :-)

      Comment


      • #4
        Hey!

        First of all I am glad to hear that you solved this issue. As an alternative to your approach, I would also recommend to start with a fresh STS installation. That doesn't mean that you have to throw away your carefully curated workspace. You should be able to continue to use that existing workspace, but with a fresh STS installation.

        Just an additional thought...

        Cheers,
        -Martin

        Comment

        Working...
        X