Announcement Announcement Module
Collapse
No announcement yet.
Troubles installing STS Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Troubles installing STS

    I'm currently trying to install STS in Eclipse Juno 4.2.2.

    I've set up a separate configuration for running Eclipse with STS, so I'm running Eclipse with
    Code:
    eclipse -configuration /path/to/custom/configuration
    command line option. This actually starts eclipse with a new configuration stored in the specified path.

    When I try to install STS from the marketplace under this configuration, it fails with this error

    Code:
    Cannot complete the install because one or more required items could not be found.
      Software being installed: Spring IDE Roo Support 3.2.0.201303060654-RELEASE (org.springframework.ide.eclipse.roo.feature.feature.group 3.2.0.201303060654-RELEASE)
      Missing requirement: Spring IDE Live Beans Graph 3.2.0.201303060654-RELEASE (org.springframework.ide.eclipse.beans.ui.livegraph 3.2.0.201303060654-RELEASE) requires 'bundle org.eclipse.zest.core [1.0.0,2.0.0)' but it could not be found
      Cannot satisfy dependency:
        From: Spring IDE Core (required) 3.2.0.201303060654-RELEASE (org.springframework.ide.eclipse.feature.feature.group 3.2.0.201303060654-RELEASE)
        To: org.springframework.ide.eclipse.beans.ui.livegraph [3.2.0.201303060654-RELEASE]
      Cannot satisfy dependency:
        From: Spring IDE Roo Support 3.2.0.201303060654-RELEASE (org.springframework.ide.eclipse.roo.feature.feature.group 3.2.0.201303060654-RELEASE)
        To: org.springframework.ide.eclipse.feature.feature.group 0.0.0

    If I try to install STS running eclipse under the default configuration, again from the marketplace, it will install successfully.

    Any suggestions?

  • #2
    Hey!

    It looks like Eclipse doesn't add the default Juno update site location to the list of available update sites if you start it with a fresh and clean configuration using "-configuration /path/to/custom/configuration".

    The STS installation pulls down some required bundles from the default Eclipse repository and since that is not configured in your case, it fails with the error you posted.

    You can solve this by adding the Eclipse update repository manually to your Eclipse when running with "-configuration /path/to/custom/configuration", please go to:

    "Preferences -> Install/Update -> Available Software Sites" and add "http://download.eclipse.org/releases/juno/".
    Once that is done you should be able to install STS from the marketplace.

    HTH,
    -Martin

    Comment


    • #3
      Originally posted by Martin Lippert View Post
      Hey!
      You can solve this by adding the Eclipse update repository manually to your Eclipse when running with "-configuration /path/to/custom/configuration", please go to:

      "Preferences -> Install/Update -> Available Software Sites" and add "http://download.eclipse.org/releases/juno/".
      Thank you Martin
      Everythng is up and running now.

      Comment


      • #4
        Glad to hear that! And thanks for letting us know!

        Cheers,
        -Martin

        Comment

        Working...
        X