Announcement Announcement Module
Collapse
No announcement yet.
Oracle Weblogic Server Runtime adapter not available in STS 3.2.0 juno 4.2.2 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Oracle Weblogic Server Runtime adapter not available in STS 3.2.0 juno 4.2.2

    I cannot get Oracle Weblogic Server Runtime adapter available in STS 3.2.0 juno 4.2.2. I have tried the 3 recommended methods of installing the OEPE plugins and struck out. I even placed a copy of the Oracle.eclipse.tools.weblogic plugins in the springsource plugin directory, restarted STS and still no luck.

    Please help, I can not proceed any further.

  • #2
    Hey!

    What exactly doesn't work here? Can you provide more details on the error message, for example, when it appears, if there is anything related in the Error Log view, or similar information? I tried this myself a minute ago and it worked, so I think we need to investigate this issue with more details from your errors.

    -Martin

    Comment


    • #3
      Originally posted by Martin Lippert View Post
      Hey!

      What exactly doesn't work here? Can you provide more details on the error message, for example, when it appears, if there is anything related in the Error Log view, or similar information? I tried this myself a minute ago and it worked, so I think we need to investigate this issue with more details from your errors.

      -Martin
      In STS when I navigate to Windows=>Preferences=>Server=>RunTime environments=>Add Button=>Expand Oracle folder and only see Oracle 4j, missing from selection is Oracle Weblogic. SO I tried to get the Oracle Weblogic Server to appear by installing OEPE plugins zip file as a local repository. I downloaded the oepe-12.1.1.2.1-juno-repository.zip file and then Help=>Install=>Add=>Archive=>point to the OEPE plugins. But after that I do not see Oracle Weblogic as a choice to to add to the Server Runt Time environmets.
      Thank you for helping/recommending. I am stuck and cannot proceed at this time.
      Mike

      Comment


      • #4
        Hey Mike!

        Here is what I did...

        - Windows -> Preferences -> Server -> Runtime Environments -> Add Button
        - I don't see the server adapter for Oracle either, so I clicked on the link at the top saying "Download additional server adapters"
        - Selected the "Oracle Weblogic Server Tools" from that list (version 2.2.1...)
        - Clicked "Next", agreed to the license and pressed "Finish"

        I have to restart STS/Eclipse after that, but then the Weblogic Server adapter appears in the list of available adapters.
        Can you execute the same steps on a fresh STS 3.2.0 for Eclipse 4.2.2 installation? Just to check if that works for an empty and fresh STS installation. Sometimes additional plugins conflict with each other, therefore my attempt to use a fresh STS install.

        Does that work? If not, what happens? Does the wizard for installing the additional server adapter report any errors?

        HTH,
        Martin

        Comment

        Working...
        X