Announcement Announcement Module
Collapse
No announcement yet.
The damn thing just will not go - OSX Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • The damn thing just will not go - OSX

    The GGTS just will not, will not work and I have no idea what to do about it.

    I have installed it freshly. I have set my network proxies, and pointed it at the 2.2.2 grails runtime.

    I create a project. The project seems to create fine. The console says "create app zz2" ant it creates.

    Then the console says "compile --non-interactive --refresh-dependencies" and it just sits there. Eventually I get

    The command 'GrailsCommand(P/zz2> compile --non-interactive --refresh-dependencies)' was terminated because it didn't produce new output for some time.

    See details for the output produced so far.

    If you think the command simply needed more time, you can increase the time limit in the Grails preferences page.

    See menu Windows >> Preferences >> Grails >> Launch
    What the hell is 'P'? Why isn't the parenthisis closed?

    So, anyway. I close GGTS. I open a command line, go to the project directory, run grails, and execute 'compile --refresh-dependencies'. Works fine.

    I reopen GGTS. Now it's complaining that it cannot find class groovy.lang.GroovyObject. The hell? grails from the command line works perfectly fine!

    Sorry about the language, but I'm just getting near the end of my rope with this damn thing.

  • #2
    Originally posted by Paul Murray View Post
    I reopen GGTS. Now it's complaining that it cannot find class groovy.lang.GroovyObject. The hell?
    Fixed by deleting ~/.groovy . Eclipse pulls stuff out of that directory, and it had some crud from an older install of grails in there.

    Still can't get the rest of the stuff to go, though.

    I note that the grails commandline widget on the toolbar doesn't work, but the "run app" widget right next to it does:
    | Environment set to development.....
    | Packaging Grails application.....
    | Running Grails application
    May 27, 2013 3:51:51 PM org.apache.coyote.AbstractProtocol init
    INFO: Initializing ProtocolHandler ["http-bio-8080"]
    May 27, 2013 3:51:51 PM org.apache.catalina.core.StandardService startInternal
    INFO: Starting service Tomcat
    May 27, 2013 3:51:51 PM org.apache.catalina.core.StandardEngine startInternal
    INFO: Starting Servlet Engine: Apache Tomcat/7.0.39
    May 27, 2013 3:51:52 PM org.apache.catalina.startup.ContextConfig getDefaultWebXmlFragment
    INFO: No global web.xml found
    May 27, 2013 3:51:52 PM org.apache.catalina.core.ApplicationContext log
    INFO: Initializing Spring root WebApplicationContext

    | Server running. Browse to http://localhost:8080/nsl-tree-gg
    Last edited by Paul Murray; May 27th, 2013, 12:53 AM.

    Comment


    • #3
      Hi Paul,

      Sorry for the trouble you are having. All of your problems are going back to one common issue. The issue is the failure to execute 'compile --refresh-dependencies' command. This command is run by STS to fill in the classpath for the project in Eclipse. When that command fails your Eclipse classpath will not have anything in it. That causes the other problems such as 'could not find 'GroovyObject' etc.

      Likely the reason why the command is failing is that you are hitting this particular bug:
      https://issuetracker.springsource.com/browse/STS-3258

      You can try the workaround suggested in the bug report. I.e. please open the preferences and navigate to "Groovy >> Grails >> Launch" and then disable the option to 'Keep External Grails Process Running'.

      Other people hitting this issue have reported this workaround worked for them. So give it a try and let me know if it works for you.

      Kris

      Comment


      • #4
        Originally posted by Kris De Volder View Post
        You can try the workaround suggested in the bug report. I.e. please open the preferences and navigate to "Groovy >> Grails >> Launch" and then disable the option to 'Keep External Grails Process Running'.
        Thank you so much, this appears to have fixed the issue.

        Comment


        • #5
          Great! Thanks for letting us know.

          Kris

          Comment

          Working...
          X