Announcement Announcement Module
Collapse
No announcement yet.
STS 3.2 consumes more than 2Gb of memory in UBUNTU 64bits, with only 1 project opened Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS 3.2 consumes more than 2Gb of memory in UBUNTU 64bits, with only 1 project opened

    Hello

    I am trying to use STS in my Ubuntu 64bits with 8Gb of memory but it is using a lot of memory ( 2 Gb and growing ) with only one maven project opened.

    In addition to the memory consumption it also runs so slow.

    Using my regular Netbeans it's a different issue..... it consumes over 1.2 Gb with some projects opened, and works faster than STS.... But, I would like to use STS.

    Any suggestions ?

  • #2
    Problem solved........

    Modified JVM args :

    -server
    -Xms128m
    -Xmx512m
    -XX:MaxPermSize=250m
    -XX:ReservedCodeCacheSize=64m
    -XX:+UseConcMarkSweepGC
    -XX:+AggressiveOpts
    -XX:+UseParNewGC
    -XX:+CMSClassUnloadingEnabled
    -XX:+CMSIncrementalMode
    -XX:+CMSIncrementalPacing
    -XX:CMSIncrementalDutyCycleMin=0
    -XX:-TraceClassUnloading
    -XX:+UseCodeCacheFlushing
    -Dsun.io.useCanonCaches=false
    -Djava.net.preferIPv4Stack=true
    -Xverify:none

    Now the memory consumption is 500 Mb !!!!!!!! Thanks to my colleague Yeradis.

    Comment


    • #3
      Hey!

      Glad to hear its working now. I hope you are also using STS 3.2.0 on Eclipse 3.8 (for optimal performance). If not, I would recommend to switch to the Eclipse 3.8-based version in order to get the best performance out of it.

      Cheers,
      -Martin

      Comment


      • #4
        Originally posted by Martin Lippert View Post
        Hey!

        Glad to hear its working now. I hope you are also using STS 3.2.0 on Eclipse 3.8 (for optimal performance). If not, I would recommend to switch to the Eclipse 3.8-based version in order to get the best performance out of it.

        Cheers,
        -Martin

        I'm using STS 3.2.0 ( full stack ) now.... and after using it for 1 day it has growed the memory consumption to 1Gb.

        Comment


        • #5
          There are two variants of STS 3.2.0 out there: one based on Eclipse 3.8.2 and one based on Eclipse 4.2.2. Which one do you have? If you are not sure, take a look at the filename of your download... :-)

          Cheers,
          -Martin

          Comment


          • #6
            Hello

            Well I think it's based on Eclipse 3.8.... file name is spring-tool-suite-3.2.0.RELEASE-e3.8.2-linux-gtk-x86_64-installer

            Comment


            • #7
              Hey!

              Yes, that looks good. In case you continue to observe memory issues and heavily increased memory usage without freeing up the memory again, we need to take a closer look at this. For that case, it would be great if you could capture a heap shapshot (using jmap) and upload that somewhere, so that we could take a closer look at the objects on the heap.

              HTH,
              Martin

              Comment


              • #8
                Dear Sirs and Madams.

                I am running juno 4.2.0 with the GGTS add-on. I am experiencing quick and sudden memory usage of eclipse which leads to a crash. I have used MAT which reports the biggest leaky suspect is as follows: (sorry for the formatting)

                Class Name - Retained Heap

                org.codehaus.groovy.grails.compiler.injection.Clas sInjector[14] - 1,290,807,032
                org.codehaus.groovy.grails.compiler.injection.Defa ultGrailsDomainClassInjector - 1,290,806,768
                java.util.ArrayList - 1,290,806,752
                java.lang.Object[301] - 1,290,806,728

                Is the recommendation (as above): switch to 3.8? or should I provide more details?

                Thanks

                Rob

                Comment


                • #9
                  Interesting.

                  We have done some work on a memory leak in GGTS since the 3.2.0 release. What you are having might be related. Could you try upgrading to the latest nightly GGTS? Also be sure to upgrade groovy-eclipse

                  You can use the following update site for upgrading:
                  http://dist.springsource.com/snapsho.../nightly/e4.2/ (for eclipse 4.2)
                  http://dist.springsource.com/snapsho.../nightly/e4.2/ (for eclipse 3.8)

                  For more information, see:
                  https://issuetracker.springsource.com/browse/STS-3079

                  Also, how large is your grails project? Approximately, how many domain classes, controllers, views?

                  Comment


                  • #10
                    Thank you for your quick response Andrew.

                    The grails project is not too large. domain: 10, controllers:13, services: 7, views: 47.
                    Plugins:
                    activiti 5.9 -- Grails Activiti Plugin - Enabled Activiti BPM Suite support for Grails
                    activiti-spring-security0.4.9 -- Activiti Spring Security Integration
                    attachmentable 0.3.0 -- Attachmentable Plugin
                    audit-logging 0.5.4 -- adds auditable to GORM domain classes
                    build-test-data 2.0.5 -- Build Test Data Plugin
                    cache 1.0.1 -- Cache Plugin
                    ckeditor 3.6.3.0 -- CKeditor plugin
                    database-migration 1.3.2 -- Grails Database Migration Plugin
                    famfamfam 1.0.1 -- Silk icons from famfamfam.com
                    fields 1.3 -- Fields Plugin
                    hibernate 2.2.2 -- Hibernate for Grails
                    joda-time 1.4 -- Joda-Time Plugin
                    jquery 1.8.3 -- JQuery for Grails
                    jquery-ui 1.8.24 -- jQuery UI resources
                    less-resources 1.3.3.1 -- Plugin LESS files resource mapper
                    mail 1.0.1 -- Provides Mail support to a running Grails application
                    markdown 1.0.0.RC1 -- Grails Markdown Plugin
                    quartz 1.0-RC7 -- Quartz plugin for Grails
                    resources 1.2.RC2 -- Resources
                    spring-security-core1.2.7.3 -- Spring Security Core Plugin
                    spring-security-ui 0.2 -- Spring Security UI
                    tomcat 2.2.2 -- Apache Tomcat plugin for Grails
                    twitter-bootstrap 2.3.0 -- Plugin Twitter Bootstrap CSS framework resource files
                    webxml 1.4.1 -- WebXmlConfig

                    Thank you for your suggestion.
                    Since posting this message - I have downloaded the GGTS standalone which is working fine.
                    I have a deadline for Tuesday - but after that I will get the latest nightly and open up the snapshot of the project which exists now at the time of writing to evaluate how it performs.

                    With thanks for your work on this - it is an excellent platform - and I enjoy using it and grails etc a great deal.

                    Comment


                    • #11
                      That is quite a few plugins that you are using. The memory leak that we fixed, dealt with ivy classloaders sticking around after they were no longer needed. This problem is exacerbated if lots of plugins are used. So, I would hope that the new version addresses your problem.

                      Please let me know if this fixes or does not fix your problem.

                      Comment


                      • #12
                        Originally posted by Andrew Eisenberg View Post
                        Interesting.

                        Could you try upgrading to the latest nightly GGTS? Also be sure to upgrade groovy-eclipse

                        You can use the following update site for upgrading:
                        http://dist.springsource.com/snapsho.../nightly/e4.2/ (for eclipse 4.2)
                        http://dist.springsource.com/snapsho.../nightly/e4.2/ (for eclipse 3.8)

                        I have upgraded to the nightly and it seems to have solved the problem - with many thanks.

                        The problem also occurred on an OS X dev machine - and switching to nightly solved this also.

                        Thanks for the fix, and the support. Greatly appreciated.

                        Comment


                        • #13
                          Good to hear.

                          Comment

                          Working...
                          X