Announcement Announcement Module
Collapse
No announcement yet.
Which version of STS should be used?? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Which version of STS should be used??

    Hello all,
    I am new to this community and also to the world of spring, I just want to know one thing which version of spring tool suite should be used ?? The reason for asking such a question is I know some of the people working in this field they told me that people are shifting back to STS 2.8.1 or earilier version than 3.2.0. I searched over the internet and mostly people using 3.2.0. Please spare some of your time and provide some help.

  • #2
    Hey!

    I would suggest to use the latest release version of STS, which is 3.2.0 at the moment. I would also recommend to use the STS 3.2.0 version that is based on Eclipse 3.8 for optimal performance and stability.

    I think the reasons why people switched back to older versions of STS were the performance issues that the new Eclipse 4.x platform introduced a while ago (was an issue with STS 3.0.0 on Eclipse 4.2 and STS 3.1.0 on Eclipse 4.2.1) and possibly issues with the new Maven Integration for Eclipse that we started to include a while ago. With regards to the performance and stability issue with the new Eclipse platform: that is the reason why we provide a distribution based on Eclipse 3.8, which you can use without loosing any functionality. And the Eclipse Juno SR2 (4.2.2) made things a lot better (and that is what is included in STS 3.2.0 for Eclipse 4.2.2).

    We also have a few good references for getting started here:
    http://forum.springsource.org/showth...etting-Started

    Hope this helps!
    -Martin

    Comment


    • #3
      Thanks a lot Martin

      Comment


      • #4
        Here is a great tutorial on how to install spring tool suite
        http://www.petermartinblog.com/2013/...ce-tool-suite/

        I wanted to mention Martin had the same advice
        I had windows 7 installed on my computer....

        Comment

        Working...
        X