Announcement Announcement Module
Collapse
No announcement yet.
Cannot make (seemingly spurious) warning dissapear Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot make (seemingly spurious) warning dissapear

    Not sure if this is best placed in the Security forum or this one but anyway...

    I have been testing out Spring security with an simple LDAP set up, using Spring 3.1.4, Secutiry 3.1.4, LDAP 1.3.1 and STS 3.2.0 on Juno.

    I've got the following in my security-context.xml

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <beans xmlns="http://www.springframework.org/schema/beans"
    	xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    	xmlns:security="http://www.springframework.org/schema/security"
    	xsi:schemaLocation="http://www.springframework.org/schema/security http://www.springframework.org/schema/security/spring-security-3.1.xsd
    		http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans-3.1.xsd">
    
    
    	<security:http auto-config="true">
    		<security:intercept-url pattern="/**"
    			access="isAuthenticated()" />
    	</security:http>
    	<security:authentication-manager>
    		<security:ldap-authentication-provider
    			user-search-base="cn=Users" user-search-filter="(uid={0})"
    			group-search-base="cn=FOOBARDEV,cn=Groups"
    			group-search-filter="(uniquemember={0})">
    		</security:ldap-authentication-provider>
    	</security:authentication-manager>
    	<security:ldap-server
    		url="ldap://foo.bar.net:9999/o=oracle,o=foo,dc=bar,dc=foo,dc=uk" />
    </beans>
    The above is as far as I can see correct however I am getting two warnings of:

    Referenced bean 'org.springframework.security.securityContextSourc e' not found
    I have checked and I have spring-ldap in my pom.xml file. The application appears to run fine in spite of these warnings.

    Anyone have any ideas?

  • #2
    Hey!

    This seems to be a problem with the tooling, I guess. I created a JIRA for this:
    https://issuetracker.springsource.com/browse/STS-3354

    We will take a look at this. In the meantime you can disable the validation that produces this warning from the project settings in the Spring section.

    HTH,
    Martin

    Comment


    • #3
      Thanks! :-)

      Comment

      Working...
      X