Announcement Announcement Module
Collapse
No announcement yet.
Installation of Spring IDE in Eclipse indigo fails Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Installation of Spring IDE in Eclipse indigo fails

    I attempted to install the Spring IDE on my eclipse indigo with the marketplace The following error ensued:
    Cannot complete the install because of a conflicting dependency.
    Software being installed: Spring IDE Core (required) 3.2.0.201303060654-RELEASE (org.springframework.ide.eclipse.feature.feature.g roup 3.2.0.201303060654-RELEASE)
    Software currently installed: JBoss Central Community 1.0.1.v20120715-0355-H112-Final (org.jboss.tools.community.central.feature.feature .group 1.0.1.v20120715-0355-H112-Final)
    Only one of the following can be installed at once:
    Mylyn Commons UI 3.8.1.v20120725-0100 (org.eclipse.mylyn.commons.ui 3.8.1.v20120725-0100)
    Mylyn Commons UI 3.6.1.v20110720-0100 (org.eclipse.mylyn.commons.ui 3.6.1.v20110720-0100)
    Mylyn Commons UI 3.8.2.v20120916-1200 (org.eclipse.mylyn.commons.ui 3.8.2.v20120916-1200)
    Mylyn Commons UI 3.8.0.v20120612-0600 (org.eclipse.mylyn.commons.ui 3.8.0.v20120612-0600)
    Mylyn Commons UI 3.8.3.v20130107-0100 (org.eclipse.mylyn.commons.ui 3.8.3.v20130107-0100)
    Mylyn Commons UI 3.6.0.v20110608-1400 (org.eclipse.mylyn.commons.ui 3.6.0.v20110608-1400)
    Cannot satisfy dependency:
    From: JBoss Central 1.0.1.v20120715-0355-H112-Final (org.jboss.tools.central 1.0.1.v20120715-0355-H112-Final)
    To: bundle org.eclipse.mylyn.commons.ui [3.6.0,3.8.0)
    Cannot satisfy dependency:
    From: JBoss Central 1.0.1.v20130112-0624-H128-Final (org.jboss.tools.central 1.0.1.v20130112-0624-H128-Final)
    To: bundle org.eclipse.mylyn.commons.ui [3.6.0,3.8.0)
    Cannot satisfy dependency:
    From: JBoss Central 1.0.1.v20120715-0355-H112-Final (org.jboss.tools.central.feature.feature.group 1.0.1.v20120715-0355-H112-Final)
    To: org.jboss.tools.central [1.0.1.v20120715-0355-H112-Final]
    Cannot satisfy dependency:
    From: JBoss Central 1.0.1.v20130112-0624-H128-Final (org.jboss.tools.central.feature.feature.group 1.0.1.v20130112-0624-H128-Final)
    To: org.jboss.tools.central [1.0.1.v20130112-0624-H128-Final]
    Cannot satisfy dependency:
    From: JBoss Central Community 1.0.1.v20120715-0355-H112-Final (org.jboss.tools.community.central.feature.feature .group 1.0.1.v20120715-0355-H112-Final)
    To: org.jboss.tools.central.feature.feature.group 1.0.0.qualifier
    Cannot satisfy dependency:
    From: Spring IDE Live Beans Graph 3.2.0.201303060654-RELEASE (org.springframework.ide.eclipse.beans.ui.livegrap h 3.2.0.201303060654-RELEASE)
    To: bundle org.eclipse.mylyn.commons.ui [3.7.0,4.0.0)
    Cannot satisfy dependency:
    From: Spring IDE Core (required) 3.2.0.201303060654-RELEASE (org.springframework.ide.eclipse.feature.feature.g roup 3.2.0.201303060654-RELEASE)
    To: org.springframework.ide.eclipse.beans.ui.livegraph [3.2.0.201303060654-RELEASE]

    and when i try do instal it manually from this udpate site:
    http://dist.springsource.com/release...Eclipse Indigo
    <Error>
    <Code>AccessDenied</Code>
    <Message>Access Denied</Message>
    <RequestId>711B9EDE1AC259F3</RequestId>
    <HostId>
    4Wfy/NG6qj8ZgcSd840+QUGf3JKB9cKUq+W5U/wofuyXxG/uGhGITtF9kFOwryYy
    </HostId>
    </Error>
    how should I do to add the spring ide

  • #2
    Hey!

    From the error log posted above it looks like you have some JBoss tools installed that are not compatible with a newer Mylyn version that is used by Spring IDE 3.2.0. Can you take a look whether there is a newer version of the JBoss tools that you are using?

    You can also try to update the Mylyn version to 3.8.0 before installing Spring IDE to see if that works or produces a similar error. If that works, installing Spring IDE afterwards should work. If that doesn't work, you might want to ask the JBoss guys for a version of their tools that is compatible with a newer Mylyn version.

    Regarding the "access denied" message: The update site URL is not meant to be used from a browser. It contains the files for a p2 repository only, nothing for the browser to display.

    HTH,
    Martin

    Comment


    • #3
      thx for your cooperation .It is OK Now I make it Manully from anathor

      Comment


      • #4
        Eclipse Juno Update Problem - Spring IDE Roo Support (201303060654-RELEASE)

        I have tried to diagnose (and correct) the following error message I get from Eclipse 'update' .....

        The current configuration contains errors and this operation can have unpredictable results.
        Spring IDE Roo Support (3.2.0.201303060654-RELEASE) requires feature "org.springsource.ide.eclipse.commons (3.2.0.qualifier)", or compatible.


        I have checked the log and dont see any Mylyn issues which might be causing this error on update.

        Thanks in advance for the help.

        Comment


        • #5
          Hey!

          Can you tell me more about how to reproduce this error? Are you using Eclipse with Spring tooling installed or an STS distribution? Which versions? And what exactly do you do to get this error?

          I don't see any relation to Mylyn, it looks more like the installation of Eclipse/STS is corrupted or that some additional components are causing dependency issues, but that is hard to tell without more information. Would be good if you could tell us more details.

          Thanks,
          Martin

          Comment

          Working...
          X