Announcement Announcement Module
Collapse
No announcement yet.
Just Updated STS to latest and now getting IDE error Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Just Updated STS to latest and now getting IDE error

    On a whim i ran the Eclipse 'software update' (probably bad idea) and now i'm getting an error in my webflow-config.xml (see below). I didn't change anything else, just did the update.

    As far as i can tell, start-state doesn't belong in the config???

    Start state definition is missing. Add a 'start-state' element

    <?xml version="1.0" encoding="UTF-8"?>
    <beans xmlns="http://www.springframework.org/schema/beans"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xmlns:webflow="http://www.springframework.org/schema/webflow-config"
    xmlns:faces="http://www.springframework.org/schema/faces"
    xsi:schemaLocation="
    http://www.springframework.org/schema/beans
    http://www.springframework.org/schem...ring-beans.xsd
    http://www.springframework.org/schema/webflow-config
    http://www.springframework.org/schem...low-config.xsd
    http://www.springframework.org/schema/faces
    http://www.springframework.org/schema/faces/spring-faces.xsd">


    <bean id="jpaFlowExecutionListener" class="org.springframework.webflow.persistence.Jpa FlowExecutionListener">
    <constructor-arg ref="entityManagerFactory" />
    <constructor-arg ref="transactionManager" />
    </bean>

    <bean id="facesContextListener" class="org.springframework.faces.webflow.FlowFaces ContextLifecycleListener" />

    <webflow:flow-executor id="flowExecutor" >
    <webflow:flow-execution-listeners>
    <webflow:listener ref="jpaFlowExecutionListener" />
    <webflow:listener ref="facesContextListener"/>
    </webflow:flow-execution-listeners>
    </webflow:flow-executor>

    <webflow:flow-registry id="flowRegistry" flow-builder-services="facesFlowBuilderServices" base-path="/WEB-INF/flows" >
    <webflow:flow-location-pattern value="/**/*-flow.xml" />
    </webflow:flow-registry>

    <faces:flow-builder-services id="facesFlowBuilderServices" development="true" />

    <faces:resources />

    <bean class="org.springframework.webflow.mvc.servlet.Flo wHandlerMapping">
    <property name="order" value="1"/>
    <property name="flowRegistry" ref="flowRegistry" />
    <property name="defaultHandler">
    <bean class="org.springframework.web.servlet.mvc.UrlFile nameViewController" />
    </property>
    </bean>

    <bean class="org.springframework.faces.webflow.JsfFlowHa ndlerAdapter">
    <property name="flowExecutor" ref="flowExecutor" />
    </bean>

    <bean id="faceletsViewResolver" class="org.springframework.web.servlet.view.UrlBas edViewResolver">
    <property name="viewClass" value="org.springframework.faces.mvc.JsfView"/>
    <property name="prefix" value="/WEB-INF/" />
    <property name="suffix" value=".xhtml" />
    </bean>

    <bean class="org.springframework.web.servlet.mvc.SimpleC ontrollerHandlerAdapter" />

    </beans>

  • #2
    Seems to be a bug. Do you know what version of STS were you were upgrading from? Which version of Webflow do you use, 2.3?

    I've filed an issue STS-3295: webflow config gives bogus "Start state definition is missing." element
    https://issuetracker.springsource.com/browse/STS-3295
    Last edited by ldossantos; Apr 4th, 2013, 04:04 PM.

    Comment


    • #3
      This particular file shouldn't even be getting Webflow validation since it's technically a Spring beans configuration file.

      Can you right-click the project to pull up the Properties dialog, then select Spring -> Web Flow Support. if webflow-config.xml appears in the list then remove it. You can then select Spring -> Bean Support and hit the Scan... button which should add the web flow-config.xml to the the list of bean config files. A project rebuild should re-validate the web flow-config.xml file.

      Comment

      Working...
      X