Announcement Announcement Module
Collapse
No announcement yet.
Simple spring utility project in STS2.3.2 wont accept top level package - gets stuck Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Simple spring utility project in STS2.3.2 wont accept top level package - gets stuck

    i was trying out STS 2.3.2 and was trying to play with spring

    however the basic spring project is pretty useless - its a singel src folder and no content structure

    tried to build a templated project - and if you do Spring Utility Project, the template doesnt work

    i can fill in the project name - but you have to provide a top level package (e.g. com.xyz) and whatever you do the builder form wont accept it.

    Has any one else had this problem and cant it be worked around?

    i've ended up going off course on maven - which was a bit of bugger and hard to sort out and now looking at gradle to build a simple spring project

    however i wanted a basic one out the box with STS - and it doesnt work

    are others sufffering with this problem

  • #2
    STS 2.3.2 is pretty old now, and the template packaging issue was one we fixed a while back. Have you tried the latest STS 3.2.0? It includes a wider variety of template projects and examples to get you started with.

    Comment


    • #3
      leo - i quoted the wrong version i'm on latest build 3.2.0 - this template got stuck as described - in the end i've had to quite that approach and i'm trying to see how build via gradle - however all the same the template ought to work and didnt.

      as spring 4 is going more to groovy and gradle - does all tihs get reworked into gradle teplates in version 4 ?

      Comment


      • #4
        Hey!

        I tried the Spring Utilities template project in STS 3.2.0 and it seems to work fine. The project requires you to define a three-level deep package structure (because that is the way this template project is defined) and then you are ready to go.

        Are you using the STS distribution for this? If not, you need to make sure that you have the Maven Integration for Eclipse installed into your Eclipse. This comes pre-installed with the STS distribution.

        Can you try the template project again with a three-level deep package structure and let me know if that works? If not, are you seeing any error message or maybe anything related in the Error Log view? That would be helpful to find out what is going wrong in your case. The template projects should all work out-of-the-box.

        With regards to your Spring-4 question: we are working on new template and tutorial projects around Spring 4 and they will be accessible from one of the upcoming STS versions. As far as I know, most of them will still use Maven for their dependency management and building, so I don't know yet whether there will be any Gradle-based templates available (from what I know at the moment). But this might change over time. Do you have a strong preference towards Maven or towards Gradle?

        HTH,
        Martin

        Comment

        Working...
        X