Announcement Announcement Module
Collapse
No announcement yet.
How can i update from Mylyn 3.6 to mylyn 3.8 in STS Page Title Module
Move Remove Collapse
This topic is closed
X
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • How can i update from Mylyn 3.6 to mylyn 3.8 in STS

    Hi,

    I want to update from Mylyn 3.6 to mylyn 3.8 in STS 2.9.1, but it is not possible since mylyn 3.6 was integrated in STS. There are no updates for Mylyn (neither for any plugin included in STS) in "Check for Updates", et when I want to install mylyn 3.8 from "Install new softwares" using the site : SpringSource Update Site for Eclipse 3.7 - http://dist.springsource.com/release/TOOLS/update/e3.7

    Here is/are the error(s) :

    software being installed : mylyn 3.8
    software currently installed : STS 2.9.1
    => "Only one of the following can be installed at once"

    I tried to uninstall Mylyn 3.6 but it is part of SpringSource Tool Suite Plugin, and uninstalling this plugin prevents STS from launching...

    Any ideas ? Thanks in advance

  • #2
    Hey!

    This is due to the package feature that we use to build up the distribution. Usually we provide updates for those packages with never versions of the embedded components, therefore it usually shouldn't be a big issue. But we disabled this update patch between 2.9.1 and 3.0.0 and beyond (in order to cope with the largely restructured codebase of STS for 3.0.0 and beyond), therefore there is no update to the package feature available to you (just to explain the background).

    There are three things that come to my mind that could solve this:

    - start with a fresh and new STS 3.2.0.RELEASE installation (it already contains the latest Mylyn bits and pieces). The update patch to newer package versions is enabled for 3.x versions again. Hope you noticed that there is an STS build on Eclipse 3.8, in case you don't want to update the Eclipse platform to the 4.x stream yet.

    - or you could start with a fresh Eclipse installation of your choice (for example Eclipse Indigo 3.7, if you need that) and install the individual Mylyn and STS bits and pieces manually (from the Eclipse Marketplace, for example). That is some extra work to do, but gives you max flexibility.

    - in case you would like to start with an STS 3.2.0.RELEASE distribution on top of Eclipse 3.7, I could also provide you with a direct download link, if you tell me the exact version that you need (OS, 32bit, 64bit, etc.). We don't officially ship that to avoid confusion and to reduce testing efforts, but if would like to give that a try, I can send you the direct download URL.

    HTH,
    -Martin

    Comment


    • #3
      Hi,

      Thank you for your reply !
      I need to use the Jira Atlassian Connector which works only with mylyn 3.8+.
      STS and Eclipse Indigo are used by a lot of developpers in my service, and I don't know if changing of Eclipse/STS versions would implicate a lot of work, but I think so, so it is not a good idea for the moment (except if I mistake).

      I have tried to delete manually Mylyn 3.6 in STS 2.9.1 by deleting all the references to Mylyn in packages and features, but it seems like I did not succeed to delete everything because some components of Mylyn were still visible in "Already Installed Plugins" in STS plugin.

      Is it possible to delete only Mylyn 3.6 from STS manually, and then installing Mylyn 3.8 ?
      Last edited by jackyisindaplace; Mar 28th, 2013, 09:22 AM.

      Comment


      • #4
        Originally posted by jackyisindaplace View Post
        Hi,

        Thank you for your reply !
        I need to use the Jira Atlassian Connector which works only with mylyn 3.8+.
        STS and Eclipse Indigo are used by a lot of developpers in my service, and I don't know if changing of Eclipse/STS versions would implicate a lot of work, but I think so, so it is not a good idea for the moment (except if I mistake).

        I have tried to delete manually Mylyn 3.6 in STS 2.9.1 by deleting all the references to Mylyn in packages and features, but it seems like I did not succeed to delete everything because some components of Mylyn were still visible in "Already Installed Plugins" in STS plugin.

        Is it possible to delete only Mylyn 3.6 from STS manually, and then installing Mylyn 3.8 ?
        I bet it took you more time to "play" with Mylyn that it would take you to download STS 3.2 and install it.
        Just saying

        Comment


        • #5
          Can you try updating Mylyn from the update site http://download.eclipse.org/mylyn/releases/latest

          Comment


          • #6
            Hey!

            I analyzed this in more detail and I was wrong to a certain degree in my first answer. I am sorry for that. In a normal situation, you should be able to just manually install a newer version of Mylyn into your existing STS installation. Mylyn updates will not be found automatically (via "Check for Updates") because it is included in our package feature (and not installed as a separate root feature). But installing it manually should work.

            The issue with the versions that you are trying to combine is: the Mylyn integration for Spring IDE 2.9.1 uses an internal API of Mylyn 3.6 (and prior) that changed in Mylyn 3.7 (and later). Therefore you cannot use the older STS 2.9.1 versions of STS with a Mylyn newer than 3.6.

            Therefore manually uninstalling the older Mylyn version doesn't help, since the Eclipse install mechanism won't let you install a newer version due to this missing old internal API package that isn't exported anymore.

            I am sorry that I can't provide a better answer, but I think you have to upgrade to a newer STS version in order to use Mylyn 3.8.

            -Martin

            Comment


            • #7
              Thank You for your replies ! So, I will upgrade STS and Eclipse.

              Where is the button "Resolved" ? ^^

              Comment


              • #8
                I think it is the "close this thread" checkbox when you reply... This is at least what I will try now... ;-)

                Comment

                Working...
                X