Announcement Announcement Module
No announcement yet.
Any plans on integrating Gradle 1.5 into STS? Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • stitcher
    started a topic Any plans on integrating Gradle 1.5 into STS?

    Any plans on integrating Gradle 1.5 into STS?


    We recently updated our plugin installation from 3.1 to 3.2. The rollout was successful, and changing Gradle from 1.0 to 1.3 helped a lot.

    With 1.5 of Gradle already rc-3, do you have any plans on making 1.5 as default version in Grade STS plugin? I know that Gradle installation can be specified in Eclipse plugin settings, I am looking for the most seamless way to keep our workstations up to date.

    Thank you for the great tool!


  • Kris De Volder
    I don't have an idea what is going on for you. I tried importing the project and it worked for me.

    It is interesting that you get the problem both with your 'real' project and the 'simple' one. So its probably not something in the project that is triggering this behavior.

    I'd suggest trying to take some stackdump snapshots with jps and jstack (commandline tools part of JDK) maybe you can get some info/hints on what Gradle process is doing while its taking so much time.

    Unfortunately, I'm not sure I'll be able to help much at this point in figuring out what Gradle is doing and why. You should probably ask for help on the Gradle forum where you'll could get input from people who know the internals of Gradle and the Gradle Daemon.

    The other thread I linked you to, that person also got help on the Gradle forum, then came back here with more specific questions / info on what was going on and we could figure it out after that.

    Sorry, but I don't think I can be much help at this point.


    Leave a comment:

  • kachelzaehler
    Hey Kris,

    thanks for your reply. I also think it's a problem with my environment but I can't figure it out.

    Building the project on the command line works fine. Importing and building/refreshing the Gradle model in STS doesn't work (I killed the STS process after 5 minutes). It downloads Gradle 1.5 and progresses for ever (I removed the .gradle folder in my home directory in advance). I had no problems with the same tooling and project using Gradle 1.3 and 1.4.

    Here are some of the relevant STS settings:
    • Active provider: direct
    • Gradle Distribution: use Gradle wrapper's default
    • Gradle User Home : Use Gradle wrapper's default
    • Gradle IDE

    and of the system itself:

    $ gradlew --version
    Using GRADLE_OPTS: -XX:-UseSplitVerifier -Xdebug -Xrunjdwp:transport=dt_socket,s
    erver=y,suspend=n,address=5005 -Xmx1024M -XX:MaxPermSize=512M -XX:ReservedCodeCa
    Listening for transport dt_socket at address: 5005

    Gradle 1.5

    Gradle build time: Mittwoch, 27. Mrz 2013 13:51 Uhr UTC
    Groovy: 1.8.6
    Ant: Apache Ant(TM) version 1.8.4 compiled on May 22 2012
    Ivy: 2.2.0
    JVM: 1.7.0_02 (Oracle Corporation 22.0-b10)
    OS: Windows 7 6.1 amd64

    -XX:-UseSplitVerifier -Xdebug -Xrunjdwp:transport=dt_socket,server=y,suspend=n,ad dress=5005

    I tested it with this simple java project as well (same result):

    Any idea?


    Attached Files
    Last edited by kachelzaehler; Apr 17th, 2013, 03:10 AM.

    Leave a comment:

  • Kris De Volder
    As far as I know things should work fine with Gradle 1.5.

    The current nightly build of the Gradle tools is already based on Gradle 1.5 tooling API and is passing all regression tests. This means it is creating and working with Gradle 1.5 based projects.

    Even with the 3.2.0.RELEASE version of the tools based on Gradle 1.3 tooling API I would expect it to work fine with Gradle 1.5 based projects as the 1.3 tooling API supports that.

    Maybe there's something about your particular build that makes it take a very long time. Resolving dependencies in Gradle builds can be quite lengthy. The progress bar is somewhat fake, Gradle doesn't really report progress. We just created a 'fake' progress bar that keeps moving forward as long as Gradle keeps showing signs of life. If it keeps moving then it means Gradle is still sending some kind of progress events, but the position of the bar is really meaningless.

    I recall one case where a user here reported having issues with very long model builds in STS gradle tooling. It turned out to be because of proxy settings causing the Gradle dependency resolve operations to keep trying and timing out. This made her model builds take upwards of 20 hours!

    Maybe something similar for you?

    The message is here:

    Maybe your problem isn't the same, but whatever your problem is, my guess is that it is likely very specific to your particular project and/or environment. So more info from you will be needed.

    One thing you can try is see if the problem (very long/never-ending builds) also happen on command line. If yes, then its a Gradle problem (either with your build or Gradle itself). In that case you should take it to the Gradle forum.

    If it only happens with the STS tooling but not on the commandline, it could be a problem with the tooling, if you can come up wth a method to reproduce it and raise a bug request on our issue tracker and can then I can try to reproduce it and investigate a little to try and determine why it happens and if its an STS problem or an issue with the Gradle tooling API.


    Leave a comment:

  • kachelzaehler

    Do you plan to support Gradle 1.5 in STS 3.2.0? It seems impossible to import (or refresh dependencies of) Gradle projects using a 1.5 wrapper into STS (no error message, the progress bar just keeps moving forward...). Any workaround for this?



    Leave a comment:

  • Kris De Volder
    Yes, usually when a new version of Gradle comes out we update the tooling api jars shipped inside of our tools to that version.
    That automatically makes that version the default.

    It looks like we will be skipping the 1.4 release though, since we haven't got a 1.4 based build yet and it looks like 1.5 will be out in the near future.

    I've created an issue here so we don't forget this :-)

    You should still be able to use 1.4 or 1.5 with the current version of the tools even though use 1.3 tooling API.

    Note that if your projects use the gradle wrapper then the project itself will specify in a properties file what distribution to use. Gradle will automatically use that version. So there typically wouldn't be any need to overrride the gradle version globally if the projects are using the Gradle wrapper setup.


    Leave a comment: