Announcement Announcement Module
No announcement yet.
Error updating gradle plugin to 3.2.0 Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error updating gradle plugin to 3.2.0

    I upgraded the rest of sts to 3.2 just fine, but the gradle ide is showing this error:

    Cannot complete the install because of a conflicting dependency.
    Software being installed: Gradle IDE (org.springsource.ide.eclipse.gradle.feature.featu
    Software currently installed: Gradle Tooling Api (
    Only one of the following can be installed at once:
    SpringSource Tool Suite Gradle Integration (Core) (org.springsource.ide.eclipse.gradle.core
    SpringSource Tool Suite Gradle Integration (Core) (org.springsource.ide.eclipse.gradle.core
    Cannot satisfy dependency:
    From: Gradle Tooling Api (
    To: org.springsource.ide.eclipse.gradle.core []
    Cannot satisfy dependency:
    From: Gradle IDE (org.springsource.ide.eclipse.gradle.feature.featu
    To: org.springsource.ide.eclipse.gradle.core []

  • #2
    It looks like somehow you can't install 3.2 version of the plugins because the 3.1 version is still there.

    Normally, I would expect the update to proceed and replace 3.1 with 3.2 but maybe for some reason its unable to remove the 3.1 version.

    Maybe try to explicitly uninstall the 3.1 gradle tooling then try installing 3.2 version. Either this will work, or maybe we'll get some information/error why 3.1 can't be uninstalled.

    To uninstall do like this:
    " Help >> Install New Software"

    Then click the "What is already installed" link in the bottom right of the dialog.

    You should get a dialog with list of installed stuff and you can find Gradle tooling there and uninstall it.

    Let me know how it goes.



    • #3
      Uninstalling and then installing worked for me. Now I'm running Gradle IDE 3.2.

      I'm still having an issue with importing gradle project and which I described here:

      Can you help me with it?



      • #4
        Thanks for letting me know uninstall/install solved the problem.
        As to your other problem it looks like you already found the solution.

        Good news all around :-)