Announcement Announcement Module
Collapse
No announcement yet.
Error updating gradle plugin to 3.2.0 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error updating gradle plugin to 3.2.0

    I upgraded the rest of sts to 3.2 just fine, but the gradle ide is showing this error:

    Cannot complete the install because of a conflicting dependency.
    Software being installed: Gradle IDE 3.2.0.201303060652-RELEASE (org.springsource.ide.eclipse.gradle.feature.featu re.group 3.2.0.201303060652-RELEASE)
    Software currently installed: Gradle Tooling Api 3.1.0.201210040512-RELEASE (org.gradle.toolingapi.feature.feature.group 3.1.0.201210040512-RELEASE)
    Only one of the following can be installed at once:
    SpringSource Tool Suite Gradle Integration (Core) 3.2.0.201303060652-RELEASE (org.springsource.ide.eclipse.gradle.core 3.2.0.201303060652-RELEASE)
    SpringSource Tool Suite Gradle Integration (Core) 3.1.0.201210040512-RELEASE (org.springsource.ide.eclipse.gradle.core 3.1.0.201210040512-RELEASE)
    Cannot satisfy dependency:
    From: Gradle Tooling Api 3.1.0.201210040512-RELEASE (org.gradle.toolingapi.feature.feature.group 3.1.0.201210040512-RELEASE)
    To: org.springsource.ide.eclipse.gradle.core [3.1.0.201210040512-RELEASE]
    Cannot satisfy dependency:
    From: Gradle IDE 3.2.0.201303060652-RELEASE (org.springsource.ide.eclipse.gradle.feature.featu re.group 3.2.0.201303060652-RELEASE)
    To: org.springsource.ide.eclipse.gradle.core [3.2.0.201303060652-RELEASE]

    http://screencast.com/t/h55qPnWkKeI

  • #2
    It looks like somehow you can't install 3.2 version of the plugins because the 3.1 version is still there.

    Normally, I would expect the update to proceed and replace 3.1 with 3.2 but maybe for some reason its unable to remove the 3.1 version.

    Maybe try to explicitly uninstall the 3.1 gradle tooling then try installing 3.2 version. Either this will work, or maybe we'll get some information/error why 3.1 can't be uninstalled.

    To uninstall do like this:
    " Help >> Install New Software"

    Then click the "What is already installed" link in the bottom right of the dialog.

    You should get a dialog with list of installed stuff and you can find Gradle tooling there and uninstall it.

    Let me know how it goes.

    Kris

    Comment


    • #3
      Uninstalling and then installing worked for me. Now I'm running Gradle IDE 3.2.

      I'm still having an issue with importing gradle project and which I described here: http://forum.springsource.org/showth...gradle-project

      Can you help me with it?

      Thanks,
      Krzysztof

      Comment


      • #4
        Thanks for letting me know uninstall/install solved the problem.
        As to your other problem it looks like you already found the solution.

        Good news all around :-)

        Comment

        Working...
        X