Announcement Announcement Module
Collapse
No announcement yet.
GGTS 3.2.0 and Groovy 1.7 problem Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • GGTS 3.2.0 and Groovy 1.7 problem

    Hello,

    I've recently updated GGTS to 3.2.0 (based on Eclipse v3.8) and noticed that it doesn't contain Groovy compiler v1.7 anymore (we use Grails 1.3.7, so need this version of the compiler).
    The SpringSource guys mentioned that they removed the 1.7 compiler to reduce GGTS install size and that the compiler can be installed from the discovery page.

    I wasn't able, though, to find the compiler v1.7 here: http://dist.springsource.com/release/TOOLS/update/e3.8
    I found it here: http://dist.springsource.org/release/GRECLIPSE/e3.7/

    But when trying to install it, I got the following error:

    Code:
    Cannot complete the install because of a conflicting dependency.
      Software being installed: Groovy Compiler 1.7.10 Feature 2.7.2.xx-RELEASE-20121219-0800-e37 (org.codehaus.groovy17.feature.feature.group 2.7.2.xx-RELEASE-20121219-0800-e37)
      Software currently installed: m2e - Maven Integration for Eclipse 1.2.0.20120903-1050 (org.eclipse.m2e.feature.feature.group 1.2.0.20120903-1050)
      Software currently installed: Groovy/Grails Tool Suite 3.2.0.201303060821-RELEASE-e38 (org.springsource.ggts.ide 3.2.0.201303060821-RELEASE-e38)
      Only one of the following can be installed at once: 
        Groovy-Eclipse plugin 2.8.0.xx-20130228-1600-e37 (org.codehaus.groovy.eclipse 2.8.0.xx-20130228-1600-e37)
        Groovy-Eclipse plugin 2.8.0.xx-20130304-1200-e42 (org.codehaus.groovy.eclipse 2.8.0.xx-20130304-1200-e42)
        Groovy-Eclipse plugin 2.8.0.xx-20130228-1500-e43 (org.codehaus.groovy.eclipse 2.8.0.xx-20130228-1500-e43)
        Groovy-Eclipse plugin 2.7.2.xx-RELEASE-20121219-0800-e37 (org.codehaus.groovy.eclipse 2.7.2.xx-RELEASE-20121219-0800-e37)
      Only one of the following can be installed at once: 
        Object Teams Development Tooling Core 3.8.1.v_OTDT_r210_201206090452 (org.eclipse.jdt.core 3.8.1.v_OTDT_r210_201206090452)
        Java Development Tools Core 3.7.3.xx-20130228-1600-e37 (org.eclipse.jdt.core 3.7.3.xx-20130228-1600-e37)
        Object Teams Development Tooling Core 3.8.3.v_OTDT_r212_201301271217 (org.eclipse.jdt.core 3.8.3.v_OTDT_r212_201301271217)
        Java Development Tools Core 3.7.3.xx-RELEASE-20121219-0800-e37 (org.eclipse.jdt.core 3.7.3.xx-RELEASE-20121219-0800-e37)
        Java Development Tools Core 3.8.1.v20120531-0637 (org.eclipse.jdt.core 3.8.1.v20120531-0637)
        Java Development Tools Core 3.9.0.xx-20130228-1500-e43 (org.eclipse.jdt.core 3.9.0.xx-20130228-1500-e43)
        Object Teams Development Tooling Core 3.8.2.v_OTDT_r211_201209011847 (org.eclipse.jdt.core 3.8.2.v_OTDT_r211_201209011847)
        Java Development Tools Core 3.8.2.xx-20130304-1200-e42 (org.eclipse.jdt.core 3.8.2.xx-20130304-1200-e42)
        Java Development Tools Core 3.8.2.v20120814-155456 (org.eclipse.jdt.core 3.8.2.v20120814-155456)
        Java Development Tools Core 3.8.3.v20130121-145325 (org.eclipse.jdt.core 3.8.3.v20130121-145325)
      Cannot satisfy dependency:
        From: Groovy-Eclipse Feature 2.7.2.xx-RELEASE-20121219-0800-e37 (org.codehaus.groovy.eclipse.feature.feature.group 2.7.2.xx-RELEASE-20121219-0800-e37)
        To: org.codehaus.groovy.jdt.patch.feature.group [2.7.1.xx-RELEASE-20121219-0800-e37]
      Cannot satisfy dependency:
        From: Groovy-Eclipse Feature 2.8.0.xx-20130228-1500-e43 (org.codehaus.groovy.eclipse.feature.feature.group 2.8.0.xx-20130228-1500-e43)
        To: org.codehaus.groovy.eclipse [2.8.0.xx-20130228-1500-e43]
      Cannot satisfy dependency:
        From: Groovy-Eclipse Feature 2.8.0.xx-20130228-1600-e37 (org.codehaus.groovy.eclipse.feature.feature.group 2.8.0.xx-20130228-1600-e37)
        To: org.codehaus.groovy.eclipse [2.8.0.xx-20130228-1600-e37]
      Cannot satisfy dependency:
        From: Groovy-Eclipse Feature 2.8.0.xx-20130304-1200-e42 (org.codehaus.groovy.eclipse.feature.feature.group 2.8.0.xx-20130304-1200-e42)
        To: org.codehaus.groovy.eclipse [2.8.0.xx-20130304-1200-e42]
      Cannot satisfy dependency:
        From: Groovy Compiler 1.7.10 Feature 2.7.2.xx-RELEASE-20121219-0800-e37 (org.codehaus.groovy17.feature.feature.group 2.7.2.xx-RELEASE-20121219-0800-e37)
        To: org.codehaus.groovy.eclipse [2.7.2.xx-RELEASE-20121219-0800-e37]
      Cannot satisfy dependency:
        From: JDI Debug UI 3.6.100.v20120530-1425 (org.eclipse.jdt.debug.ui 3.6.100.v20120530-1425)
        To: bundle org.eclipse.jdt.core [3.8.0,4.0.0)
      Cannot satisfy dependency:
        From: Java Server UI Support 1.1.202.v20110419 (org.eclipse.jst.server.ui 1.1.202.v20110419)
        To: bundle org.eclipse.jdt.debug.ui [3.2.100,4.0.0)
      Cannot satisfy dependency:
        From: JST Server UI 3.4.0.v20120503_1042-7A77FHr9xFcC2CFLZBCJMHLg7D64 (org.eclipse.jst.server_ui.feature.feature.group 3.4.0.v20120503_1042-7A77FHr9xFcC2CFLZBCJMHLg7D64)
        To: org.eclipse.jst.server.ui [1.1.202.v20110419]
      Cannot satisfy dependency:
        From: m2e - Maven Integration for Eclipse 1.2.0.20120903-1050 (org.eclipse.m2e.feature.feature.group 1.2.0.20120903-1050)
        To: org.eclipse.jdt.feature.group 3.6.0
      Cannot satisfy dependency:
        From: Groovy/Grails Tool Suite 3.2.0.201303060821-RELEASE-e38 (org.springsource.ggts.ide 3.2.0.201303060821-RELEASE-e38)
        To: org.springsource.ggts.package.feature.group [3.2.0.201303060821-RELEASE-e38]
      Cannot satisfy dependency:
        From: Groovy/Grails Tool Suite Package 3.2.0.201303060821-RELEASE-e38 (org.springsource.ggts.package.feature.group 3.2.0.201303060821-RELEASE-e38)
        To: org.codehaus.groovy.eclipse.feature.feature.group 2.0.0
      Cannot satisfy dependency:
        From: Groovy/Grails Tool Suite Package 3.2.0.201303060821-RELEASE-e38 (org.springsource.ggts.package.feature.group 3.2.0.201303060821-RELEASE-e38)
        To: org.eclipse.jst.server_ui.feature.feature.group 0.0.0
      Cannot satisfy dependency:
        From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.7.1.xx-RELEASE-20121219-0800-e37 Eclipse Java Development Tools 3.8.0.v20120525-1249-8-8nFqlFNOfwKDRGz-pXLdGxEM83 (org.eclipse.jdt.feature.group 3.8.0.v20120525-1249-8-8nFqlFNOfwKDRGz-pXLdGxEM83)
        To: org.eclipse.jdt.core [3.7.3.xx-RELEASE-20121219-0800-e37]
      Cannot satisfy dependency:
        From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.7.1.xx-RELEASE-20121219-0800-e37 Eclipse Java Development Tools 3.8.1.v20120814-104540-8-8nFqpFNOfwKDRVz-tXOcL5d_83 (org.eclipse.jdt.feature.group 3.8.1.v20120814-104540-8-8nFqpFNOfwKDRVz-tXOcL5d_83)
        To: org.eclipse.jdt.core [3.7.3.xx-RELEASE-20121219-0800-e37]
      Cannot satisfy dependency:
        From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.7.1.xx-RELEASE-20121219-0800-e37 Eclipse Java Development Tools 3.8.2.v20130116-090414-8-8nFu3FNOfwKLRuqgXKIy9z0I83 (org.eclipse.jdt.feature.group 3.8.2.v20130116-090414-8-8nFu3FNOfwKLRuqgXKIy9z0I83)
        To: org.eclipse.jdt.core [3.7.3.xx-RELEASE-20121219-0800-e37]
    Will appreciate any help,
    Yuriy.

  • #2
    You are trying to install the Groovy-Eclipse for e3.7. Try the e4.2 (Juno) version instead.

    http://dist.springsource.org/release/GRECLIPSE/e4.2/

    It should also be available from the dashboard extension page (opened when you boot up STS).

    Comment


    • #3
      This worked for me, thanks!

      Comment

      Working...
      X