Announcement Announcement Module
Collapse
No announcement yet.
Red exclamation mark next to project name in project explorer Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Red exclamation mark next to project name in project explorer

    In the Groovy/Grails Tool Suite, when one creates a Grails 2.2 project, one have to manually change the Groovy compiler version to 2.0 (error: Attachment ). After doing this, there's a red exclamation mark next to the project name in the project explorer window. What does the red exclamation mark mean? How can I get rid of the error? Re-compiling doesn't make it go away even though there seem to be no errors.
    Attached Files
    Last edited by earthling; Mar 10th, 2013, 05:41 PM. Reason: Attached a screenshot of the error before changing the Groovy compiler version

  • #2
    Groovy-Eclipse only supports one groovy compiler at a time (ie- if you want to switch compiler levels, you must go into your preferences, switch and restart). Each Groovy project keeps track of the compiler level that it expects (currently, this is not being matched to the grails version that it expects, but it should).

    So, what is happening here is that since you originally created your project with a 1.8.6 level, your project expects a groovy 1.8.x compiler, but it is finding a 2.0.x compiler.

    To fix, select the project, right-click -> Groovy -> Fix Compiler Mismatch problems. This brings up a dialog that allows you to set the project compiler level to the workspace level. And this should remove the !.

    Comment


    • #3
      Thank you for your response, Andrew. I couldn't find the option "Fix Compiler Mismatch problems" initially. After looking around for a bit, this seemed to work: go to the Dashboard -> Extensions -> Select Groovy 2.0 -> Install -> Restart. This made the red exclamation mark disappear and the option "Fix Compiler Mismatch problems" to appear in the project, right-click -> Groovy menu. I'm not sure how I could switch to Groovy 2.0 initially if the plugin wasn't installed. I'd done a Project -> right click -> Properties -> Groovy Compiler -> Select 2.0 from the dropdown.
      Thanks a lot for the help! I had been struggling with this for a while!

      Comment


      • #4
        Apologies, I had been a bit misleading. Groovy 2.0 was not installed by default until the 3.2.0 release (officially announced today). Now Groovy 2.0 is installed in GGTS when you unzip it.

        Comment

        Working...
        X