Announcement Announcement Module
Collapse
No announcement yet.
No repository found Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • No repository found

    So ... I went to update to the latest & greatest (3.2.0.201302181415-RC1-e42 of Groovy/Grails tool suite, and SPringSource UAA Integration) and I'm left with:

    An error occurred while collecting items to be installed
    session context wasprofile=DefaultProfile, phase=org.eclipse.equinox.internal.p2.engine.phase s.Collect, operand=, action=).
    No repository found containing: osgi.bundle,com.vmware.vfabric.ide.eclipse.tcserve r.core,3.2.0.201302180819-RC1
    No repository found containing: osgi.bundle,com.vmware.vfabric.ide.eclipse.tcserve r.insight.ui,3.2.0.201302180819-RC1
    No repository found containing: osgi.bundle,com.vmware.vfabric.ide.eclipse.tcserve r.livegraph,3.2.0.201302180819-RC1
    No repository found containing: osgi.bundle,com.vmware.vfabric.ide.eclipse.tcserve r.reloading,3.2.0.201302180819-RC1
    No repository found containing: osgi.bundle,com.vmware.vfabric.ide.eclipse.tcserve r.ui,3.2.0.201302180819-RC1
    No repository found containing: osgi.bundle,org.aspectj.ajde,1.7.2.20130214224500
    No repository found containing: osgi.bundle,org.aspectj.runtime,1.7.2.201302142245 00
    No repository found containing: osgi.bundle,org.aspectj.runtime.source,1.7.2.20130 214224500
    No repository found containing: osgi.bundle,org.aspectj.weaver,1.7.2.2013021422450 0
    No repository found containing: osgi.bundle,org.codehaus.groovy.eclipse,2.8.0.xx-20130215-1600-e42
    No repository found containing: osgi.bundle,org.codehaus.groovy.eclipse.ant,2.8.0. xx-20130215-1600-e42
    No repository found containing: osgi.bundle,org.codehaus.groovy.eclipse.astviews,2 .8.0.xx-20130215-1600-e42
    No repository found containing: osgi.bundle,org.codehaus.groovy.eclipse.codeassist .completion,2.8.0.xx-20130215-1600-e42
    No repository found containing: osgi.bundle,org.codehaus.groovy.eclipse.codebrowsi ng,2.8.0.xx-20130215-1600-e42
    No repository found containing: osgi.bundle,org.codehaus.groovy.eclipse.core,2.8.0 .xx-20130215-1600-e42
    No repository found containing: osgi.bundle,org.codehaus.groovy.eclipse.dsl,2.8.0. xx-20130215-1600-e42
    No repository found containing: osgi.bundle,org.codehaus.groovy.eclipse.quickfix,2 .8.0.xx-20130215-1600-e42
    No repository found containing: osgi.bundle,org.codehaus.groovy.eclipse.refactorin g,2.8.0.xx-20130215-1600-e42
    No repository found containing: osgi.bundle,org.codehaus.groovy.eclipse.ui,2.8.0.x x-20130215-1600-e42
    No repository found containing: osgi.bundle,org.codehaus.groovy.frameworkadapter,2 .8.0.xx-20130215-1600-e42
    No repository found containing: osgi.bundle,org.eclipse.ajdt.core,2.2.2.e42x-20130214-2200
    No repository found containing: osgi.bundle,org.eclipse.ajdt.core.source,2.2.2.e42 x-20130214-2200
    No repository found containing: osgi.bundle,org.eclipse.ajdt.doc.user,2.2.2.e42x-20130214-2200
    No repository found containing: osgi.bundle,org.eclipse.ajdt.examples,2.2.2.e42x-20130214-2200
    No repository found containing: osgi.bundle,org.eclipse.ajdt.examples.source,2.2.2 .e42x-20130214-2200
    No repository found containing: osgi.bundle,org.eclipse.ajdt.mylyn.ui,2.2.0.e42x-20130214-2200
    No repository found containing: osgi.bundle,org.eclipse.ajdt.mylyn.ui.source,2.2.0 .e42x-20130214-2200
    No repository found containing: osgi.bundle,org.eclipse.ajdt.ui,2.2.2.e42x-20130214-2200
    No repository found containing: osgi.bundle,org.eclipse.ajdt.ui.source,2.2.2.e42x-20130214-2200
    No repository found containing: osgi.bundle,org.eclipse.aspectj,2.2.2.e42x-20130214-2200
    No repository found containing: osgi.bundle,org.eclipse.compare,3.5.301.v20130125-135424
    No repository found containing: osgi.bundle,org.eclipse.contribution.visualiser,2. 2.2.e42x-20130214-2200
    No repository found containing: osgi.bundle,org.eclipse.contribution.visualiser.so urce,2.2.2.e42x-20130214-2200
    No repository found containing: osgi.bundle,org.eclipse.contribution.weaving.jdt,2 .2.2.e42x-20130214-2200
    No repository found containing: osgi.bundle,org.eclipse.contribution.weaving.jdt.s ource,2.2.2.e42x-20130214-2200
    No repository found containing: osgi.bundle,org.eclipse.contribution.xref.core,2.2 .2.e42x-20130214-2200
    No repository found containing: osgi.bundle,org.eclipse.contribution.xref.core.sou rce,2.2.2.e42x-20130214-2200
    No repository found containing: osgi.bundle,org.eclipse.contribution.xref.ui,2.2.2 .e42x-20130214-2200
    No repository found containing: osgi.bundle,org.eclipse.contribution.xref.ui.sourc e,2.2.2.e42x-20130214-2200
    No repository found containing: osgi.bundle,org.eclipse.debug.ui,3.8.2.v20130130-171415
    No repository found containing: osgi.bundle,org.eclipse.equinox.weaving.aspectj,1. 0.200.I20130127-2000
    No repository found containing: osgi.bundle,org.eclipse.equinox.weaving.aspectj.so urce,1.0.200.I20130127-2000
    No repository found containing: osgi.bundle,org.eclipse.equinox.weaving.caching,1. 0.200.I20130127-2000
    No repository found containing: osgi.bundle,org.eclipse.equinox.weaving.caching.j9 ,1.0.200.I20130127-2000
    No repository found containing: osgi.bundle,org.eclipse.equinox.weaving.caching.j9 .source,1.0.200.I20130127-2000
    No repository found containing: osgi.bundle,org.eclipse.equinox.weaving.caching.so urce,1.0.200.I20130127-2000
    No repository found containing: osgi.bundle,org.eclipse.equinox.weaving.hook,1.0.2 00.I20130127-2000
    No repository found containing: osgi.bundle,org.eclipse.equinox.weaving.hook.sourc e,1.0.200.I20130127-2000
    No repository found containing: osgi.bundle,org.eclipse.help.base,3.6.101.v2013020 41200
    No repository found containing: osgi.bundle,org.eclipse.jdt.core,3.8.2.xx-20130215-1600-e42
    No repository found containing: osgi.bundle,org.eclipse.jdt.groovy.core,2.8.0.xx-20130215-1600-e42
    No repository found containing: osgi.bundle,org.eclipse.platform,4.2.2.v2013020412 00
    No repository found containing: osgi.bundle,org.eclipse.rcp,4.2.1.v201302041200
    No repository found containing: osgi.bundle,org.eclipse.team.ui,3.6.201.v20130125-135424
    No repository found containing: osgi.bundle,org.grails.ide.eclipse.core,3.2.0.2013 02180809-RC1
    No repository found containing: osgi.bundle,org.grails.ide.eclipse.editor.groovy,3 .2.0.201302180809-RC1
    No repository found containing: osgi.bundle,org.grails.ide.eclipse.editor.gsp,3.2. 0.201302180809-RC1
    No repository found containing: osgi.bundle,org.grails.ide.eclipse.explorer,3.2.0. 201302180809-RC1
    No repository found containing: osgi.bundle,org.grails.ide.eclipse.groovy.debug.co re,3.2.0.201302180809-RC1
    No repository found containing: osgi.bundle,org.grails.ide.eclipse.groovy.debug.ui ,3.2.0.201302180809-RC1
    No repository found containing: osgi.bundle,org.grails.ide.eclipse.maven,3.2.0.201 302180809-RC1
    No repository found containing: osgi.bundle,org.grails.ide.eclipse.refactoring,3.2 .0.201302180809-RC1
    No repository found containing: osgi.bundle,org.grails.ide.eclipse.resources,3.2.0 .201302180809-RC1
    No repository found containing: osgi.bundle,org.grails.ide.eclipse.runonserver,3.2 .0.201302180809-RC1
    No repository found containing: osgi.bundle,org.grails.ide.eclipse.runtime.shared, 3.2.0.201302180809-RC1
    No repository found containing: osgi.bundle,org.grails.ide.eclipse.runtime13,3.2.0 .201302180809-RC1
    No repository found containing: osgi.bundle,org.grails.ide.eclipse.runtime22,3.2.0 .201302180809-RC1
    No repository found containing: osgi.bundle,org.grails.ide.eclipse.search,3.2.0.20 1302180809-RC1
    No repository found containing: osgi.bundle,org.grails.ide.eclipse.ui,3.2.0.201302 180809-RC1
    No repository found containing: osgi.bundle,org.springframework.ide.eclipse.uaa,3. 2.0.201302180752-RC1
    No repository found containing: osgi.bundle,org.springsource.ggts,3.2.0.2013021814 15-RC1
    No repository found containing: osgi.bundle,org.springsource.ide.eclipse.commons.c onfigurator,3.2.0.201302180752-RC1
    No repository found containing: osgi.bundle,org.springsource.ide.eclipse.commons.c ontent.core,3.2.0.201302180752-RC1
    No repository found containing: osgi.bundle,org.springsource.ide.eclipse.commons.c ore,3.2.0.201302180752-RC1
    No repository found containing: osgi.bundle,org.springsource.ide.eclipse.commons.f rameworks.core,3.2.0.201302180752-RC1
    No repository found containing: osgi.bundle,org.springsource.ide.eclipse.commons.f rameworks.ui,3.2.0.201302180752-RC1
    No repository found containing: osgi.bundle,org.springsource.ide.eclipse.commons.l ivexp,3.2.0.201302180752-RC1
    No repository found containing: osgi.bundle,org.springsource.ide.eclipse.commons.u i,3.2.0.201302180752-RC1
    No repository found containing: osgi.bundle,org.springsource.ide.eclipse.dashboard .ui,3.2.0.201302180752-RC1
    No repository found containing: org.eclipse.update.feature,com.vmware.vfabric.ide. eclipse.tcserver,3.2.0.201302180819-RC1
    No repository found containing: org.eclipse.update.feature,com.vmware.vfabric.ide. eclipse.tcserver.insight,3.2.0.201302180819-RC1
    No repository found containing: osgi.bundle,org.codehaus.groovy,1.8.6.xx-20130215-1600-e42
    No repository found containing: osgi.bundle,org.codehaus.groovy,2.0.6.xx-20130215-1600-e42
    No repository found containing: org.eclipse.update.feature,org.codehaus.groovy.ecl ipse.feature,2.8.0.xx-20130215-1600-e42
    .
    .
    .


    I'm currently running 3.2.0.M2 ... and this issue with updating has been happening a lot lately. With the last revision of the STS, I ended up performing a complete reinstall to get to the latest.

    Any ideas on how to resolve this?

    Thanks,

    dr_j

  • #2
    Hey!

    Most of the times removing and re-adding the update sites in Eclipse/STS helps. To make it a little bit easier, you could also do this:
    http://www.digitalsanctuary.com/tech...e-eclipse.html

    Deleting the p2 repository cache also helps from time to time (p2/org.eclipse.equinox.p2.repository/cache).

    HTH,
    Martin

    Comment


    • #3
      Partial success

      Wow .. I'm not sure what to say. This partially worked; at first, I followed the procedures and added the "/" to the end of all the update sites. This resulted in 2 updates NOT appearing anymore (the ones I was interested in, the groovy/grails update being the primary one). An attempt to update anyway, picking up the 2 updates that were listed failed with the "no repository found" error.

      Reading through the comments on the post, though, some people had success with removing the trailing "/", so ... I went through and did that. The 2 updates I was most interested in were now listed ... but the 2 that had shown up in the last step were now gone. However, an attempt to update was, indeed, successful.

      I think some update sites require the slash, and some do not ... and somewhere in there is a bum site that is blocking everything. Now I just have to narrow it down (hopefully I remembered to back up my bookmarks.xml).

      Many thanks,

      dr_j

      Comment


      • #4
        Hey!

        I would wonder whether this is indeed related to the trailing "/" or just to the fact that you are changing URLs - which causes p2 to flush caches. Did you try to verify the "/" assumption with a fresh STS/Eclipse install?

        Just asking because I also saw people just deleting and adding update sites to fix similar problems.

        But if your assumption about the trailing "/" turns out to be correct, that would indeed be very very interesting and great for other users that are facing similar issues.

        Let me know what you find out!!!

        Cheers,
        -Martin

        Comment


        • #5
          No, I didn't do a fresh STS install; I've been trying to avoid that (I reinstalled clean just a few weeks ago, as that was the only way I could get an upgrade to the latest milestone release working).

          It may well be that flushing the caches is what did it; by toggling back and forth between slashes and no slashes, every single URL was touched one way or the other, so the cache may well have been completely cleaned up.

          The next time I run into this issue, I'll try dumping the caches. This seems to happen with fair frequency, so I expect it to occur again in the next few weeks. It's frustrating when it does happen; if it is the caches, then maybe some form of auto-flush is in order (just a stab in the dark).

          Comment


          • #6
            Here's a quick update; the other day, a slew of updates to my installation of STS became available ... and of course, I get the same set of errors that no repository could be found. I tried the method of deleting the cache first (as Martin suggested, at p2/org.eclipse.equinox.p2.repository/cache). That, however, had no effect.

            What I opted to do that did work was to export my list of repositories; delete all the repositories from the list of available sites, and then import the list. Once I did that, my update went smoothly with no errors.

            I'm still puzzled over why this happens; it seems to happen with great regularity ... but at least now it seems there is a decent workaround.

            Thanks all!

            Comment


            • #7
              Hey!

              Thanks for letting us know and thanks for sharing the solution.
              I guess that will help many other users who are facing this problem.

              Thanks again!
              -Martin

              Comment

              Working...
              X