Announcement Announcement Module
Collapse
No announcement yet.
STS/GGTS with Groovy 1.6 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS/GGTS with Groovy 1.6

    Hello,

    we want to set up our grails project with Eclipse and GGTS. Unfortunately no GGTS version, even the older ones, do support Groovy 1.6 which our software does rely on.

    What chances to we have? Usage of 1.7 compiler e.g. produces dozens of errors like:

    Code:
    org.codehaus.groovy.control.messages.SyntaxErrorMessage@12fbe81a
    ... or ..
    Code:
    /shop-1project/shop/grails-app/conf/__2F_shop_2D_1project_2F_shop_2F_grails_2D_app_2F_views_2F_standardShop_2F_home_2E_gsp.groovy: 6 Groovy:Invalid duplicate class definition of class __2F_shop_2D_1project_2F_shop_2F_grails_2D_app_2F_views_2F_standardShop_2F_home_2E_gsp : The source /home/cklein/Entwicklung/projekte/shop/shop/grails-app/conf/__2F_shop_2D_1project_2F_shop_2F_grails_2D_app_2F_views_2F_standardShop_2F_home_2E_gsp.groovy contains at least two definitions of the class __2F_shop_2D_1project_2F_shop_2F_grails_2D_app_2F_views_2F_standardShop_2F_home_2E_gsp.
    ... or ...
    Code:
    /shop-1project/shop/grails-app/services/de/bechtle/shop/service/controller/OrderHistoryService.groovy: 119 Groovy:cannot modify final field 'customerNumbers' outside of constructor.
    NOTE: We definitively can not upgrade our software due to business reasons.


    Regards,
    cklein

  • #2
    Unfortunately, we dropped support for Groovy 1.6 years ago. You will need to install Groovy-Eclipse 2.0.2. This will install into Eclipse 3.6.

    You can get a copy of Groovy-Eclipse 2.0.2 here: http://dist.springsource.org.s3.amaz...0-0900-e36.zip

    Download it and point your Eclipse install manager to the zip file (no need to unzip it). As for grails support, it was still in its infancy for the 2.0.2 release.

    Here are the links to the STS installations:

    Windows http://dist.springsource.com/release...-installer.exe
    Windows http://dist.springsource.com/release....6.1-win32.zip
    Windows (64bit) http://dist.springsource.com/release...-installer.exe
    Windows (64bit) http://dist.springsource.com/release...n32-x86_64.zip
    Mac OS X (Carbon) http://dist.springsource.com/release...-installer.dmg
    Mac OS X (Carbon) http://dist.springsource.com/release...-carbon.tar.gz
    Mac OS X (Cocoa) http://dist.springsource.com/release...-installer.dmg
    Mac OS X (Cocoa) http://dist.springsource.com/release...x-cocoa.tar.gz
    Mac OS X (Cocoa, 64bit) http://dist.springsource.com/release...-installer.dmg
    Mac OS X (Cocoa, 64bit) http://dist.springsource.com/release...-x86_64.tar.gz
    Linux (GTK) http://dist.springsource.com/release...k-installer.sh
    Linux (GTK) http://dist.springsource.com/release...nux-gtk.tar.gz
    Linux (GTK, 64bit) http://dist.springsource.com/release...4-installer.sh
    Linux (GTK, 64bit) http://dist.springsource.com/release...-x86_64.tar.gz

    Let me know if you have any troubles.

    Comment


    • #3
      Hello Andrew.

      Thank you very much for this quick reply.

      Your advice sounds very promising. I'll give it try and give you a feedback afterwards.


      Regards
      cklein

      Comment


      • #4
        Hello Andrew.

        Indeed we do have trouble with your advice.

        Sure we can install Groovy-Eclipse 2.0.2 but how do we get grails support then? You say grails support was in its infancy. Does that mean that it is not available at all for GRECLIPSE-2.0.2?

        Furthermore you have posted links to the 2.5.0 release of the STS. We tried them but ran into dependency errors when installing the "Grails support" extension at the dashboard.
        Code:
        Problems occurred while performing installation: Operation details
        Operation details
        Cannot complete the install because of a conflicting dependency.
        Software being installed: SpringSource Tool Suite Grails Support 2.9.2.201205071000-RELEASE (com.springsource.sts.grails.feature.group 2.9.2.201205071000-RELEASE)
        Software currently installed: SpringSource Tool Suite 2.5.0.201010241000-RELEASE (com.springsource.sts.ide 2.5.0.201010241000-RELEASE)
        Only one of the following can be installed at once: 
        SpringSource Tool Suite Application Platform Quick Fixes 2.5.0.201010241000-RELEASE (com.springsource.sts.quickfix 2.5.0.201010241000-RELEASE)
        SpringSource Tool Suite Quick Fixes 2.9.2.201205071000-RELEASE (com.springsource.sts.quickfix 2.9.2.201205071000-RELEASE)
        Cannot satisfy dependency:
        From: SpringSource Tool Suite (required) 2.5.0.201010241000-RELEASE (com.springsource.sts.feature.group 2.5.0.201010241000-RELEASE)
        To: com.springsource.sts.quickfix [2.5.0.201010241000-RELEASE]
        Cannot satisfy dependency:
        From: SpringSource Tool Suite (required) 2.9.2.201205071000-RELEASE (com.springsource.sts.feature.group 2.9.2.201205071000-RELEASE)
        To: com.springsource.sts.quickfix [2.9.2.201205071000-RELEASE]
        Cannot satisfy dependency:
        From: SpringSource Tool Suite Grails Support 2.9.2.201205071000-RELEASE (com.springsource.sts.grails.feature.group 2.9.2.201205071000-RELEASE)
        To: com.springsource.sts.feature.group [2.9.2,2.10.0)
        Cannot satisfy dependency:
        From: SpringSource Tool Suite 2.5.0.201010241000-RELEASE (com.springsource.sts.ide 2.5.0.201010241000-RELEASE)
        To: com.springsource.sts.package.feature.group [2.5.0.201010241000-RELEASE]
        Cannot satisfy dependency:
        From: SpringSource Tool Suite Package 2.5.0.201010241000-RELEASE (com.springsource.sts.package.feature.group 2.5.0.201010241000-RELEASE)
        To: com.springsource.sts.server.cf.feature.group 0.0.0
        Cannot satisfy dependency:
        From: SpringSource Tool Suite Cloud Foundry Integration 2.5.0.201010241000-RELEASE (com.springsource.sts.server.cf.feature.group 2.5.0.201010241000-RELEASE)
        To: com.springsource.sts.feature.group [2.5.0,2.6.0)
        Furthermore the "Groovy support" extension does not install the Groovy-1.6 compiler so we can't get along with that version anyway.
        Code:
        org.codehaus.groovy,1.7.10.xx-20120301-1300-e36-RELEASE,plugins/org.codehaus.groovy_1.7.10.xx-20120301-1300-e36-RELEASE/,4,false
        org.codehaus.groovy,1.8.6.xx-20120301-1300-e36-RELEASE,plugins/org.codehaus.groovy_1.8.6.xx-20120301-1300-e36-RELEASE/,4,false
        What we need is actually a running version of STS/GGTS with a Groovy 1.6 compiler as a backend. Is that possible or not?

        Regards,
        cklein

        Comment


        • #5
          Unfortunately, you cannot use the extension page to install. Back in those days, we were not as good at keeping our update sites coherent for older versions.

          Try this:

          1. download and unzip STS 2.5.0
          2. Use this update site to install Groovy-Eclipse: http://dist.springsource.org/release...0-0900-e36.zip
          3. Use this update site to install Grails-IDE http://dist.springsource.com/release....RELEASE/e3.6/

          The reason that you are not seeing the Groovy 1.6 compiler is that you are trying to install from the extensions page, which does not have the correct stuff in it.

          Comment


          • #6
            Finally we performed an upgrade to Grails-1.3.9 with Groovy 1.7 thus I'm not gonna test this anymore.

            Comment


            • #7
              That is a much better move. :-)

              Comment

              Working...
              X