Announcement Announcement Module
Collapse
No announcement yet.
Problem in installing the STS with the eclipse marketplac Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem in installing the STS with the eclipse marketplac

    Hi.

    i'm working with eclipse indigo (3.7).

    I installed the STS (Spring Tool Suite) with the eclipse marketplace, and nothing seems to changed (after all the load and restart), i cant see the STS dashboard, and when i go to:

    help -> about eclipse,

    i don't see any sign for STS (but all my other installations are showed).

    when i go to the eclipse marketplace and search for STS (for eclipse 3.7), it is showing me that it is installed!

    I tried the solution of going to: window->preferences-> spring , and there checking the dashboard, but in my case there is no such an option there..

    This is very weird, suggestions anyone?

  • #2
    Hey!

    So there was no error message coming up during the installation itself (complaining about missing resources or so)? If you open the welcome screen, there is nothing showing up for Spring tooling and AspectJ tooling?

    I tried this with a vanilla Eclipse JEE Indigo SR2 installation and it works in general, so I expect a conflict with another installed extension maybe.

    Can you open up a console view, switch to "OSGi Host Console" and type in "ss" for "short status"?
    Maybe there are some bundles in the state of just "INSTALLED" instead of something else? Can you check that?

    -Martin

    Comment


    • #3
      Hi Martin,
      I did what you suggested, here's some part of the output where i started to see "INSTALLED":

      1354 INSTALLED org.eclipse.mylyn.bugzilla.core_3.8.2.v20120916-1200
      1355 INSTALLED org.eclipse.mylyn.bugzilla.ide_3.8.2.v20120916-1200
      1356 INSTALLED org.eclipse.mylyn.bugzilla.ui_3.8.2.v20120916-1200
      1357 <<LAZY>> org.eclipse.mylyn.commons.identity_0.9.1.v20120412-0100
      1358 <<LAZY>> org.eclipse.mylyn.commons.identity.core_1.0.2.v201 20916-1200
      1359 INSTALLED org.eclipse.mylyn.commons.net_3.8.2.v20120916-1200
      1360 INSTALLED org.eclipse.mylyn.commons.notifications_0.9.1.v201 20412-0100
      1361 INSTALLED org.eclipse.mylyn.commons.notifications.core_1.0.2 .v20120916-1200
      1362 INSTALLED org.eclipse.mylyn.commons.notifications.feed_1.0.2 .v20120916-1200
      1363 INSTALLED org.eclipse.mylyn.commons.notifications.ui_1.0.2.v 20120916-1200
      1364 INSTALLED org.eclipse.mylyn.commons.repositories_0.9.1.v2012 0412-0100
      1365 INSTALLED org.eclipse.mylyn.commons.repositories.core_1.0.2. v20120916-1200
      1366 INSTALLED org.eclipse.mylyn.commons.repositories.ui_1.0.2.v2 0120916-1200
      1367 INSTALLED org.eclipse.mylyn.commons.team_0.9.1.v20120412-0100
      1368 INSTALLED org.eclipse.mylyn.commons.workbench_3.8.2.v2012091 6-1200
      1369 INSTALLED org.eclipse.mylyn.commons.xmlrpc_3.8.2.v20120916-1200
      1370 INSTALLED org.eclipse.mylyn.context.core_3.8.2.v20120916-1200
      1371 INSTALLED org.eclipse.mylyn.context.tasks.ui_3.8.2.v20120916-1200
      1372 INSTALLED org.eclipse.mylyn.context.ui_3.8.2.v20120916-1200
      1373 INSTALLED org.eclipse.mylyn.discovery.core_3.8.2.v20120916-1200
      1374 INSTALLED org.eclipse.mylyn.discovery.ui_3.8.2.v20120916-1200
      1375 <<LAZY>> org.eclipse.mylyn.help.ui_3.8.2.v20120916-1200
      1376 INSTALLED org.eclipse.mylyn.ide.ant_3.8.2.v20120916-1200
      1377 INSTALLED org.eclipse.mylyn.ide.ui_3.8.2.v20120916-1200
      1378 INSTALLED org.eclipse.mylyn.java.tasks_3.8.2.v20120916-1200
      1379 INSTALLED org.eclipse.mylyn.java.ui_3.8.2.v20120916-1200
      1380 INSTALLED org.eclipse.mylyn.monitor.core_3.8.2.v20120916-1200
      1381 INSTALLED org.eclipse.mylyn.monitor.ui_3.8.2.v20120916-1200
      1382 INSTALLED org.eclipse.mylyn.resources.ui_3.8.2.v20120916-1200
      1383 INSTALLED org.eclipse.mylyn.tasks.bugs_3.8.2.v20120916-1200
      1384 INSTALLED org.eclipse.mylyn.tasks.core_3.8.2.v20120916-1200
      1385 INSTALLED org.eclipse.mylyn.tasks.index.core_3.8.2.v20120916-1200
      1386 INSTALLED org.eclipse.mylyn.tasks.index.ui_3.8.2.v20120916-1200
      1387 INSTALLED org.eclipse.mylyn.tasks.search_3.8.2.v20120916-1200
      1388 INSTALLED org.eclipse.mylyn.tasks.ui_3.8.2.v20120916-1200
      1389 INSTALLED org.eclipse.mylyn.team.cvs_3.8.2.v20120916-1200
      1390 INSTALLED org.eclipse.mylyn.team.ui_3.8.2.v20120916-1200
      1496 <<LAZY>> org.springsource.ide.eclipse.commons.frameworks.co re_3.2.0.201301292010-CI-B173
      1497 INSTALLED org.springsource.ide.eclipse.commons.frameworks.ui _3.2.0.201301292010-CI-B173
      1498 <<LAZY>> org.springsource.ide.eclipse.commons.livexp_3.2.0. 201301292010-CI-B173
      1499 INSTALLED org.springsource.ide.eclipse.commons.ui_3.2.0.2013 01292010-CI-B173

      Master=0
      1514 <<LAZY>> org.codehaus.groovy_1.8.6.xx-20130219-1300-e37
      1515 ACTIVE org.codehaus.groovy_2.0.6.xx-20130219-1300-e37

      1517 <<LAZY>> org.codehaus.groovy.eclipse.ant_2.8.0.xx-20130219-1300-e37
      1518 <<LAZY>> org.codehaus.groovy.eclipse.astviews_2.8.0.xx-20130219-1300-e37
      1519 <<LAZY>> org.codehaus.groovy.eclipse.codeassist.completion_ 2.8.0.xx-20130219-1300-e37
      1520 <<LAZY>> org.codehaus.groovy.eclipse.codebrowsing_2.8.0.xx-20130219-1300-e37
      1523 <<LAZY>> org.codehaus.groovy.eclipse.quickfix_2.8.0.xx-20130219-1300-e37
      1524 <<LAZY>> org.codehaus.groovy.eclipse.refactoring_2.8.0.xx-20130219-1300-e37
      1525 <<LAZY>> org.codehaus.groovy.eclipse.ui_2.8.0.xx-20130219-1300-e37
      1526 ACTIVE org.eclipse.jdt.core_3.7.3.xx-20130219-1300-e37
      Fragments=320, 321
      1573 INSTALLED org.grails.ide.eclipse.core_3.1.0.201210040544-RELEASE
      1574 INSTALLED org.grails.ide.eclipse.editor.groovy_3.1.0.2012100 40544-RELEASE
      1575 INSTALLED org.grails.ide.eclipse.editor.gsp_3.1.0.2012100405 44-RELEASE
      1576 INSTALLED org.grails.ide.eclipse.explorer_3.1.0.201210040544-RELEASE
      1577 <<LAZY>> org.grails.ide.eclipse.groovy.debug.core_3.1.0.201 210040544-RELEASE
      1578 <<LAZY>> org.grails.ide.eclipse.groovy.debug.ui_3.1.0.20121 0040544-RELEASE
      1579 INSTALLED org.grails.ide.eclipse.maven_3.1.0.201210040544-RELEASE
      1580 INSTALLED org.grails.ide.eclipse.refactoring_3.1.0.201210040 544-RELEASE
      1581 <<LAZY>> org.grails.ide.eclipse.resources_3.1.0.20121004054 4-RELEASE
      1582 INSTALLED org.grails.ide.eclipse.runonserver_3.1.0.201210040 544-RELEASE
      1583 RESOLVED org.grails.ide.eclipse.runtime.shared_3.1.0.201210 040544-RELEASE

      1586 INSTALLED org.grails.ide.eclipse.search_3.1.0.201210040544-RELEASE
      1587 INSTALLED org.grails.ide.eclipse.ui_3.1.0.201210040544-RELEASE
      1651 <<LAZY>> org.eclipse.m2e.core.ui_1.2.0.20120903-1050

      1654 RESOLVED org.eclipse.m2e.maven.runtime_1.2.0.20120903-0645
      1655 <<LAZY>> org.eclipse.m2e.model.edit_1.2.0.20120903-1050

      1730 INSTALLED com.vmware.vfabric.ide.eclipse.tcserver.core_3.1.0 .201210040536-RELEASE
      1731 INSTALLED com.vmware.vfabric.ide.eclipse.tcserver.insight.ui _3.1.0.201210040536-RELEASE
      1732 INSTALLED com.vmware.vfabric.ide.eclipse.tcserver.livegraph_ 3.1.0.201210040536-RELEASE
      1733 <<LAZY>> com.vmware.vfabric.ide.eclipse.tcserver.reloading_ 3.1.0.201210040536-RELEASE
      1734 INSTALLED com.vmware.vfabric.ide.eclipse.tcserver.ui_3.1.0.2 01210040536-RELEASE


      1742 <<LAZY>> org.eclipse.ajdt.examples_2.2.1.e37x-20130216-1800
      1743 <<LAZY>> org.eclipse.ajdt.mylyn.ui_2.2.1.e37x-20130216-1800
      1744 ACTIVE org.eclipse.ajdt.ui_2.2.1.e37x-20130216-1800
      1745 <<LAZY>> org.eclipse.aspectj_2.2.1.e37x-20130216-1800
      1746 <<LAZY>> org.eclipse.contribution.visualiser_2.2.1.e37x-20130216-1800
      1747 <<LAZY>> org.eclipse.contribution.xref.core_2.2.1.e37x-20130216-1800
      1748 <<LAZY>> org.eclipse.contribution.xref.ui_2.2.1.e37x-20130216-1800

      1763 <<LAZY>> org.springframework.ide.eclipse.ajdt.ui.visualiser _3.1.0.201210040510-RELEASE
      1764 <<LAZY>> org.springframework.ide.eclipse.ajdt.ui.xref_3.1.0 .201210040510-RELEASE
      1765 ACTIVE org.springframework.ide.eclipse.aop.core_3.1.0.201 210040510-RELEASE
      1766 INSTALLED org.springframework.ide.eclipse.aop.mylyn_3.1.0.20 1210040510-RELEASE
      1767 ACTIVE org.springframework.ide.eclipse.aop.ui_3.1.0.20121 0040510-RELEASE
      1768 <<LAZY>> org.springframework.ide.eclipse.aop.ui.matcher_3.1 .0.201210040510-RELEASE
      1769 <<LAZY>> org.springframework.ide.eclipse.batch_3.1.0.201210 040510-RELEASE
      1770 ACTIVE org.springframework.ide.eclipse.beans.core_3.1.0.2 01210040510-RELEASE
      1771 <<LAZY>> org.springframework.ide.eclipse.beans.core.autowir e_3.1.0.201210040510-RELEASE
      1772 <<LAZY>> org.springframework.ide.eclipse.beans.core.metadat a_3.1.0.201210040510-RELEASE
      1773 INSTALLED org.springframework.ide.eclipse.beans.mylyn_3.1.0. 201210040510-RELEASE
      1774 ACTIVE org.springframework.ide.eclipse.beans.ui_3.1.0.201 210040510-RELEASE
      1775 <<LAZY>> org.springframework.ide.eclipse.beans.ui.autowire_ 3.1.0.201210040510-RELEASE
      1776 <<LAZY>> org.springframework.ide.eclipse.beans.ui.editor_3. 1.0.201210040510-RELEASE
      1777 <<LAZY>> org.springframework.ide.eclipse.beans.ui.graph_3.1 .0.201210040510-RELEASE
      1778 INSTALLED org.springframework.ide.eclipse.beans.ui.livegraph _3.1.0.201210040510-RELEASE
      1779 <<LAZY>> org.springframework.ide.eclipse.beans.ui.refactori ng_3.1.0.201210040510-RELEASE
      1780 <<LAZY>> org.springframework.ide.eclipse.beans.ui.search_3. 1.0.201210040510-RELEASE
      1781 INSTALLED org.springframework.ide.eclipse.bestpractices_3.1. 0.201210040510-RELEASE
      1782 INSTALLED org.springframework.ide.eclipse.config.core_3.1.0. 201210040510-RELEASE
      1783 INSTALLED org.springframework.ide.eclipse.config.graph_3.1.0 .201210040510-RELEASE
      1784 INSTALLED org.springframework.ide.eclipse.config.ui_3.1.0.20 1210040510-RELEASE

      1788 <<LAZY>> org.springframework.ide.eclipse.integration_3.1.0. 201210040510-RELEASE
      1789 INSTALLED org.springframework.ide.eclipse.maven_3.1.0.201210 040510-RELEASE
      1790 INSTALLED org.springframework.ide.eclipse.maven.legacy_3.1.0 .201210040510-RELEASE
      1791 INSTALLED org.springframework.ide.eclipse.metadata_3.1.0.201 210040510-RELEASE
      1792 INSTALLED org.springframework.ide.eclipse.mylyn_3.1.0.201210 040510-RELEASE
      1793 <<LAZY>> org.springframework.ide.eclipse.osgi_3.1.0.2012100 40510-RELEASE
      1794 <<LAZY>> org.springframework.ide.eclipse.osgi.runtime_3.1.0 .201210040510-RELEASE
      1795 ACTIVE org.springframework.ide.eclipse.osgi.targetdefinit ion_3.1.0.201210040510-RELEASE
      1796 INSTALLED org.springframework.ide.eclipse.quickfix_3.1.0.201 210040510-RELEASE
      1797 INSTALLED org.springframework.ide.eclipse.roo.core_3.1.0.201 210040510-RELEASE
      1798 INSTALLED org.springframework.ide.eclipse.roo.ui_3.1.0.20121 0040510-RELEASE
      1799 <<LAZY>> org.springframework.ide.eclipse.security_3.1.0.201 210040510-RELEASE
      1800 ACTIVE org.springframework.ide.eclipse.uaa_3.1.0.20121004 0458-RELEASE
      1801 ACTIVE org.springframework.ide.eclipse.ui_3.1.0.201210040 510-RELEASE
      1802 <<LAZY>> org.springframework.ide.eclipse.webflow.core_3.1.0 .201210040510-RELEASE
      1803 INSTALLED org.springframework.ide.eclipse.webflow.mylyn_3.1. 0.201210040510-RELEASE
      1804 <<LAZY>> org.springframework.ide.eclipse.webflow.ui_3.1.0.2 01210040510-RELEASE
      1805 <<LAZY>> org.springframework.ide.eclipse.webflow.ui.editor_ 3.1.0.201210040510-RELEASE
      1806 <<LAZY>> org.springframework.ide.eclipse.webflow.ui.graph_3 .1.0.201210040510-RELEASE
      1807 INSTALLED org.springframework.ide.eclipse.wizard_3.1.0.20121 0040510-RELEASE
      1808 RESOLVED org.springframework.jdbc_3.1.1.RELEASE

      1822 INSTALLED org.springsource.ide.eclipse.dashboard.ui_3.1.0.20 1210040458-RELEASE

      Comment


      • #4
        Hey!

        Thanks for the details, this clearly looks like some heavy conflicts in your installation. Can you type "diag 1822", "diag 1499", and "diag 1377" and post the output here? I would like to see it in order to find out what exactly went wrong here.

        -Martin

        Comment


        • #5
          diag 1822:

          reference:file plugins/org.springsource.ide.eclipse.dashboard.ui_3.1.0.20 1210040458-RELEASE.jar [1822
          Direct constraints which are unresolved:
          Missing required bundle org.eclipse.mylyn.commons.core_[3.7.0,4.0.0).
          Missing required bundle org.eclipse.mylyn.commons.ui_[3.7.0,4.0.0).
          Missing required bundle org.eclipse.mylyn.commons.net_[3.7.0,4.0.0).
          Missing required bundle org.eclipse.mylyn.commons.workbench_[3.7.0,4.0.0).
          Missing required bundle org.eclipse.mylyn.discovery.core_[3.7.0,4.0.0).
          Missing required bundle org.eclipse.mylyn.discovery.ui_[3.7.0,4.0.0).
          Missing required bundle org.eclipse.mylyn.tasks.bugs_[3.7.0,4.0.0).
          Missing required bundle org.eclipse.mylyn.tasks.core_[3.7.0,4.0.0).
          Missing required bundle org.eclipse.mylyn.tasks.ui_[3.7.0,4.0.0).
          Missing required bundle org.springsource.ide.eclipse.commons.core_0.0.0.
          Missing required bundle org.springsource.ide.eclipse.commons.ui_0.0.0.
          Missing required bundle org.springsource.ide.eclipse.commons.configurator_ 0.0.0.
          Leaf constraints in the dependency chain which are unresolved:
          reference:file plugins/org.eclipse.mylyn.commons.notifications.ui_1.0.2.v 20120916-1200.jar [1363
          Missing required bundle org.eclipse.mylyn.commons.core_3.8.0.
          reference:filelugins/org.eclipse.mylyn.tasks.bugs_3.8.2.v20120916-1200.jar [1383
          Missing required bundle org.eclipse.mylyn.commons.core_[3.8.0,4.0.0).
          reference:file plugins/org.eclipse.mylyn.tasks.ui_3.8.2.v20120916-1200.jar [1388
          Missing required bundle org.eclipse.mylyn.commons.ui_3.8.0.
          reference:file plugins/org.eclipse.mylyn.discovery.ui_3.8.2.v20120916-1200.jar [1374
          Missing required bundle org.eclipse.mylyn.commons.ui_[3.8.0,4.0.0).
          reference:file plugins/org.eclipse.mylyn.tasks.core_3.8.2.v20120916-1200.jar [1384]
          Missing required bundle org.eclipse.mylyn.commons.core_3.8.0.
          reference:file plugins/org.eclipse.mylyn.discovery.core_3.8.2.v20120916-1200.jar [1373]
          Missing required bundle org.eclipse.mylyn.commons.core_3.8.0.
          reference:file plugins/org.eclipse.mylyn.tasks.ui_3.8.2.v20120916-1200.jar [1388
          Missing required bundle org.eclipse.mylyn.commons.core_3.8.0.
          reference:file plugins/org.eclipse.mylyn.tasks.bugs_3.8.2.v20120916-1200.jar [1383]
          Missing required bundle org.eclipse.mylyn.commons.ui_[3.8.0,4.0.0).
          reference:file plugins/org.eclipse.mylyn.monitor.ui_3.8.2.v20120916-1200.jar [1381
          Missing required bundle org.eclipse.mylyn.commons.core_[3.8.0,4.0.0).
          reference:file plugins/org.springsource.ide.eclipse.commons.configurator_ 3.2.0.201301292010-CI-B173.jar [1493
          Missing required bundle org.eclipse.mylyn.commons.ui_[3.7.0,4.0.0).
          reference:file plugins/org.eclipse.mylyn.commons.workbench_3.8.2.v2012091 6-1200.jar [1368
          Missing required bundle org.eclipse.mylyn.commons.ui_3.8.0.
          reference:file plugins/org.eclipse.mylyn.commons.notifications.feed_1.0.2 .v20120916-1200.jar [1362
          Missing required bundle org.eclipse.mylyn.commons.core_0.0.0.
          reference:file plugins/org.eclipse.mylyn.discovery.ui_3.8.2.v20120916-1200.jar [1374
          Missing required bundle org.eclipse.mylyn.commons.core_[3.8.0,4.0.0).
          reference:file plugins/org.eclipse.mylyn.commons.notifications.core_1.0.2 .v20120916-1200.jar [1361
          Missing required bundle org.eclipse.mylyn.commons.core_0.0.0.
          reference:file plugins/org.eclipse.mylyn.commons.repositories.ui_1.0.2.v2 0120916-1200.jar [1366
          Missing required bundle org.eclipse.mylyn.commons.core_3.8.0.
          reference:file plugins/org.eclipse.mylyn.monitor.core_3.8.2.v20120916-1200.jar [1380
          Missing required bundle org.eclipse.mylyn.commons.core_[3.8.0,4.0.0).
          reference:file plugins/org.eclipse.mylyn.commons.repositories.ui_1.0.2.v2 0120916-1200.jar [1366
          Missing required bundle org.eclipse.mylyn.commons.ui_3.8.0.
          reference:file plugins/org.eclipse.mylyn.commons.notifications.ui_1.0.2.v 20120916-1200.jar [1363
          Missing required bundle org.eclipse.mylyn.commons.ui_3.8.0.
          reference:file plugins/org.eclipse.mylyn.commons.workbench_3.8.2.v2012091 6-1200.jar [1368
          Missing required bundle org.eclipse.mylyn.commons.core_3.8.0.
          reference:file plugins/org.eclipse.mylyn.context.core_3.8.2.v20120916-1200.jar [1370
          Missing required bundle org.eclipse.mylyn.commons.core_[3.8.0,4.0.0).
          reference:file plugins/org.eclipse.mylyn.commons.repositories.core_1.0.2. v20120916-1200.jar [1365
          Missing required bundle org.eclipse.mylyn.commons.core_0.0.0.
          reference:file plugins/org.eclipse.mylyn.commons.net_3.8.2.v20120916-1200.jar [1359
          Missing required bundle org.eclipse.mylyn.commons.core_0.0.0.

          Comment


          • #6
            diag 1499
            reference:file plugins/org.springsource.ide.eclipse.commons.ui_3.2.0.2013 01292010-CI-B173.jar [1499]
            Direct constraints which are unresolved:
            Missing required bundle org.springsource.ide.eclipse.commons.core_0.0.0.
            Leaf constraints in the dependency chain which are unresolved:
            reference:file plugins/org.eclipse.mylyn.commons.net_3.8.2.v20120916-1200.jar [1359]
            Missing required bundle org.eclipse.mylyn.commons.core_0.0.0.


            diag 1377
            reference:file plugins/org.eclipse.mylyn.ide.ui_3.8.2.v20120916-1200.jar [1377]
            Direct constraints which are unresolved:
            Missing required bundle org.eclipse.mylyn.commons.core_[3.8.0,4.0.0).
            Missing required bundle org.eclipse.mylyn.commons.ui_[3.8.0,4.0.0).
            Missing required bundle org.eclipse.mylyn.context.core_[3.8.0,4.0.0).
            Missing required bundle org.eclipse.mylyn.context.ui_[3.8.0,4.0.0).
            Missing required bundle org.eclipse.mylyn.resources.ui_[3.8.0,4.0.0).
            Leaf constraints in the dependency chain which are unresolved:
            reference:file plugins/org.eclipse.mylyn.commons.workbench_3.8.2.v2012091 6-1200.jar [1368]
            Missing required bundle org.eclipse.mylyn.commons.core_3.8.0.
            reference:file plugins/org.eclipse.mylyn.commons.workbench_3.8.2.v2012091 6-1200.jar [1368]
            Missing required bundle org.eclipse.mylyn.commons.ui_3.8.0.
            reference:file plugins/org.eclipse.mylyn.monitor.ui_3.8.2.v20120916-1200.jar [1381]
            Missing required bundle org.eclipse.mylyn.commons.core_[3.8.0,4.0.0).
            reference:file plugins/org.eclipse.mylyn.resources.ui_3.8.2.v20120916-1200.jar [1382]
            Missing required bundle org.eclipse.mylyn.commons.core_[3.8.0,4.0.0).
            reference:file plugins/org.eclipse.mylyn.context.ui_3.8.2.v20120916-1200.jar [1372]
            Missing optionally required bundle org.eclipse.e4.ui.workbench_0.10.1.
            reference:file plugins/org.eclipse.mylyn.context.ui_3.8.2.v20120916-1200.jar [1372]
            Missing required bundle org.eclipse.mylyn.commons.ui_[3.8.0,4.0.0).
            reference:file plugins/org.eclipse.mylyn.context.ui_3.8.2.v20120916-1200.jar [1372]
            Missing optionally required bundle org.eclipse.e4.ui.model.workbench_0.10.0.
            reference:file plugins/org.eclipse.mylyn.resources.ui_3.8.2.v20120916-1200.jar [1382]
            Missing required bundle org.eclipse.mylyn.commons.ui_[3.8.0,4.0.0).
            reference:file plugins/org.eclipse.mylyn.context.ui_3.8.2.v20120916-1200.jar [1372]
            Missing required bundle org.eclipse.mylyn.commons.core_[3.8.0,4.0.0).
            reference:file plugins/org.eclipse.mylyn.monitor.core_3.8.2.v20120916-1200.jar [1380]
            Missing required bundle org.eclipse.mylyn.commons.core_[3.8.0,4.0.0).
            reference:file plugins/org.eclipse.mylyn.context.core_3.8.2.v20120916-1200.jar [1370]
            Missing required bundle org.eclipse.mylyn.commons.core_[3.8.0,4.0.0).

            Comment


            • #7
              Hey!

              It looks like it is coming from a missing bundle "org.eclipse.mylyn.commons.core". Do you see a bundle with that name in the list from the "ss" command? If yes, in what state is it?

              In the end, it looks like the installation process somehow corrupted your installation (for unknown reasons). Therefore I guess you will need a fresh install... I would recommend to start with a fresh STS 3.1.0.RELEASE based on Eclipse 3.8 and install extensions into that as needed. I am sorry, but I think that will be the best solution for this problem...

              Cheers,
              -Martin

              Comment


              • #8
                Hey!

                It looks like it is coming from a missing bundle "org.eclipse.mylyn.commons.core". Do you see a bundle with that name in the list from the "ss" command? If yes, in what state is it?

                In the end, it looks like the installation process somehow corrupted your installation (for unknown reasons). Therefore I guess you will need a fresh install... I would recommend to start with a fresh STS 3.1.0.RELEASE based on Eclipse 3.8 and install extensions into that as needed. I am sorry, but I think that will be the best solution for this problem...

                Cheers,
                -Martin

                Comment


                • #9
                  I installed Eclipse Juno, and the problem solved (maybe i did made a bad installation in indigo along the way).

                  After installing STS successefuly on Juno, i opened a new MVC project, fixed the errors in the sample STS project by adding all the required spring jars, and now there are 2 problems:

                  1. I can't get the option: "Run on server" (altough i did set a tomcat's server in the workspace).

                  2. With every step i make (clean, delete etc') i'm getting the follwing error:

                  Errors occurred during the build.
                  Errors running builder 'Faceted Project Validation Builder' on project 'First_STS_Project'.
                  Could not initialize class org.eclipse.jst.j2ee.project.facet.IJ2EEFacetConst ants
                  Errors running builder 'Validation' on project 'First_STS_Project'.
                  org.eclipse.jst.j2ee.project.facet.IJ2EEFacetConst ants

                  This is not a local problem on my specific workspace, because i getting the same error in my second PC as well.

                  Comment


                  • #10
                    Hey!

                    In case you install STS into an existing Eclipse Juno, you should also install the Maven Integration for Eclipse from the Juno repository (maybe along with the m2e-wtp addition that you can get from the Eclipse Marketplace afterwards). The Spring template projects are all using Maven and the integration into Eclipse to work properly.

                    The other thing looks like something from the Webtools project is missing. Did you use Eclipse Juno JEE as base or just the Eclipse Juno SDK?

                    You could avoid all this by using one of our preconfigured downloads for STS from here:
                    http://www.springsource.org/sts

                    Go to "Download" and you can grab a ready-to-use distribution that contains everything you need and works out-of-the-box. The distribution is also based on Eclipse Juno (and I would recommend to use the version that is based on Eclipse 3.8 for best performance and stability). It is a full Eclipse JEE distribution with all the necessary extensions already installed and I would strongly recommend to go this way to avoid all the installation work. It is much easier.

                    HTH,
                    Martin

                    Comment


                    • #11
                      Thanks martin, i downloaded it from: http://www.springsource.org/sts
                      Now everthing is working..

                      Comment


                      • #12
                        Hey!

                        Glad to hear everything is working for you now!!!
                        And thanks for letting us know!

                        Cheers,
                        -Martin

                        Comment

                        Working...
                        X