Announcement Announcement Module
Collapse
No announcement yet.
STS 3.0.0 - It is hanging and not saving any thing Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS 3.0.0 - It is hanging and not saving any thing

    Hi

    I am using STS 3.0.0, today I see problem with STS and it's hanging very often and not saving.
    When I save I am getting the following error intially
    [Save Failed
    Native Library C:\Users\sdhurjet\AppData\Local\Temp\jline_.dll already loaded in another classloader


    I deleted most of the files in ...../Temp directory and tried , the error has not gone but it's hanging most often and when I close the STS I am getting the following information with exit code

    java was started but returned exit code = -805306369
    I changed JDK in STS.ini file and tried but same problem is there. I am attching the file which shows the exit code and configuration. Appreciate any body helps here.

    When I build STS I am getting the following exception.

    Building the workspace has encountered problems
    Errors occurred during the build.
    Errors running builder 'Java Builder' on project 'cmlui'.
    C:\Users\sdhurjet\AppData\Local\Temp\jline_2_0_1.d ll: The process cannot access the file because it is being used by another process


    - Sri
    Last edited by sridhar.dhurjeti; Feb 15th, 2013, 08:52 AM.

  • #2
    Please upgrade to the latest STS and Groovy-Eclipse. We have fixed this jline issue.

    Comment


    • #3
      Thank you, let me try that.

      Comment


      • #4
        Hi Andrew,

        I upgraded to latest STS 3.1 but still the problem is there. Some times more often , I need to restart the STS all the times.
        It is hanging when I try to copy a variable / code snippet in the file.

        Thanks

        Sridhar

        Comment


        • #5
          Hi,

          Even i am facing this issue. I was using STS 2.8.1, when i encountered the issue as suggested I upgraded to STS 3.1.0. But still the issue persists.

          When i restart the STS because of this issue it works fine for sometime, but when the alert appears again i could not even save a file. Later on it hangs.

          Comment


          • #6
            I think you all are hitting a variant of this issue:

            https://issuetracker.springsource.com/browse/STS-2648

            There is an attempt to load the jline library twice.

            Try setting these system properties from inside of your GGTS.ini:

            -Dgrails.console.enable.interactive=false
            -Dgrails.console.enable.terminal=false
            -Djline.terminal=jline.UnsupportedTerminal

            And this one only if you are running 2.0 or later:

            -Dgrails.console.class=grails.build.logging.GrailsE clipseConsole

            Other questions:

            1. Are you hitting this problem when you have another workspace open or a grails app already running?
            2. Are you using projects in your workspace with multiple grails versions?

            Comment

            Working...
            X