Announcement Announcement Module
Collapse
No announcement yet.
Project Grails version (2.1.0) does not match install version (2.2.0) Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Project Grails version (2.1.0) does not match install version (2.2.0)

    In GGTS 3.2.0.M2 I am trying to import a 2.1 Grails project. I am getting this error:
    Project Grails version (2.1.0) does not match install version (2.2.0)

    How do I resolve this?

  • #2
    Hey!

    I am not the expert for the Grails tooling here, but I guess you should be able to download Grails 2.1.x from grails.org (do to the downloads, take a look at the "previous versions" section and select 2.1.3, for example). Once you have that, you should be able to configure that in GGTS as a possible Grails runtime (Preferences -> Groovy -> Grails).

    Hope that works. But I am sure in case I am missing something, my colleagues will add more information.

    Cheers,
    -Martin

    Comment


    • #3
      Martin is right. The Grails import wizard will verify that you have the correct grails runtime, so that it can correctly configure the project on import. There are just too many problems caused by incorrectly configured projects where a project is developed to work with one version of Grails then configured in GGTS to use a different one by accident.

      If a matching install is already available in your workspace the Wizard should automatically select it for you and use that.

      If however a Grails install with the correct version isn't yet configured in the workspace the Wizard has not really any way to configure the project correctly, so it will issue an error message and its up to you to deal with it. Essentially, you can do this by downloading and configuring the correct Grails version as Martin explained.

      The Wizard actually has a clickable 'link' to 'Configure Grails Installations' inside the 'Grails Install' section. This should automatically open the right preferences page for you.

      Kris

      Comment

      Working...
      X