Announcement Announcement Module
No announcement yet.
STS 3.1.0 no Collaboration extensions, like subclipse, available for installation Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS 3.1.0 no Collaboration extensions, like subclipse, available for installation

    On a fresh install of spring-tool-suite-3.1.0.RELEASE-e3.8-win32-x86_64, I do not have any collaboration tools available, such as subversion stuff.

    I did have previous version of STS installed, but deleted it.

    How can I get STS to show me the extensions again?

    Here's what I see:

    Attached Files

  • #2
    I just discovered the error log !! (now I'm making progress --

    I see several entries like the following when I click on the Extensions tab in the dashboard:

    Unknown category ' SourceCodeManagement' referenced by connector '' declared in org.springsource.ide.eclipse.discovery-3.1.0.jar_4962566965887185166.jar

    And before those errors, this is in the log:

    Cannot load bundle org.eclipse.mylyn.discovery-3.6.jar&r=1_1563835255118381814.jar from url error in opening zip file error in opening zip file
    at Method)
    at java.util.jar.JarFile.<init>(
    at java.util.jar.JarFile.<init>(
    at org.eclipse.mylyn.internal.discovery.core.model.Di scoveryRegistryStrategy.processBundle(DiscoveryReg
    at org.eclipse.mylyn.internal.discovery.core.model.Di scoveryRegistryStrategy.processBundles(DiscoveryRe
    at org.eclipse.mylyn.internal.discovery.core.model.Di scoveryRegistryStrategy.onStart(DiscoveryRegistryS
    at org.eclipse.core.internal.registry.ExtensionRegist ry.<init>(
    at org.eclipse.mylyn.internal.discovery.core.model.Re moteBundleDiscoveryStrategy.performDiscovery(Remot
    at org.eclipse.mylyn.internal.discovery.core.model.Co nnectorDiscovery.performDiscovery(ConnectorDiscove
    at org.eclipse.mylyn.internal.discovery.ui.wizards.Di scoveryViewer$
    at org.eclipse.jface.operation.ModalContext$ModalCont
    Does anyone know how to fix that?

    Related to the question above (which I haven't found an answer for), how can I switch from subclipse to subversive as the svn extension?
    Last edited by lili5058; Feb 4th, 2013, 10:57 AM. Reason: just discovered the error.log which contained some useful data.


    • #3

      I tried the URL that is mentioned in the error report, but that seems to work for me. So it could be a temporary problem or a cached version on your local drive got corrupted, I guess. I will ask the Mylyn team for help here, they might know where that cache data is being stored.



      • #4
        This morning Extensions are all there

        Thanks for responding ...

        I just tried out the Extensions this morning and everything is working as expected.
        Did the Mylyn team look into it and find some issue?

        Here's what I see now:

        Attached Files


        • #5

          Glad to hear that it is working again. Looks like it was a temporary network issue... :-)
          Nothing that the Mylyn team needed to fix... :-)