Announcement Announcement Module
Collapse
No announcement yet.
GGTS -3.1.0 - Problem when using JDK7 and Grails 2.2.0 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • GGTS -3.1.0 - Problem when using JDK7 and Grails 2.2.0

    I try to use the GGTS with JDK7 and Grails 2.2.0 (Groovy 2.0 compiler) on a windows7 system.
    My Problem is that when I create a Grails project the project can not be compiled because the ConfigLoader.groovy class in the cache-1.0.1-plugin is causing a problem.

    Description: Internal compiler error: java.lang.UnsupportedClassVersionError: Bad version number in .class file at java.lang.ClassLoader.defineClass1(Native Method)

    Element: ConfigLoader.groovy

    Folder: .link_to_grails_plugins/cache-1.0.1/src/groovy/grails/plugin/cache

    Any ideas how i can solve this problem without changing the JDK and/or Grails version ?

    Regards
    Ivan

  • #2
    Hi Ivan,

    Sounds like some part of your setup isn't running with Java7. Not sure which pieces you are configuring but I could imagine it isn't enough just to configure a Java7 JRE inside GGTS but you must also launch GGTS using a 1.7 JDK? How are you utilising Java7?

    cheers
    Andy

    Comment


    • #3
      Hi Andy,

      thanks you for the hint. The case was exactly that the JDK the GGTS was started with was a JDK6 and not a JDK7 like used in the project. So my compile error is gone. Now I face another one - the app cant be stared with the run-app command from inside the GGTS. From command line everything ok. The error says :

      Error opening zip file or JAR manifest missing : null
      Error occurred during initialization of VM
      agent library failed to init: instrument

      After a research I found the anwsers to make it run at https://issuetracker.springsource.com/browse/STS-3128

      cheers
      Ivan
      Last edited by Papfoo; Jan 12th, 2013, 06:51 AM.

      Comment

      Working...
      X