Announcement Announcement Module
Collapse
No announcement yet.
STS Tookit install on Eclipse 4.3.0 Stable Build: 4.3M4. Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS Tookit install on Eclipse 4.3.0 Stable Build: 4.3M4.

    Hi

    Because of the numerous performance issues with Juno 4.2 which have reportedly been fixed in 4.3M4, I decided to download the stable JEE version of eclipse. However I am having problems with installing the STS 3.0.0 from the eclipse marketplace.

    The issue is to do with a dependency on AJDT, and I'm not sure what the problem is. I've tried downloading the latest versions from the ajdt eclipse site but this also causes errors as shown in (2).

    Is there a development build that is currently built again 4.3.0 (for me STS base on 4.2.0 isn't usable because of the performance issues) ?

    Logs:

    1) From the eclipse update
    Cannot complete the install because of a conflicting dependency.
    Software being installed: Spring IDE AJDT Integration (optional) 3.1.0.201210040510-RELEASE (org.springframework.ide.eclipse.ajdt.feature.feat ure.group 3.1.0.201210040510-RELEASE)
    Only one of the following can be installed at once:
    Java Development Tools Core 3.8.2.xx-20120921-2000-e42RELEASE (org.eclipse.jdt.core 3.8.2.xx-20120921-2000-e42RELEASE)
    Java Development Tools Core 3.7.3.v20120119-1537 (org.eclipse.jdt.core 3.7.3.v20120119-1537)
    Java Development Tools Core 3.7.0.v_B61 (org.eclipse.jdt.core 3.7.0.v_B61)
    Java Development Tools Core 3.7.1.v_B76_R37x (org.eclipse.jdt.core 3.7.1.v_B76_R37x)
    Object Teams Development Tooling Core 3.7.3.v_OTDT_r202_201202051448 (org.eclipse.jdt.core 3.7.3.v_OTDT_r202_201202051448)
    Object Teams Development Tooling Core 3.7.0.v_OTDT_r200_201106070730 (org.eclipse.jdt.core 3.7.0.v_OTDT_r200_201106070730)
    Object Teams Development Tooling Core 3.9.0.v_OTDT_r220_201212161846 (org.eclipse.jdt.core 3.9.0.v_OTDT_r220_201212161846)
    Java Development Tools Core 3.9.0.v20121208-144805 (org.eclipse.jdt.core 3.9.0.v20121208-144805)
    Object Teams Development Tooling Core 3.7.1.v_OTDT_r201_201109101025 (org.eclipse.jdt.core 3.7.1.v_OTDT_r201_201109101025)
    Cannot satisfy dependency:
    From: AspectJ Development Tools Core 2.2.1.e42x-RELEASE-20120921-1400 (org.eclipse.ajdt.core 2.2.1.e42x-RELEASE-20120921-1400)
    To: bundle org.eclipse.jdt.core [3.6.0,3.9.0)
    Cannot satisfy dependency:
    From: AspectJ Development Tools Core 2.2.2.e42x-20121206-0900 (org.eclipse.ajdt.core 2.2.2.e42x-20121206-0900)
    To: bundle org.eclipse.jdt.core [3.6.0,3.9.0)
    Cannot satisfy dependency:
    From: AspectJ Development Tools UI 2.2.1.e42x-RELEASE-20120921-1400 (org.eclipse.ajdt.ui 2.2.1.e42x-RELEASE-20120921-1400)
    To: bundle org.eclipse.jdt.ui [3.8.0,4.9.0)
    Cannot satisfy dependency:
    From: AspectJ Development Tools UI 2.2.2.e42x-20121206-0900 (org.eclipse.ajdt.ui 2.2.2.e42x-20121206-0900)
    To: bundle org.eclipse.jdt.ui [3.8.0,4.9.0)
    Cannot satisfy dependency:
    From: Java Development Tools UI 3.9.0.v20121212-170926 (org.eclipse.jdt.ui 3.9.0.v20121212-170926)
    To: bundle org.eclipse.jdt.core [3.9.0,4.0.0)
    Cannot satisfy dependency:
    From: Spring IDE AJDT Integration (optional) 3.1.0.201210040510-RELEASE (org.springframework.ide.eclipse.ajdt.feature.feat ure.group 3.1.0.201210040510-RELEASE)
    To: org.springframework.ide.eclipse.ajdt.ui.xref [3.1.0.201210040510-RELEASE]
    Cannot satisfy dependency:
    From: Spring IDE AOP Xref UI 3.1.0.201210040510-RELEASE (org.springframework.ide.eclipse.ajdt.ui.xref 3.1.0.201210040510-RELEASE)
    To: package org.eclipse.ajdt.core 0.0.0
    Cannot satisfy dependency:
    From: Spring IDE AOP Xref UI 3.1.0.201210040510-RELEASE (org.springframework.ide.eclipse.ajdt.ui.xref 3.1.0.201210040510-RELEASE)
    To: package org.eclipse.ajdt.internal.ui.editor 0.0.0


    2) Tring to install the latest ajdt code:
    Cannot complete the install because of a conflicting dependency.
    Software being installed: AspectJ Development Tools 2.2.2.e42x-20121206-0900 (org.eclipse.ajdt.feature.group 2.2.2.e42x-20121206-0900)
    Only one of the following can be installed at once:
    Java Development Tools Core 3.8.2.xx-20120921-2000-e42RELEASE (org.eclipse.jdt.core 3.8.2.xx-20120921-2000-e42RELEASE)
    Java Development Tools Core 3.7.3.v20120119-1537 (org.eclipse.jdt.core 3.7.3.v20120119-1537)
    Java Development Tools Core 3.7.0.v_B61 (org.eclipse.jdt.core 3.7.0.v_B61)
    Java Development Tools Core 3.7.1.v_B76_R37x (org.eclipse.jdt.core 3.7.1.v_B76_R37x)
    Object Teams Development Tooling Core 3.7.3.v_OTDT_r202_201202051448 (org.eclipse.jdt.core 3.7.3.v_OTDT_r202_201202051448)
    Object Teams Development Tooling Core 3.7.0.v_OTDT_r200_201106070730 (org.eclipse.jdt.core 3.7.0.v_OTDT_r200_201106070730)
    Object Teams Development Tooling Core 3.9.0.v_OTDT_r220_201212161846 (org.eclipse.jdt.core 3.9.0.v_OTDT_r220_201212161846)
    Java Development Tools Core 3.9.0.v20121208-144805 (org.eclipse.jdt.core 3.9.0.v20121208-144805)
    Object Teams Development Tooling Core 3.7.1.v_OTDT_r201_201109101025 (org.eclipse.jdt.core 3.7.1.v_OTDT_r201_201109101025)
    Cannot satisfy dependency:
    From: AspectJ Development Tools 2.2.2.e42x-20121206-0900 (org.eclipse.ajdt.feature.group 2.2.2.e42x-20121206-0900)
    To: org.eclipse.ajdt.ui [2.2.2.e42x-20121206-0900]
    Cannot satisfy dependency:
    From: AspectJ Development Tools UI 2.2.2.e42x-20121206-0900 (org.eclipse.ajdt.ui 2.2.2.e42x-20121206-0900)
    To: bundle org.eclipse.jdt.core [3.6.0,3.9.0)
    Cannot satisfy dependency:
    From: AspectJ Development Tools UI 2.2.2.e42x-20121206-0900 (org.eclipse.ajdt.ui 2.2.2.e42x-20121206-0900)
    To: bundle org.eclipse.jdt.ui [3.8.0,4.9.0)
    Cannot satisfy dependency:
    From: Java Development Tools UI 3.9.0.v20121212-170926 (org.eclipse.jdt.ui 3.9.0.v20121212-170926)
    To: bundle org.eclipse.jdt.core [3.9.0,4.0.0)

  • #2
    We do not have an AJDT that is available on Eclipse 4.3. We will be releasing 4.3-based AJDT builds in February, and we are targeting a stable build for March.

    Comment


    • #3
      Hey!

      Did you try to download the latest 4.2.2 maintenance builds for Eclipse? Most of the performance fixes are in those builds already and you should be able to use STS with those builds.

      Another option would be to use STS 3.1.0.RELEASE on top of Eclipse 3.8, for which we provide the full distributions that are ready-to-use. Would that be possible?

      HTH,
      Martin

      Comment


      • #4
        4.2.2 Maintenance Build

        Thanks Martin,

        Will give it a try.

        Regards
        Kiren

        Comment

        Working...
        X