Announcement Announcement Module
Collapse
No announcement yet.
STS toolkit not Installing on eclipse Juno (4.2) Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS toolkit not Installing on eclipse Juno (4.2)

    Hi

    While trying to install STS toolkit from eclipse marketplace I get the following error

    An error occurred while collecting items to be installed
    session context wasprofile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phase s.Collect, operand=, action=).
    Unable to read repository at http://download.springsource.com/rel...0920133900.jar.
    Read timed out
    Unable to read repository at http://download.springsource.com/rel...10-RELEASE.jar.
    Read timed out
    Unable to read repository at http://download.springsource.com/rel...10-RELEASE.jar.
    Read timed out
    Unable to read repository at http://download.springsource.com/rel....1.RELEASE.jar.
    Read timed out
    An error occurred while collecting items to be installed
    session context wasprofile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phase s.Collect, operand=, action=).
    Unable to read repository at http://download.springsource.com/rel...0920133900.jar.
    Read timed out
    An error occurred while collecting items to be installed
    session context wasprofile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phase s.Collect, operand=, action=).
    Unable to read repository at http://download.springsource.com/rel...e42RELEASE.jar.
    Read timed out
    Unable to read repository at http://download.springsource.com/rel...0920133900.jar.
    Read timed out
    Unable to read repository at http://download.springsource.com/rel...12-RELEASE.jar.
    Read timed out

    While accesing url through browser i get 403

    <Error>
    <Code>AccessDenied</Code>
    <Message>Access Denied</Message>
    <RequestId>6477EAEC38078D95</RequestId>
    <HostId>
    GZG+X2I4VRUFS0dGwytkyduii+EwI98GGEopoN+RgxKrq4YI/HK7zItrw6niPjYh
    </HostId>
    </Error>


    Can anyone help on this or maintainer can fix the issue of access

  • #2
    Hey!

    We had a problem with our content servers, but that is solved already for a few days. So if you are still facing this issue, it must be something else. Are you behind a proxy? Can you install other plugins from the Marketplace?

    The 403 is correct by design, since the URLs are not meant to be accessible via a browser.

    HTH,
    Martin

    Comment


    • #3
      Hi

      I am able to install other plugins from market place like i have installed m2e , egit. It installed without any problem

      Again I tried I got same error

      An error occurred while collecting items to be installed
      session context wasprofile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phase s.Collect, operand=, action=).
      Unable to read repository at http://download.springsource.com/rel...0920133900.jar.
      Read timed out

      My public ip is 119.82.66.242
      Access time 18:45 IST (GMT +5:30)
      may be this can help in getting some log information

      I am able to see other packages/jar files being downloaded in eclipse but it always stuck on this.

      I you want me to to some debug or any activity please feel free to contact me on list or by mail

      Comment


      • #4
        Hey!

        OK, sounds good so far. Can you shutdown Eclipse, delete the p2/org.eclipse.equinox.p2.repository/cache directory and restart and try again? Maybe there is corrupted data in the repository cache...

        -Martin

        Comment


        • #5
          Hi

          Tried by deleting the cache as mentioned. But still no luck
          session context wasprofile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phase s.Collect, operand=, action=).
          Unable to read repository at http://download.springsource.com/rel...0920133900.jar.
          Read timed out

          As I am thinking there is still problem with amazon cloudfront hope its is not.

          Comment


          • #6
            Hi

            I retried It worked now and all the files were also was being downloaded through browser so from my point it was issue from clodfront

            Comment


            • #7
              Hey!

              Glad to hear it is working now and thanks for letting us know.
              Seems indeed like a strange problem with Amazon CloudFront...

              -Martin

              Comment

              Working...
              X