Announcement Announcement Module
Collapse
No announcement yet.
Required class missing Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Required class missing

    I'm getting a strange problem with STS 3.1 ... I have a project which works fine for a co-worker, but when I load it up on my machine I get the maven error below. I can build the project using Maven from the command line.

    Any advice would be appreciated!


    Code:
    Description	Resource	Path	Location	Type
    Execution default-resources of goal org.apache.maven.plugins:maven-resources-plugin:2.5:resources failed: A required class was missing while executing org.apache.maven.plugins:maven-resources-plugin:2.5:resources: org/codehaus/plexus/util/ReaderFactory
    -----------------------------------------------------
    realm =    plugin>org.apache.maven.plugins:maven-resources-plugin:2.5
    strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy
    urls[0] = file:/C:/Documents%20and%20Settings/a501508/.m2/repository/org/apache/maven/plugins/maven-resources-plugin/2.5/maven-resources-plugin-2.5.jar
    urls[1] = file:/C:/Documents%20and%20Settings/a501508/.m2/repository/org/codehaus/plexus/plexus-utils/1.4.1/plexus-utils-1.4.1.jar
    urls[2] = file:/C:/Documents%20and%20Settings/a501508/.m2/repository/org/apache/maven/reporting/maven-reporting-api/2.0.6/maven-reporting-api-2.0.6.jar
    urls[3] = file:/C:/Documents%20and%20Settings/a501508/.m2/repository/org/apache/maven/doxia/doxia-sink-api/1.0-alpha-7/doxia-sink-api-1.0-alpha-7.jar
    urls[4] = file:/C:/Documents%20and%20Settings/a501508/.m2/repository/commons-cli/commons-cli/1.0/commons-cli-1.0.jar
    urls[5] = file:/C:/Documents%20and%20Settings/a501508/.m2/repository/junit/junit/3.8.1/junit-3.8.1.jar
    urls[6] = file:/C:/Documents%20and%20Settings/a501508/.m2/repository/org/apache/maven/shared/maven-filtering/1.0/maven-filtering-1.0.jar
    urls[7] = file:/C:/Documents%20and%20Settings/a501508/.m2/repository/org/codehaus/plexus/plexus-interpolation/1.13/plexus-interpolation-1.13.jar
    Number of foreign imports: 4
    import: Entry[import org.sonatype.plexus.build.incremental from realm ClassRealm[plexus.core, parent: null]]
    import: Entry[import org.codehaus.plexus.util.Scanner from realm ClassRealm[plexus.core, parent: null]]
    import: Entry[import org.codehaus.plexus.util.AbstractScanner from realm ClassRealm[plexus.core, parent: null]]
    import: Entry[import  from realm ClassRealm[maven.api, parent: null]]
    
    -----------------------------------------------------
     (org.apache.maven.plugins:maven-resources-plugin:2.5:resources:default-resources:process-resources)	pom.xml	/LogManager	line 10	Maven Build Problem

  • #2
    Just a guess, but try deleting your ~/.m2/repository directory. Could have been corrupted. m2e tends to be more susceptible to corruption than maven on the command line.

    Comment

    Working...
    X