Announcement Announcement Module
Collapse
No announcement yet.
GGTS - access maven repository via company proxy Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • GGTS - access maven repository via company proxy

    Hi,

    I am evaluating GGTS to see if I can use it for our new website.
    My problem is that I get stuck in the project creation process due to company proxy.

    Could you please help to see where I should set this information ?

    Code:
    | Loading Grails 2.1.1
    | Configuring classpath.
    | Environment set to development.....
    | Installing zip tomcat-2.1.1.zip.....
    | Installed plugin tomcat-2.1.1
    | Resolving plugin JAR dependencies.....
    | Installing zip cache-1.0.0.zip.....
    | Installed plugin cache-1.0.0
    | Resolving plugin JAR dependencies...
    | Installing zip hibernate-2.1.1.zip.....
    | Installed plugin hibernate-2.1.1
    | Resolving plugin JAR dependencies
    :: problems summary ::
    :::: ERRORS
    	Server access Error: Connection refused: connect url=http://grails.org/plugins/grails-antlr/tags/RELEASE_2_7_6/antlr-2.7.6.pom
    
    	Server access Error: Connection refused: connect url=http://grails.org/plugins/grails-antlr/tags/RELEASE_2_7_6/grails-antlr-2.7.6.jar
    
    	Server access Error: Connection refused: connect url=http://repo.grails.org/grails/core/antlr/antlr/2.7.6/antlr-2.7.6.pom
    
    	Server access Error: Connection refused: connect url=http://repo.grails.org/grails/core/antlr/antlr/2.7.6/antlr-2.7.6.jar
    
    	Server access Error: Connection refused: connect url=http://repo1.maven.org/maven2/antlr/antlr/2.7.6/antlr-2.7.6.pom
    
    	Server access Error: Connection refused: connect url=http://repo1.maven.org/maven2/antlr/antlr/2.7.6/antlr-2.7.6.jar
    
    | Error Failed to install plugin [hibernate-2.1.1]. Plugin has missing JAR dependencies.
    | Resolving plugin JAR dependencies...

  • #2
    Make sure to add correct proxies at:

    Preferences -> General -> Network Connections

    Also, for grails, you should use the grails add-proxy and set-proxy commands

    http://grails.org/doc/latest/ref/Com...add-proxy.html
    http://grails.org/doc/latest/ref/Com...set-proxy.html

    Comment


    • #3
      Hi Andrew,

      I did already set the following and it still not working:
      Http Native is unchecked
      Http Manual is checked with host/post set as in IE/Firefox (Auth = No).

      Also, I'm really new to all this and not sure how to run the grails command line from tools suite.

      Thanks for your help

      Comment


      • #4
        You have two options for running add/set-proxy:

        1. Open up a terminal, cd to your project directory and run grails add-proxy (must make sure that the grails command is on your path)
        2. Open up the grails perspective, click on Navigate -> Open Grails Prompt

        Comment


        • #5
          Working fine. Thanks a lot.

          Comment

          Working...
          X