Announcement Announcement Module
Collapse
No announcement yet.
User Agent Analysis POSTing to localhost? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • User Agent Analysis POSTing to localhost?

    Why does STS's UAA (User Analysis Agent) POST to http://localhost:8000?

    When I launch a server on port 8000 it periodically receives a POST http://uaa.springsource.org HTTP/1.1 request

  • #2
    Hey!

    So you are receiving posts to the domain "uaa.springsource.org" for your locally running server on port 8000? This sounds a bit like a network configuration issue. What happens if you do a ping on uaa.springsource.org? Does it talk to localhost as well?

    -Martin

    Comment


    • #3
      Code:
      $ ping uaa.springsource.org
      PING s3-1-w.amazonaws.com (72.21.211.188): 56 data bytes
      I went to Preferences, searched for "proxy" and found the following:
      https://www.evernote.com/shard/s9/sh...mall&width=832
      There is a proxy entry for http://localhost:8000/ (which I don't remember setting up) but it's disabled.

      Comment


      • #4
        Hey!

        That proxy setting looks suspicious. The UAA integration tries to use those proxy configs, but it should not in case it is not active. What happens when you delete that entry?

        -Martin

        Comment


        • #5
          Since I opened that Preferences page the strange behavior stopped, even without changing anything. It seems that part of the preferences were corrupted/inconsistent but it's working fine now. I'll report back it the problem returns.

          Comment


          • #6
            Hey!

            Good to know its working again and thanks for letting us know. Let me know if it stops working again and we will try to find a solution then again.

            Thanks,
            Martin

            Comment

            Working...
            X