Announcement Announcement Module
Collapse
No announcement yet.
STS 3.1 problems with maven on fresh install Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS 3.1 problems with maven on fresh install

    I have maven problems after fresh installation of STS 3.1
    On any maven command, it breaks like this:

    Errors occurred during the build.
    Errors running builder 'Maven Project Builder' on project 'test-mvc'.
    Could not calculate build plan: Plugin org.apache.maven.plugins:maven-resources-plugin:2.5 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-resources-plugin:jar:2.5

    In "Problems" I see:

    Failure to transfer org.apache.maven.plugins:maven-resources-pluginom:2.5 from http://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced. Original error: Could not transfer artifact org.apache.maven.plugins:maven-resources-pluginom:2.5 from/to central (http://repo.maven.apache.org/maven2): connection timed out to http://repo.maven.apache.org/maven2/...plugin-2.5.pom pom.xml /test-mvc line 1 Maven Configuration Problem


    The exact same projects work on STS 2.9 - I run them side by side; and from command line.

    Seems to be some connection problem, local to STS 3.1
    Just reinstalled STS and it is still the issue.
    Any clue?

  • #2
    Hey!

    I guess you are behind a proxy. Maven needs your proxy configured in the Maven settings.xml file of the local maven repo that you are using, but since you said that Maven works from the command line and within STS 2.9, this doesn't sound like to be the reason in your case. Maybe you configured a different local Maven repo for the Maven integration for Eclipse? Can you take a look at the Maven preferences inside Eclipse?

    HTH,
    Martin

    Comment


    • #3
      Proxy is not the problem this time (I am aware of it but I'm not behind the proxy right now).

      Same local repo: /Users/myname/.m2

      Same behavior on embedded mvn or the one installed with STS.

      I suspect that mvn doen't get connected to maven repo when inside STS, for some reasons.
      I see n "problems":

      Failure to transfer org.apache.maven.plugins:maven-resources-pluginom:2.5 from http://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced. Original error: Could not transfer artifact org.apache.maven.plugins:maven-resources-pluginom:2.5 from/to central (http://repo.maven.apache.org/maven2): connection timed out to http://repo.maven.apache.org/maven2/...plugin-2.5.pom pom.xml /test-mvc line 1 Maven Configuration Problem

      Connection from internal STS browser to the same URIL is ok.
      Maven console output (inside STS 3.0):
      org.apache.maven.plugins:maven-resources-plugin:jar:2.5 is missing, no dependency information available
      The plugin is in place in maven repo:
      /Users/dzimine/.m2/repository/org/apache/maven/plugins/maven-resources-plugin/2.5

      Comment


      • #4
        Problem solved (Thanks Martin and Andrew) - by dumping local maven repository ~/.m2/repository and forcing maven to re-download all dependencies.

        Comment


        • #5
          Originally posted by dzimine View Post
          Problem solved (Thanks Martin and Andrew) - by dumping local maven repository ~/.m2/repository and forcing maven to re-download all dependencies.

          Hi All,
          I am new to STS, I tried installing "spring-tool-suite-3.2.0.RELEASE-e4.2.2" on Windows 7 , When I create a spring Template project I am facing maven-resources-plugin:2.5 problem can anyone please help.

          I have tried deleting .lastupdatedfiles from maven repository and updating the project still facing the same issue. I am not behind any proxy.

          Can anyone please help as I m struggling since long time.. Thanks in advance..
          ------------------------------------------------------------------------
          Errors occurred during the build.
          Errors running builder 'Maven Project Builder' on project 'MyTest'.
          Could not calculate build plan: Plugin org.apache.maven.plugins:maven-resources-plugin:2.5 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-resources-plugin:jar:2.5
          Plugin org.apache.maven.plugins:maven-resources-plugin:2.5 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-resources-plugin:jar:2.5
          Could not calculate build plan: Plugin org.apache.maven.plugins:maven-resources-plugin:2.5 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-resources-plugin:jar:2.5
          Plugin org.apache.maven.plugins:maven-resources-plugin:2.5 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-resources-plugin:jar:2.5
          --------------------------------------------------------

          Comment


          • #6
            Hey!

            Did you try to delete the complete local Maven repo under .m2/repository?
            (in addition to what Andrew recommended on the other thread with the same question)

            HTH,
            -Martin

            Comment

            Working...
            X