Announcement Announcement Module
No announcement yet.
FileNotFoundException for Config.groovy on GGTS 3.1.0 in Fedora 17 Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • FileNotFoundException for Config.groovy on GGTS 3.1.0 in Fedora 17

    hi all,

    I'm having an issue using GGTS 3.1.0 in Fedora getting a FileNotFoundException for Config.groovy, and was hoping someone here might have some advice.

    I'm on 64 bit Fedora 17, using Sun jdk 1.7 u9, JAVA_HOME set, 64 bit GGTS 3.1.0 Release installed under my home directory. I've imported a grails project into my workspace dir, it uses grails 1.3.7 which is also installed under my home directory, and groovy compiler 1.7. I can compile the project using "grails compile" from the command line without errors, but in GGTS I get a few "groovy:unable to resolve class" errors, with the following error from the console where I start GGTS: ./grails-app/conf/Config.groovy (No such file or directory)
    grails-app/conf/Config.groovy does exist, from the project root directory, and is readable.

    This seems similar to STS-1636, but I tried the 4 step solution outlined there by Kris without success. I've also tried cleaning the project, refreshing grails dependencies, building outside GGTS and refreshing without success. I have 64 bit GGTS 3.1.0 Release installed on Windows 7 64-bit and can import the same project there without errors, but would prefer to develop from linux, preferably Fedora.

    Does anyone have any suggestions how to fix this issue?