Announcement Announcement Module
Collapse
No announcement yet.
vfabric-tc-server-developer-2.7.2.RELEASE configuration problem Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • vfabric-tc-server-developer-2.7.2.RELEASE configuration problem

    After installing STS 3.1.0 under users\me\ of windows Vista (BTW, I just learn the installation location to save myself from the Windows write access right restriction troubles), I run into a problem on the final step:
    Could not load the Tomcat server configuration at C:\Users\me\springsource\vfabric-tc-server-developer-2.7.2.RELEASE\conf. The configuration may be corrupt or incomplete.
    And the message in the detail field is the following:
    C:\Users\me\springsource\vfabric-tc-server-developer-2.7.2.RELEASE\conf\catalina.policy (The system cannot find the path specified)
    I can't see the conf directory there. The installation process seems to be find to me. There wasn't any errors. I, however, do see a conf directory under a tc Server instance directory. So, something is not right here.

    How to solve this problem?

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    Updated:

    I copy the conf directory one level up and create another tc server instance. The problem is solved. Something in STS needs to be fixed though.
    Last edited by vw729; Oct 16th, 2012, 08:27 PM.

  • #2
    Hey!

    Thanks for the report and the update. Can you describe in more detail what you did exactly to hit this problem? When I am downloading and installing STS, there is no instance being created. When I then startup STS for the first time with an empty workspace, it successfully creates an instance. Therefore I wonder what you did differently here. So it would be great to get some more details.

    Thanks,
    Martin

    Comment


    • #3
      Hi Martin,

      Thanks for your quick response.

      As I have mentioned, I needed to re-install STS under my user directory instead of directly under the C driver to work around the write access restriction. In my work bench, there was a server configuration. I needed to delete the server configuration due to the location change. The problem occurred when I added a new server afterward.

      Comment


      • #4
        Hi vw729,

        Is this reproducible? Are you still able to create a corrupted server def if you don't "copy the conf directory one level up"? Or was it just one-shot deal? Can you double check your Server Runtime Env is in a good shape?

        Cheers,
        Tomasz

        Comment


        • #5
          I haven't re-installed STS again yet. So, I can't answer your question on whether it is reproducible or not. I run into an application publishing problem. For every single application I published on either TC or tc server, I always get the 404 error for http://localhost:8080/spring-social-showcase/ or so. If I just type "mvn tomcat:run", the application can be up. Something is not right. I can't find TC log files as what I could do before for the old version of TC to locate the problem. It seems to me that I need to re-install STS again.

          Comment


          • #6
            Is there anything related in the Error Log view while publishing an app? Anything suspicious in the Console? Is the Server you publishing to indicated as Started, Sync'ed etc on the Servers view?

            Cheers,
            Tomasz

            Comment


            • #7
              Also I hit this problem just now.
              I made a fresh installation of STS 3.1.0 (Juno 4.2), opened a new workspace and tried the auto-config (Prefrences -> SpringSource).
              I could recover and old conf from the old installation.
              I hope this can help the dev team.

              Regards,
              Stefano

              Comment

              Working...
              X