Announcement Announcement Module
Collapse
No announcement yet.
Error updating STS Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error updating STS

    Hello,

    I'm trying to install update to my STS 2.9.1.RELEASE and getting the error. The file STS downloads indeed is missing the closing tag.

    Code:
    Unable to read repository at file:/C:/springsource/sts-2.8.1.RELEASE/p2/org.eclipse.equinox.p2.repository/cache/compositeContent-87448873.xml
    The element type "property" must be terminated by the matching end-tag "</property>".

  • #2
    Hey!

    Two things here: It looks like the cached p2 data got corrupted. The easiest way to solve this is to just delete the content of the p2/org.eclipse.equinox.p2.repository/cache directory. That should solve the problem you are mentioning.

    The second thing is: you cannot update from 2.9.1.RELEASE to any of the latest 3.0.0 or 3.1.0 versions of STS via the update mechanism. This is disabled by default and doesn't work if you force it to update those pieces. In case you wanna update STS to 3.x, we recommend to start with a fresh install. Upgrading that will be possible again (so upgrading from 3.0.0 to 3.1.0 or beyond), but the switch to the 3.x versions require a fresh installation of STS. Don't know if you wanted to do that or not, but I thought I should mention that here, just in case... :-)

    HTH,
    Martin

    Comment


    • #3
      Thank for the advice

      Originally posted by Martin Lippert View Post
      Hey!

      Two things here: It looks like the cached p2 data got corrupted. The easiest way to solve this is to just delete the content of the p2/org.eclipse.equinox.p2.repository/cache directory. That should solve the problem you are mentioning.

      The second thing is: you cannot update from 2.9.1.RELEASE to any of the latest 3.0.0 or 3.1.0 versions of STS via the update mechanism. This is disabled by default and doesn't work if you force it to update those pieces. In case you wanna update STS to 3.x, we recommend to start with a fresh install. Upgrading that will be possible again (so upgrading from 3.0.0 to 3.1.0 or beyond), but the switch to the 3.x versions require a fresh installation of STS. Don't know if you wanted to do that or not, but I thought I should mention that here, just in case... :-)

      HTH,
      Martin
      Thank you for the advice, I upgraded and all looks fine.

      -aaron

      Comment


      • #4
        Hey!

        Glad to hear its all working now and thanks for letting us know!!!

        Cheers,
        -Martin

        Comment


        • #5
          Originally posted by Martin Lippert View Post
          "The easiest way to solve this is to just delete the content of the p2/org.eclipse.equinox.p2.repository/cache directory. That should solve the problem you are mentioning."
          I tried this, but the file is replaced by another one with the closing slash missing, even when read only is selected. I cannot see STS in installation details so I cannot see what version I have, uninstall it or deal with it in any other way. The error occurs every time I run update and seems to prevent it from completing.

          Edit:
          Found a solution by unticking Papyrus in Preferences>Install/Update>Available Software Sites,
          or go to http://www.eclipse.org/modeling/mdt/...ates/index.php and change the Papyrus update location to a more appropriate one.
          Last edited by Paulos; Oct 21st, 2012, 10:41 AM. Reason: Displays quotation as statement on http://forum.springsource.org/archive/index.php/t-131091.html

          Comment


          • #6
            Hey!

            Great that you found out which update site caused the problem and thanks for letting us know that it works now.

            Cheers,
            -Martin

            Comment

            Working...
            X