Announcement Announcement Module
Collapse
No announcement yet.
STS&JBOSS TOOL causing issues on indigo Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS&JBOSS TOOL causing issues on indigo

    I am having issues with sts suite and jboss tools on eclipse indigo. I first installed eclipse indigo then i installed jobss tools which went fine then I tried to install sts on top of it and I got following error. i need help please help

    Cannot complete the install because of a conflicting dependency.
    Software being installed: Spring IDE Core (required) 3.1.0.201210040510-RELEASE (org.springframework.ide.eclipse.feature.feature.g roup 3.1.0.201210040510-RELEASE)
    Software currently installed: JBoss Central Community 1.0.1.v20120715-0355-H112-Final (org.jboss.tools.community.central.feature.feature .group 1.0.1.v20120715-0355-H112-Final)
    Only one of the following can be installed at once:
    Mylyn Commons UI 3.8.1.v20120725-0100 (org.eclipse.mylyn.commons.ui 3.8.1.v20120725-0100)
    Mylyn Commons UI 3.6.1.v20110720-0100 (org.eclipse.mylyn.commons.ui 3.6.1.v20110720-0100)
    Mylyn Commons UI 3.8.2.v20120916-1200 (org.eclipse.mylyn.commons.ui 3.8.2.v20120916-1200)
    Mylyn Commons UI 3.8.0.v20120612-0600 (org.eclipse.mylyn.commons.ui 3.8.0.v20120612-0600)
    Mylyn Commons UI 3.6.0.v20110608-1400 (org.eclipse.mylyn.commons.ui 3.6.0.v20110608-1400)
    Cannot satisfy dependency:
    From: JBoss Central 1.0.1.v20120715-0355-H112-Final (org.jboss.tools.central 1.0.1.v20120715-0355-H112-Final)
    To: bundle org.eclipse.mylyn.commons.ui [3.6.0,3.8.0)
    Cannot satisfy dependency:
    From: JBoss Central 1.0.1.v20120715-0355-H112-Final (org.jboss.tools.central.feature.feature.group 1.0.1.v20120715-0355-H112-Final)
    To: org.jboss.tools.central [1.0.1.v20120715-0355-H112-Final]
    Cannot satisfy dependency:
    From: JBoss Central Community 1.0.1.v20120715-0355-H112-Final (org.jboss.tools.community.central.feature.feature .group 1.0.1.v20120715-0355-H112-Final)
    To: org.jboss.tools.central.feature.feature.group 1.0.0.qualifier
    Cannot satisfy dependency:
    From: Spring IDE Configuration Graphical Editing 3.1.0.201210040510-RELEASE (org.springframework.ide.eclipse.config.graph 3.1.0.201210040510-RELEASE)
    To: bundle org.eclipse.mylyn.commons.ui [3.7.0,4.0.0)
    Cannot satisfy dependency:
    From: Spring IDE Core (required) 3.1.0.201210040510-RELEASE (org.springframework.ide.eclipse.feature.feature.g roup 3.1.0.201210040510-RELEASE)
    To: org.springframework.ide.eclipse.config.graph [3.1.0.201210040510-RELEASE]

  • #2
    Hey!

    It looks like the JBoss tools are not yet compatible with the latest Mylyn 3.8 release, which is available from the composite update site that STS/GGTS is using. I would hope that there is a Mylyn 3.8 compatible version of the JBoss tools out soon.

    In the meantime, you should be able to install the STS tooling manually from this update site:
    http://download.springsource.com/rel....RELEASE/e3.7/

    HTH,
    Martin

    Comment


    • #3
      Hi Martin, thanks for replying really appreciate that. I can install STS on indigo no problem. The problem only comes when I have jboss tools installed in indigo and then I tried to install sts tooling on top of that. If I install sts directly on indigo then there is no issue. The problem is I need jboss tooling and sts both installed together inside indigo. This is not happening. can you please suggest if that can be worked out?

      thanks

      Comment


      • #4
        Did you try to install STS from that update site that I mentioned (sp without updating Mylyn at the same time)?

        -Martin

        Comment


        • #5
          i did and i got the same error. i selected everything by default. are you suggesting i should deselect all the mylyn options when i install sts suite inside indigo. here is what i did.i installed indigo then i installed jboss tool then installed sts...it did not work...then i started another eclipse install and only installed sts and that went ok

          Comment

          Working...
          X