Announcement Announcement Module
Collapse
No announcement yet.
GGTS Updates broke my IDE Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • GGTS Updates broke my IDE

    My 3.0.0 GGTS was recently upgraded to 3.1.0RELEASE. The update seemed to be ok and has been running without incident for a few days. This morning I was prompted to install 2 software updates - I recall that one had something to do with CollabNet and the other with JavaHL. After installing the updates and restarting GGTS, running any grails command causes GGTS to crash and close without any kind of error message. Any idea what the trouble is or how to fix it?

  • #2
    The progress bar consistently reaches 35% and displays the message "Setting classpath containers" before the window closes. Sometimes an error message pops up saying "Java was started but returned exit code=1", with a bunch of system properties.

    Comment


    • #3
      ggts error message

      here is the ggts error message:

      Attachment
      Attached Files

      Comment


      • #4
        I found my installation history at Help > About > Installation Details. Looks like the Collabnet Merge Client was updated from 3.0.11 to 3.0.12 and the Subversion JavaHL Native Library Adapter from 1.7.6 to 1.7.7.

        So I uninstalled Collabnet Merge Client - didn't help. Then I discovered I could revert the entire installation. However, the revert procedure fails with this error:

        An error occurred while collecting items to be installed
        session context wasprofile=DefaultProfile, phase=org.eclipse.equinox.internal.p2.engine.phase s.Collect, operand=, action=).
        No repository found containing: osgi.bundle,com.collabnet.subversion.merge,3.0.11
        No repository found containing: org.eclipse.update.feature,com.collabnet.subversio n.merge.feature,3.0.11
        No repository found containing: org.eclipse.update.feature,org.tigris.subversion.c lientadapter.javahl.feature,1.7.6
        No repository found containing: osgi.bundle,org.tigris.subversion.clientadapter.ja vahl.win64,1.7.6

        What's the best way forward here? Is there a way to rescue this installation? Should I re-install GGTS 3.1.0 from scratch? Am I on the right track with blaming these plugin updates for my troubles?

        Comment


        • #5
          restarting with -clean option in GGTS.ini does not help.

          Comment


          • #6
            Looks like I've jumped out of the frying pan, into the fire...

            I removed my GGTS installation, then installed a new 64-bit version of GGTS 3.1.0 RELEASE from the download site. I then installed m2e and subclipse plugins. I also added a Grails 2.1.0 path to my preferences (as the project I am working on is still under 2.1.0).

            Now when I try to start GGTS, the Build workspace task reaches 99%, where it hangs for a minute or so, then the IDE crashes and the window closes. Your suggestions on fixing this will be most gratefully appreciated. :-)

            Comment


            • #7
              Uninstalled GGTS 3.1.0 and re-installed GGTS 3.0.0 and everything seems to be OK again. I'm grateful to be alive...

              Comment


              • #8
                Do you still have the error logs available? Help -> Show view -> Other -> Error log?

                I'd like to know what they say. Perhaps this would help us find out what's going on.

                Comment


                • #9
                  Thanks for your reply, Andrew. I thought a clean uninstall was the best way forward, so I deleted everything. Nice to know where to look for the error logs in future. I also learned how to revert my installation to a previous snapshot - hopefully next time I'll get it right. Now I just have to figure out how to stifle those "updates available" popups as they seem to contain a mixed bag of tricks.

                  Comment

                  Working...
                  X