Announcement Announcement Module
Collapse
No announcement yet.
cannot install Spring Tool Suite (STS) for Eclipse Juno (3.8 + 4.2) 3.1.0.RELEASE Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • cannot install Spring Tool Suite (STS) for Eclipse Juno (3.8 + 4.2) 3.1.0.RELEASE

    hi all!

    I'm getting this error message when trying to install STS via eclipse marketplace:

    Cannot complete the install because one or more required items could not be found.
    Software being installed: Spring IDE Autowire Extension (optional) 3.1.0.201210040510-RELEASE (org.springframework.ide.eclipse.autowire.feature. feature.group 3.1.0.201210040510-RELEASE)
    Missing requirement: Spring IDE Live Beans Graph 3.1.0.201210040510-RELEASE (org.springframework.ide.eclipse.beans.ui.livegrap h 3.1.0.201210040510-RELEASE) requires 'bundle org.eclipse.zest.core [1.0.0,2.0.0)' but it could not be found
    Cannot satisfy dependency:
    From: Spring IDE Autowire Extension (optional) 3.1.0.201210040510-RELEASE (org.springframework.ide.eclipse.autowire.feature. feature.group 3.1.0.201210040510-RELEASE)
    To: org.springframework.ide.eclipse.feature.feature.gr oup 0.0.0
    Cannot satisfy dependency:
    From: Spring IDE Core (required) 3.1.0.201210040510-RELEASE (org.springframework.ide.eclipse.feature.feature.g roup 3.1.0.201210040510-RELEASE)
    To: org.springframework.ide.eclipse.beans.ui.livegraph [3.1.0.201210040510-RELEASE]

    When I'm trying to install it via the update site, I get the same error.

    eclipse version: eclipse jee juno
    java version: 1.7.0_07
    OS: ubuntu12.04.1 desktop 32

    THANKS!
    Last edited by bigyu7; Oct 11th, 2012, 12:56 AM.

  • #2
    Ok, I got it!

    Need to install GEF Using the Eclipse Update Manager. See http://www.eclipse.org/gef/updates/index.php

    Comment


    • #3
      Some of STS's features require GEF. If you have the Eclipse Juno update site enabled when you install STS, the installer should normally be able to pull down the GEF dependency without any prompting. Glad you were able to get this working.

      Comment


      • #4
        Hi
        I am not able installed spring ide in eclipse juno using update side..

        Cannot complete the install because one or more required items could not be found.
        Software being installed: Spring IDE Spring Data Support 3.1.0.201210040510-RELEASE (org.springframework.ide.eclipse.data.feature.feat ure.group 3.1.0.201210040510-RELEASE)
        Missing requirement: Spring IDE Live Beans Graph 3.1.0.201210040510-RELEASE (org.springframework.ide.eclipse.beans.ui.livegrap h 3.1.0.201210040510-RELEASE) requires 'bundle org.eclipse.zest.core [1.0.0,2.0.0)' but it could not be found
        Cannot satisfy dependency:
        From: Spring IDE Spring Data Support 3.1.0.201210040510-RELEASE (org.springframework.ide.eclipse.data.feature.feat ure.group 3.1.0.201210040510-RELEASE)
        To: org.springframework.ide.eclipse.feature.feature.gr oup 0.0.0
        Cannot satisfy dependency:
        From: Spring IDE Core (required) 3.1.0.201210040510-RELEASE (org.springframework.ide.eclipse.feature.feature.g roup 3.1.0.201210040510-RELEASE)
        To: org.springframework.ide.eclipse.beans.ui.livegraph [3.1.0.201210040510-RELEASE]


        Not sure what to do.

        Comment


        • #5
          Originally posted by bigyu7 View Post
          Ok, I got it!

          Need to install GEF Using the Eclipse Update Manager. See http://www.eclipse.org/gef/updates/index.php
          Hey did you try this link, I think just browse this link and get the solution of your problem

          Comment


          • #6
            Gr8 thanks a lot...

            Comment


            • #7
              ldossantos's answer is right.

              I copyed the eclipse to /usr/local/java, and not have write permission, so the installer cannot pull down the GEF dependency.

              When I moved the eclipse directory to my home, the STS installed success.

              Comment

              Working...
              X