Announcement Announcement Module
Collapse
No announcement yet.
GGTS 3.x on JDK7? OS X issue? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • GGTS 3.x on JDK7? OS X issue?

    When trying to start GGTS 3.x (my 3.1 is currently an upgraded 3.0) on OS X with JDK 7 I get the following error
    The JVM shared library "/Library/Java/JavaVirtualMachines/jsk1.7.0_10.jdk" does not contain the JNI_CreateJavaVM symbol.
    In the background (if opened from a Terminal) the application claims:
    /Applications/springsource/ggts-3.0.0.RELEASE/GGTS.app/Contents/MacOS/GGTS ; exit;
    Unable to find any JVMs matching architecture "i386".
    2012-10-09 10:38:40.420 GGTS[9431:707] Error loading /Library/Java/JavaVirtualMachines/jdk1.7.0_10.jdk/Contents/MacOS/libjli.dylib: dlopen(/Library/Java/JavaVirtualMachines/jdk1.7.0_10.jdk/Contents/MacOS/libjli.dylib, 265): no suitable image found. Did find:
    /Library/Java/JavaVirtualMachines/jdk1.7.0_10.jdk/Contents/MacOS/libjli.dylib: mach-o, but wrong architecture
    Is this an OS X specific issue?

    Thanks,
    Gerd

  • #2
    From looking around it seems that can come up when there is a 32bit/64bit mismatch. I presume you are running 64bit vm with 64bit GGTS? Do you have anything installed that might have an incompatible system library? (Like a subclipse that includes a 32bit library)

    I've seen mention of using -d32 passed to eclipse to make it call old libraries in 32bit 'mode' (so, put that on -vmargs).

    Sounds like we might need a jira to make sure we get to the bottom of it.

    Andy
    ---
    Andy Clement
    GGTS Team

    Comment


    • #3
      Unfortunately for MacOS there is only a 64bit JDK7 available ...

      Should I open a Jira issue anyways?

      Comment


      • #4
        Originally posted by ascheman View Post
        Unfortunately for MacOS there is only a 64bit JDK7 available ...

        Should I open a Jira issue anyways?
        Yep, I guess we need an issue. Did you try the -d32 flag to ensure 'old level' libraries are treated as such? (and are you using subclipse?). If you mention that info in any jira you raise, that'll be helpful.

        cheers
        Andy

        Comment


        • #5
          OK, Issue IDE-1262 raised ...

          There is no -d32 flag to JDK7:

          $ JAVA_HOME=/Library/Java/JavaVirtualMachines/jdk1.7.0_10.jdk/Contents/Home java -d32
          Error: This Java instance does not support a 32-bit JVM.

          Comment


          • #6
            I followed up on the JIRA issue....

            Comment

            Working...
            X