Announcement Announcement Module
Collapse
No announcement yet.
GGTS 3.1.0 on Mountain Lion does not allow for more than 1.5 G Heap Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • GGTS 3.1.0 on Mountain Lion does not allow for more than 1.5 G Heap

    Yesterday I upgraded my MBP (16 G RAM) to Mac OS 10.8.2 (Mountain Lion). Today I tried to start GGTS again, but now get the error message

    Error occurred during initialization of VM
    Could not reserve enough space for object heap

    I had set the sizes in GGTS.ini to

    -Xmx2048m
    -XX:MaxPermSize=768m

    which worked perfectly well with OS 10.7.x (Lion) and still works with my parallel Eclipse Indigo (3.7). If I reduce the the heap/permgenspace size to

    -Xmx1536m
    -XX:MaxPermSize=512m

    GGTS is working again. I upgraded from GGTS 3.0.0 to 3.1.0 through the standard upgrade process (Help->CheckForUpdates) today. GGTS will not even write logs to ~/.workspaces/.../.metadata/.log nor to ../../../configuration/xxx.log.

    Any ideas are welcome ... I suspect I will be running out of space sooner or later otherwise. Should I file a bug report?

  • #2
    Hey!

    I haven't seen this myself, but I guess that this is somehow related to the removal of the Java runtime when updating to Mountain Lion and that GGTS is now running with a different JDK/JRE. What version of GGTS (32bit, 64bit) are you using? And what Java version is showing up when you start GGTS (in case it starts with the lower memory settings)?

    -Martin

    Comment


    • #3
      Hi Martin,

      thanks for the fast reply ...

      ... yes, I was forced to reinstall JDK after the ML upgrade but as far as I can see I still have the usual Java VMs under /System/Library/Frameworks/JavaVM.framework/Versions/ and maybe the new/reinstalled version under /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home which is actually a 1.6.0_35 release (64-Bit Server VM (build 20.10-b01-428)).

      This is also the one used by GGTS (if I make it start with Xmx1536m) as well as the one used by Indigo where it runs with Xmx2048m).

      I also was trying to run GGTS with JDK 1.7 but this caused other problems ... so I concentrated on the Java 6 solution.

      Regards,
      Gerd

      Comment


      • #4
        Hey!

        I tried to reproduce the issue, but I am able to start by STS 3.2.0.M1 with JDK6 and JDK7 on OSX 10.8.2 with -Xmx2048m, for example (with big MaxPermSize, too). Both settings start just fine. Maybe there is a confusion going on whether to run the 32bit version of the 64bit version of the JDK6, since the JDK is able to run both. That is at least the only explanation that comes to my head.

        What happens when you execute "java -version" on the command line? Does it show up with the 64bit Server VM? And is there maybe somewhere the "-client" option or something like "-d32" involved in your settings somewhere?

        HTH,
        Martin

        Comment


        • #5
          Sorry, I cannot reproduce the problem anymore since I switched back to MacOS X Lion (10.7.5) for other reasons. The new GGTS 3.2.0 runs well on this system ...

          Comment


          • #6
            Hey!

            Thanks for letting us know and glad to hear its working fine now.

            Cheers,
            -Martin

            Comment

            Working...
            X