Announcement Announcement Module
Collapse
No announcement yet.
STS & GGTS 3.1.0 released Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS & GGTS 3.1.0 released

    Dear Spring Community,

    we are happy to announce the next major release of our Eclipse-based tooling today: The Spring Tool Suite (STS) 3.1.0 and the Groovy/Grails Tool Suite (GGTS) 3.1.0.

    Highlights from this release include:
    • Eclipse Juno SR1 updates (including Mylyn, EGit, m2e, m2e-wtp)
    • Mac distributions now OSX 10.8 Mountain Lion Gatekeeper compatible
    • updated to tc Server 2.7.2
    • new Spring Data Gemfire project templates
    • the new Live Beans Graph feature (experimental)
    • grails import wizard
    • support for mavenized grails projects
    • updated to Groovy 2.0.4 and Grails 2.1.1
    Both tool suites ship on top of the latest Eclipse Juno SR1 from September this year.

    Some of our users reported general performance issues with the new Eclipse Juno 4.2 platform that STS 3.0.0 ships with. Most of these issues seem to be related to the underlying UI platform and its usage from various plugins and extensions. Since our goal is to provide the best possible user experience, we decided to provide two separate distributions for STS 3.1.0: one that is built on top of Eclipse Juno 3.8 and one on top of Eclipse Juno 4.2. People who have trouble using the 4.2-based version should try the 3.8-based distribution instead.

    To download the distributions, please go visit:
    Detailed new and noteworthy notes can be found here: STS/GGTS 3.1.0 New & Noteworthy

    Updates from STS/GGTS 3.0.0 are available through the automatic "Check for Updates" again. Users of STS 2.9.x (or older) should start with a fresh installation of STS/GGTS 3.1.0.

    The next version 3.2.0 is scheduled to arrive in March 2013, shortly after the Eclipse Juno SR2 release. Also watch out for milestone builds of 3.2.0 if you wanna stay up-to-date with the latest developments.

    Enjoy!!!
    The SpringSource tooling team

  • #2
    I need instructions & files for offline installation of the tool suite with groovy extensions. I have sts3.1.0 e4.2 installed but I need to add the groovy extensions to a disconnected/offline computer. I found the following article: http://stackoverflow.com/questions/9...74852#14974852
    but it's links are out-of-date for 3.1. What is the updatesite.zip file link for 3.1 e4.2??

    Comment


    • #3
      Hey!

      The download links for the update site archive are listed on the downloads page:
      http://www.springsource.org/sts (then go to "Download").

      You should be able to use that update site to install the Groovy/Grails tooling into an existing STS.

      In case you don't need any Spring tooling, you could also take a look at the ready-to-use Groovy/Grails Tool Suite distribution, which is also available from that download page. It is the same as STS, but instead of the Spring tooling being installed by default, you get everything you need for Groovy/Grails.

      BTW: the update site archive is the same for STS and GGTS, it contains all the features combined into one update site.
      BTW: Do you need Eclipse 4.2? In case you observe instabilities or performance issues, we still recommend to use the Eclipse-3.8-based distributions in order to get the best performance and stability.

      HTH,
      Martin

      Comment


      • #4
        Thanks, I actually meant to download the GGTS version.

        Comment


        • #5
          Sounds good... :-)
          Glad I could help!

          Cheers,
          -Martin

          Comment

          Working...
          X